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INTRODUCTION

The objective of IT Workshop is to impart basic computer usage and maintenance skills and to introduce
you to a suite of productivity tools that will aid in your day to day activities.

IT workshop works in a learning-by-doing mode. It concentrates more on hands-on experience for the
participants rather theoretical classes. It enables the participant to make the best use of Microsoft Office
Suite in their day-to-day requirements and make use of it to improve the standards in the educational
environment. The IT Workshop prepares the participant to have a hands-on experience in maintaining and
troubleshooting a PC by themselves.

Computer Hardware, Windows & Linux

Hardware comprises all of the physical parts of a computer, as distinguished from the data it contains or
operates on. Software provides instructions for the hardware to accomplish tasks.

Windows is a range of closed source proprietary commercial operating environments for personal
computers and also servers. This range was first introduced by Microsoft in 1985 and eventually has come
to dominate the world of personal computer market. All recent versions of Windows are full-fledged
operating systems.

Linux is a computer operating system. It is among the most famous examples of free software and of open-
source development. Initially, Linux was largely developed and used by individual enthusiasts.

Productivity Tools

Microsoft Office is a suite of productivity programs created by Microsoft and developed for Microsoft
Windows and Apple Macintosh operating systems. In addition to the office applications, it includes
associated servers and Web-based services.

Office is considered to be the de facto standard for productivity programs, and has many features not present
in other suites. However, the reverse is also true, with other programs having capabilities that Office doesn't.

Microsoft Office suite includes Word, Power Point, Excel, Publisher, Outlook in most of its versions.

Internet and World Wide Web

Internet & World Wide Web module introduces the different ways of hooking on to the internet from
home and workplace and effectively usage of the internet. Usage of web browsers, email, newsgroups and
discussion forums would be covered.
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PC Hardware
TASKI1:

Identification of the peripherals of a computer, components in a CPU and its functions. Draw the block
diagram of the CPU along with the configuration of each peripheral.

COMPUTER HARDWARE

Introduction to Computer Hardware:

Hardware is the physical appearance of the devices or tools. It is what which we can touch and feel.
Computer Hardware consists of the Monitor, CPU, Keyboard, Mouse and all other devices connected to the
computer either externally or internally.

A typical computer (personal computer, PC) consists of a desktop or tower case (chassis) and the following
parts:

1. CPU The central processing unit contains the heart of any computer, the processor. The processor is
fitted on to a Mother Board. The Mother Board contains various components, which support the
functioning of a PC.

2. System board/Motherboard which holds the Processor, Random Access Memory and other parts,
and has slots for expansion cards

3. RAM (Random Access Memory)- for program execution and short term data-storage, so the
computer doesn't have to take the time to access the hard drive to find something. More RAM can

AURORAS'S TECHNOLOGICAL AND RESEARCH INSTITUTE
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4. Buses : PCI bus, PCI-E bus, ISA bus (outdated), USB, AGP

5. Power Supply - a case that holds a transformer, voltage control and fan

|.'||.|.|I“1j. .'|'\.'|IIIIll.||I'\.I'.\I"."I'|I.I'|I.

LR .
WL i

6. Storage controllers, of IDE, SCSI or other type, that control hard disk, floppy disk, CD-ROM and
other drives; the controllers sit directly on the motherboard (on-board) or on expansion cards

7. Video display controller that produces the output for the computer display

8. Computer bus controllers (parallel, serial, USB, Fire wire) to connect the computer to external
peripheral devices such as printers or scanners

9. Some type of a removable media writer:
10. CD - the most common type of removable media, cheap but fragile.

CD-ROM, , CD-RVW, CD-R, DVD, DVD-ROM., DVD-RW, DVD-R,

11. Floppy disk
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12. Tape Drive - mainly for backup and long-term storage

13. Internal storage - keeps data inside the computer for later use.

14. Hard disk - for medium-term storage of data.

15. Disk array controller

16. Sound card - translates signals from the system board into analog voltage levels, and has terminals
to plug in speakers.

17. Networking - to connect the computer to the Internet and/or other computers
18. Modem - for dial-up connections

19. Network card - for DSL/Cable internet, and/or connecting to other computers.
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20.0ther peripherals: In addition, hardware can include external components of a computer system.
The following are either standard or very common.

Input , Keyboard, Pointing devices, Mouse, Trackball, Joystick, Game pad —~

Function keys

- ]
4 | ENTER _OR ‘DO IT" KEYS

l;L_t_LE_uL_l_t_u_t_L_L T,
E CLLELELELLL =

l_Li_L_l_i_l_l_i_ L
il_\ B0,

F—
| Appilcation Key | .
Typewriter keys Cursor Numeric
_ control keypad
keys

21.0utput : The ouput devices are:

Printer, Speakers, Monitor, Networking, Modem, Network card

TASK2

COMPUTER ASSEMBLING AND TROUBLE SHOOTING
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How to Build Your Own PC

For many, building a computer is scarier than working on a car. Saving money isn’t the only benefit to
building your own computer. In addition, you will acquire knowledge otherwise required for an upgrade
further down the road. You’ll also get exactly what you want. Before you can sit down at your new
computer desk though, you’ll need to actually build the system. Piecing a computer together may sound like
a tough task, but if you take a couple of precautions, there is nothing to worry about. Most components
include warranties and a toll-free number. If you suspect a particular piece of hardware is causing dissention
in the ranks, don’t hesitate to ask for help.

Before We Begin:

In order to ensure everything goes smoothly, gather a few important tools. A head screwdriver is a must and
needle-nosed pliers are often helpful. Buy quality thermal grease to keep the processor in contact with the
heat sink. If you don’t have an anti-static wrist band, make a conscious effort to touch a ground point every
so often (exposed metal on the case works fine) to keep electrostatic discharge from damaging any of your
components.

Step One: Case Preparation

You need to make sure your case is ready to accept the insides of a computer. After opening the empty case
(usually accomplished by removing two screws on one side), lay the case on its side, so the motherboard can
be dropped into place. If the case includes screws and cables, take those out and set them aside. There
should be a set of copper colored spacers in the bag of screws — we’ll use those to mount the motherboard
above the metal plate on the side of the case. You may need to lay your motherboard down in the case to
determine where the copper spacers are needed, but be extra careful — if you add a spacer that doesn’t
correspond to a mounting hole in the motherboard, you risk a short-circuit.

Next, you’ll want to check the thin, metal plate towards the rear of the case that includes holes for the
PS/2, serial, parallel, and USB ports. If it matches the configuration of your motherboard, you’re set.
If not, you’ll need to remove the plate by sliding it out. Again, be careful; the sides of the plate are
sharp. Once the proper plate is in place, set the case aside for a moment and focus on the
motherboard.
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Step Two: Populate the Motherboard

Working on a motherboard that has already been mounted can get tricky, so it is best to install the processor
and memory before the board is installed in a case. Both the Pentium 4 and Athlon XP plug into a processor
socket with no force, so there should be no reason to apply pressure when installing the processor. First, lift
the arm adjacent to the socket. Then align the processor with the socket according to the pattern of pins on
the socket interface. There is only one way the processor will fit, so again, do not apply pressure while
inserting the chip. Finally, close the arm, securing the processor on the motherboard. Now, using the
thermal grease mentioned previously, apply a thin film over the processor’s core.

The process isn’t nearly as graceful for Athlon XP owners. In fact, be forewarned that the processor
core is sensitive to pressure, so if you feel you may be pushing too hard to affix the heat sink, take a
quick break to re-evaluate your strength, tough guy. There is only one way that a Socket A heat sink
should fit, so be sure that the larger end of the socket aligns with the cut-out section of the heat sink.
One end will clip easily onto the motherboard, while the other will require more persuasive coercion.
In the following picture, I’ve demonstrated a technique for attaching a heat sink. Use a screwdriver to
push down on the clip while pulling outwards with a set of pliers.
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Step Three: Fixing Memories:

: Depending on what type of motherboard you’ve got, there may be
some variation in how memory is installed. Still, there are a few general rules of thumb you’ll want to abide
by. First, don’t immerse the modules in water.

Second, pay close attention to the type of RAM supported by your motherboard. Some boards
support both PC133 and DDR memory, but the majority is constrained to a single standard. If DDR
is your poison of choice, note that the modules will only fit into the 184-pin slots one way. Boards that
support 16-bit RDRAM require that two modules be used at a time. If the board has four slots and
you’ve only got two modules, be sure that the remaining two are terminated with a CRIMM module
(usually included with i850 motherboards). The installation process itself is simple: pull the plastic
clips on each end of the slot, inset the module according to the slot’s keying, and apply equal force to
the entire module until it clicks into place. Repeat, if necessary.

Step Four: Fixing your motherboard

Since the motherboard now houses a processor and memory, it can be installed in the already-been-prepped
case. Line up the mounting holes with the copper spacers and use the included screws to mount the board.
Now that your custom machine is taking shape, it may be a good time to step back for a break. Relax,
meditate, take some pictures, watch Friends, or have a Big Blue Banana.

AURORAS'S TECHNOLOGICAL AND RESEARCH INSTITUTE
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Step Five: Prepare the Cables
Most motherboards include two IDE cables and a floppy drive connector. While the interior of the case is
still clean (thus reasonably accessible), attach the cables to the motherboard. Note that one end of the cable
has two connectors close together — this end attaches to your IDE device of choice, while the other end goes
to the motherboard. Each cable should be marked with a red wire to indicate Pin 1. It is imperative to match
Pin 1 on the cable with Pin 1 on the motherboard and again with Pin 1 on the hard disk drive or CD-ROM.

Conventional IDE cables are fine for the most part, but in the interest of cleanliness, we’ve
developed a soft spot for round cables. Not only do these cables take up less room, but they are also
easier to tuck away, promoting better air flow throughout your case.

Step Six: Install Your Media

With the cables out of the way, you can now install your hard disk drive, CD-ROM drive and floppy disk
drive. First, you’ll want to make sure each drive is designated as a ‘master’ or ‘slave’ drive using the
jumpers on the back of each drive. If you’ve got one hard drive and one CD-ROM, you’ll see the best
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performance from both devices if each is installed onto its own channel. In that case, both drives can be set
as ‘masters.” With the addition of a CD-RW drive, you would want to assign one drive as a ‘master’ and one
as a ‘slave,” leaving the hard drive on its own channel.
Now, you’re ready to add a CD-ROM drive. You may have a metal panel preventing you from inserting the
drive into a 5.25" slot. If so, remove the panel by rocking it back and forth until it comes loose. If your case
uses rails, attach them to the drive and slide it into the chassis. Otherwise, use the included screws to secure
the drive.

The floppy drive can be installed using the same method, only use one of the external 3.5'" inch bays.
Attach the appropriate cable and secure the drive using the same small screws.

Finally, install your hard disk drive in an internal 3.5'"" bay. Many cases sport detachable disk drive
bays that often ease installation, but if we were really looking for the easy way out, we would have
picked up a G4 Cube. Attach the ends of each cable to the corresponding drive. For instance, the end
of the primary IDE cable should run to the hard drive. Similarly, the end of the secondary cable
should go to the secondary ‘master’ drive, while the second connector attaches to the secondary
‘slave.’

Step Seven: In Go the Cards

Expansion cards add capabilities beyond what integrated sound and graphics can do. Additionally, you can
buy cards that add SCSI, USB 2.0, Gigabit networking — even cable television support!

AURORAS'S TECHNOLOGICAL AND RESEARCH INSTITUTE
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Unless your new system is to be used exclusively for business, it’s a safe bet that a new graphics card
will find its way into your AGP slot (the brown one in the middle of the motherboard). Nowadays,
graphics cards are cooled by heat sinks and fans, much like processors. It should come as no surprise,
then, that high-end cards generate lots of heat. When I build a computer, I typically leave the white
PCI slot closest to the video card empty for plenty of air flow. Installing the card itself is a snap —
position the card over the slot and push down gently until it is fully inserted. Use one of the screws
included with the case to secure the card to the chassis. Use the same procedure to install each of your
other cards. If you haven’t yet purchased them, consider an upgraded sound card and network card,
at the least.

>

Step Eight: Connecting the Connectors

In order for your computer to turn on when you hit the power button, you need to connect the switches and
light emitting diodes (LEDs) from your case to the motherboard. The connectors themselves are usually
labeled, but it can be a little harder to locate the pins on the motherboard. Your best source for this data is
the manual included with the board. Once you have the connectors, well, connected, we can move on to the
next step. Don’t worry; we’ll test the lights and switches a little later.Dont forget refer to the motherboard
manual while connecting the connectors

Step Nine: Power supply

We’ve waited a long time for this — simply, I have no desire to play with hardware actively fed by an
electrical socket. I have no desire to look like Carrot Top, so I never add power until I'm done under the
proverbial hood. We’re pretty much done though, so go ahead and connect the large 4-pin power connectors
to the hard disk drive and D—ROM drive. The small 4-pin Molex connector is required for the floppy disk

\

‘ >

-

— - .
=~ _ =
e~

X ® o
-
- ° o
-

< o

drive, SP—

If you’ve got a Pentium 4 processor, not only will you need to connect the ATX power connector, but you’ll
also require a 4-pin 12V auxiliary connector. Athlon XP-compatible motherboards only need power from
the standard ATX connector. At this point, feel free to connect the case’s power supply to a wall socket.

s - Ce
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Step Ten: Check Properly
Before you put the cover back on the case, it would be wise to test the machine. Connect a keyboard and
mouse to the motherboard and a display to the video card. Press the power button and immediately hit the
‘Delete’ key to enter the motherboard’s BIOS. Check the front of the case to ensure both the power and hard
drive lights are functioning (you will probably need disk activity before you can check the hard drive LED).
Eject the CD-ROM tray to check power to the drive. Finally, check the BIOS to make sure the drives are

configured as you originally intended. This, unfortunately, is where we part ways — for tips on configuring
your BIOS, reference your motherboard’s manual.

Hopefully you haven’t electrocuted yourself. I think you’d agree
that building a new computer is a learning experience,
regardless if it’s your first time or fiftieth. There is always
something that can go wrong, and if you build new machines for
long enough, anything and everything will happen. If things
don’t go your way the first time, be patient and troubleshoot the
problem. Always remember to keep manuals of all components
with you while fixing your PC.
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TASK3

Windows XP Installation:

Windows XP (codename Whistler, also known as Windows NT 5.1) is the latest desktop version of the
Microsoft Windows operating system. It was made publicly available on October 25, 2001. Two editions of
Windows XP are most commonly available: Windows XP Home Edition which is targeted at home users
and Windows XP Professional which has additional features such as dual-processor support and the ability
to join a domain, a grouping of centrally managed Windows computers. The letters "XP" originate from the
word "Experience".

TASK4

BIOS SETUP & DISK FORMATTING

BIOS SETUP

What IsBIOS?  BIOS is an acronym for Basic Input Output System.
Why BIOS?

To run any system, there must be default settings so that the system can load those settings when it is
started or restarted. For a computer system the basic I/O settings and boot process details are necessary to
start a system. All these default, predefined settings will be loaded in the BIOS and whenever we start the
system, these settings will be loaded. How to view BIOS?

Whenever we start the system, we can enter into the BIOS Setup Utility by pressing Del Key.
Sometimes an F/ or F§ key has to be instead of DEL key, depending on the type of BIOS.

When we enter in to this utility we get these following menus/services, depending upon our mother board.
Main

In main Menu, we can view the details such as BIOS Version, Processor Type, and Speed, RAM Size and
the system bus speed and memory speed.

We can change the settings like language system time and date. We can even change the hyper threading
facility if the processor supports this technology.
Advanced:

We must be very careful when we change these settings otherwise it may cause our system to malfunction.
Here, we can change the settings of PCI devices, Floppy Drives configuration and chipset, USB peripheral

devices and even monitoring the Hardware.
Security:
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We can set the supervisor password, to restrict unauthorized users to enter the BIOS setup utility.

User password can also be set to restrict the unauthorized persons to boot or use the system.

What is a Password?

How to type a Password?

We can even set the Chassis Intrusion to protect the system devices from removing the components of the
system.

Power:

The power settings protect the system from power failures by configuring the ACPL.

For example, after power failure we can stay off the system or Power on the system or else we can even
make the system to restore its previous state by selecting the appropriate options.

Boot:

What if you forget Password?

DISK FORMATTING:

What is Disk Formatting?

Disk formatting is nothing but creating new tracks and sectors on a magnetic storage device.
Why Disk Formatting?

Every disk must be formatted before the first usage. Because then only we can address each and every
memory unit.

How to Disk Format?

To format the disks we have the following methods.
Fdisk

FDisk is a windows command, throw which we can create partitions on a hard drive so that we can format
each drive and use the same.

AURORAS'S TECHNOLOGICAL AND RESEARCH INSTITUTE
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MAicrosoft Windows 78
Fixed Disk Setup Program
(C)Copuright Microsoft Corp. 1983 — 19798
FDISK Options

Currenlt Fixed dizk drive:s 1

hooze one of the following:

Create DOS pavtitinn awr Logical DOS Deive
Cet actiuwe pawrtition

Doclcte partition ox Logical DOE Drivc
Dizplay partition ainlormation

Enter choice: [11

Format
Format is an external command which will create the actual tracks and sectors on a magnetic drive.

To format a partition we need to use format command.

] .5.
el

C=-WIHDOWS >l ormat -7
Furmalbzs a dizxk Fur wse wilth ME-DOE.

Fﬁ drive: [~U[:1labelll [ Q1 [ F:sizel LB i ~851 L[ C1

F drives: L-sUL:labelll L-Q1 LAT:tracks ~H:isectowrsl]l LAH i 51 LACI
F drive: [~UL:1abelll [~G1 [~11 [~41 L-B &I ~51 L[-C1]
F Awviuve: T01 TA1 T#241 TART TA/R 1 #RT T

#UL=z1label]l Specifies the volume label.
I'exrforms a guick [ormat.
Spevifivy Lhe wice vf Lthe Fluppy dixk Ltu furmal <zuch
as 168, 188, 3Za, 368, 720, 1.2, 1l.44, Z2.88>.
Allocates space on the formatted disk for system files.
S Copies system ftiles to the formatted disk.
sTtracks Specifies the number of tracks per disk zide.
AHzzertnwrs BperifFies the mumhew nf =zertnwrs per twark.
s1 Formats a single side of a floppy disk.
~4 Formats a L.20C—dinch 260K floppy disk in a high—dens ity driva.
~8 Pormatz cight zcctorz porr track.
-G Tezlys vluslters Lhal are currenlly marked ““bad. ™

= WINDOWS = _

Disk Manager

Disk Manager is a tool to manage a magnetic drive, through which we can create the partitions as well as
formatting the particular partitions at a time.

Partition Magic
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Partition Magic is also a tool to do the same thing but it gives its services available in GUI which is more
user friendly.

Red Hat Linux Installation Process:
1. LINUX BOOT OPTIONS

Actually Linux can be installed in two different modes, based on the requirement of the user.
Graphical Mode.
Text Mode.

Graphical Mode - In this you can work with Graphical Interface (i.e., it supports mouse and Icons ). By
clicking the icon with the mouse, you can perform related action.

To install Linux in Graphical Mode Press Enter.

Text Mode - In this mode you have to interact with character based interface ( i.e., Command prompt ).

To install Linux in Text Mode Type : Linux text and Press Enter.

After selecting the mode of installation, it goes on detecting the basic input output devices and file systems.
And at last it displays a screen asking whether to test the CD inserted to install or to Skip the test process.
Otherwise we can test total installation CD’s.

On completion of testing the CD’s, it goes on loading an installation program “ANACONDA” which helps
us in the installation of the remaining part.

2 WELCOME TO INSTALLATION PROCESS

It starts with the display of the welcome screen containing the online help , and four buttons to help
us in the different activities in the installation process.

Hide Help/Show Help - Which helps you in guiding the installation process, which can be activated
or hidden.

Release Notes - Which contain the Basic Hardware Requirements that are necessary for the installation of
the Red Linux 9.0 and some other post-installation issues.

Next - This button allows you to go to next step of the installation process by the current step.

Back - This button allows you to move back of the installation process to make any changes that previously
mentioned.

Action: click “Next” to move to next screen.

3. SELECTING A LANGUAGE
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It displays a screen containing various languages, to select a language you would like to use during this
installation process.

4. CONFIGURING KEYBOARD AND MOUSE

Here we need to select our own keyboard and mouse layouts which will help you to interactively proceed in
the installation process.

At this point of time it displays you the different types of keyboard layouts. So that you can select your
desired one that you would like to use for the system.

And also choose the appropriate Mouse for the system, based on the following:
Do you have a PS/2, USB, Bus or Serial mouse?

Hint:- If the connector your mouse plugs into is Round - It is a PS/2

If the connector your mouse plugs into is Rectangular - It is a USB mouse

If the connector your mouse plugs into is Trapezoidal - It is a Serial mouse

Select the exact mouse type among the available.
5. TYPE OF INSTALLATION:

There are different installation types that are available which will enable you to select that will best meet
your needs.

There are four different types of installations are there —

Personal Desktop

- You select it for personal computers or laptops, select this installation type to install a graphical desktop
environment and create a system ideal for home or desktop use.

Work Station

- This option installs a graphical desktop environment with tools for software development and system
administration.

Server

- If you would like to set up file sharing, print sharing, and web services and additional services.
Custom

- Select this installation type to gain complete control over the installation process,

Including software package selection and authentication preferences.:
6. PARTITIONING THE DISK

Partitioning the disk can be done either automatically or manually.

AUTOMATIC PARTITIONING

— By selecting automatic portioning, you will not have to use partitioning tools to assign mount points,
create partitions, or allocate space for your installation. Automatic partitioning allows you to have some
control concerning what data is removed from your system.

To remove only Linux partitions remove all Linux partitions on this system.
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To remove all partitions on your hard drive, select remove all partitions on this system.

To retain your current data and partitions, assuming you have enough free space available on your
hard disk, select Keep all partitions and use existing free space.

You can review the partitions that are automatically created using the check box Review (and modify if
needed) the partitions created.

MANUAL PARTITIONING

— To partition manually, choose the Disk Druid partitioning Tool. For the manual partitioning of Linux
installation you need assign disk space for the three compulsory file systems, they are /boot, /(root), swap
/boot

- This type of partition should of ext3 file system type. For this /boot partition a minimum of about 150MB
is necessary.

Swap

The swap partition should of swap file system type having a minimum of the double the RAM available on
your system.

(i.e., if, RAM is of 512MB, your swap should be a minimum of 1024MB.)

/(root) —

The symbol ‘/’ stands for the root. This root partition should be a minimum of 5GB. And you can also
increase it based on your availability to increase your system performance.

To add a new partition Just click on the NEW button and select your mount point (i.e., directory of partition
ex: /, /boot, /user, etc., ), select your file system type among the available i.e. Ext3, ext2, swap, vfat, etc., ),
and you have different additional size options like Fixed Size, Fill all space up to(MB), Fill to maximum
allowable size. And also you can make a partition to be primary partition and check for the bad blocks on
each partition.

7. BOOT LOADER CONFIGURATION

The GRUB boot loader will allow you to boot other operating systems. It will allow you to select an
operating system to boot from the list. To add another operating system. You can also add other operating
systems that are not detected automatically.

For greater system security, you can set your password for the boot loader. To avoid unauthorized changes
to the system.

You can also change the type of boot loader other than GRUB, among the available like LILO. And also
you can avoid to install boot loader.
8. NETWORK CONFIGURATION

With this option you can set your Network devices manually or using DHCP (Dynamic Host Configuration
Protocol) which will automatically takes default IP address, and Net mask addresses. The DHCP also set
your Hostname.

9. FIREWALL CONFIGURATION

A firewall configuration is set between yours computer and network. And decides which resources of your
computer are accessible by the remote users on the network. On proper configuration of firewall we can set
different security levels for the system.
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By using firewalls we can avoid any entrusted passage of data and also we can set our own protocol
supports.

10 . ADDITIONAL LANGUAGE SUPPORT

This screen shows different additional languages for installation. These additional languages can be used to
switch after installation process.
11. SELECTING A TIME ZONE

To set our time zone we can do it either by selecting computers physical location or by your time zone’s
offset from Universal Time, Coordinated. This screen shows two tabs namely location and UTC Offset.
First tab offers you the ability to configure by location. Second tab allows to set UTC Offset.

12. ROOT PASSWORD SETTINGS

The Root password is for avoiding any unauthorized access to Administration settings .
13. PERSONAL DESKTOP DEFAULTS

With this screen we can accept the default package list or we can customize the set of packages to be
installed.

14. SELECTION OF PACKAGES TO INSTALL

On selecting the customized set of packages we can select our own selection of desktops, applications,
servers, development tools and system tools to be installed among the available.

And also we have an option to select a minimal set of packages and all the packages that are available which
will install complete set of packages(about 1400) which will require about 4850 MB of space.
15. ABOUT TO INSTALL

This is the final step to make any modifications to the installation process. Once you click the next button
you cannot do any modifications.
16. INSTALLING THE PACKAGES

First it formats the file systems and copies the files to our hard disk to continue installation. Then there starts
the installing of packages which may take up to several minutes of time during which we need to insert next
two CD ROMs to complete the installation process.

17. CREATING A BOOT DISK

Here the prompts you to create a Linux boot disk on your choice for your further requirement.
18. CONFIGURING YOUR DISPLAY

At this stage you need to select your video card type and monitor configuration and also you restore to the
original values.

19. END OF INSTALLATION PROCESS At the end of the installation process it will remove all the media
that is used by the installation. And reboots your system again.

Screenshots
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e d:]:ll.:lu| |r*]3_q. E ".Il.l.::-|

Srnline: Hielp:

-

Authentication
Configuration

ou can skip this section ifyou
will not be setting up natwvork
passwords, If you are unsure,
ask your system adminiswator
for assistance.

Linless wou are setting up an
HIS password, vou will nobce
ihal boih MD3 and shadow are
seloched. Using hoth will reake
WOLN 5y B M a5 SeCUre as
possihble.

+ Enable MD5 Passwords -
allows z long password w0 be
used (up 1o 250 characiers),

* Use Shadow Passwards -
provices a very secure
method of retaining
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[0 ) Enter the oot (administraton) passwerc for e system.

|¢ Bach

Comfigur i

|| Cna.x 2 MOE passwords

[+] Enae shadow pas swvards

_ Erable NS

o 2omair:

WIS Sewer

%5 LDAF Kerberos 5|SME |

] Usa broadcas: to find 12 sena-
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Package Group
Selection

Selectthe package (applicagan)
groups thatyoeu want to install. Ta
salect a package group, click on
thie chich box beside il

Cnce a packays group has breen
selected, click on Detalls o view
which packages will be installed
by default and to add or remove
oplional packages frem that
yroup.

To seeleect incliviclual packayes,
check the Salect Individual

Packages bux al the bollom of the
SCrEEn.

|ﬁllldelle :1| |Ij|'h:-EEEE Watag

orine | e o
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-aclﬂaga SFOUp Se 2t an

Dezkiops
|| X Windew System [31733] Dizfalls

Install this groun of packages ta use the base graphical (21
g USerIperace.

|z GNOME Dezkiop Envirenment [35/35] Dealls

LIk a5 5 praver), g plical usar ) mtafars wich
Ircluczs a panel, casaiog, syst2m lcans, and & crapalcal
fi= mianager

[T KDE Deshiop Envimonment J0iE|

- EDC s a pewedul, graphical vser irmerzoe which | acludes
'3.1.-'! e aden ibon, sesadern i e, arel i yraphie al lile
maragar,

Applicatlons

L1 Ediwers [ov4]
somictiries called tewt editows, these ae peegrimes that
ﬂ;’-’_ alow vau i create gad 201 fles. Thase Include Cmacs anc
oo
M Coyi meering and Scienlilic | 7|

This graus ncludes sackages for sedfoming mathe matlcal
\\:'3 aned sienlilie coenpGalioee aomd plalling, aecaedl e

CHTvRrslar.
" melact indiv dual packages Iertal nstall sizas 1,251

| Dack E} hest |

‘-ackaga SFOUR Se 2t ar

PEEkﬂgE Details for ‘Graphical Intermef’ Jor1e]

[z]

Selection A rn e gemp can e boh Base ol Sl packss mem i, P ;I;cmdﬂ ]
packages are dwavs selectad as larg as the package group is selected. _
Seled ]:Im 53 select the spuoral rackages to be nsalled: _
groups thaty _
select apack Base Packages = e
thi: chiech bo Indexkmn - The webpage vou see after astalling Rad Hat L. .
it (il
optional Packages EMAcs ane
Cnce apacks Jlbalea - Ar ema oo for GHOML :
'-F'l_"-ﬂf‘-fl: clic | vl urlon - GNOMC'S RE-06 18 &1 20 QRIUMVE e 5L 7]
W hl-:h_pa.( ka | galm - A GTI- clone of the ACL Instar essanger ol am. thematical
by '_d'E'?‘“" 0 T paleon - GTI- browser based s Gecko (Mazllla rancar ag argleal, —
optional pach Tl wnumemaeting A S nume based H222 wehecunlenencing apolicadion
yroup. T liy sk ETIF Dedeercd low licas A4 skl
To select ind ] rinillan A Wb e [—
rineillar e b IEE <l nlegrated st Mo, [w |
check he Sa ™! =) =
Packages b« Tatal (nswall stze: 1L,=810 %7 Dheslail
ECMERN. Fat
Sl oK c
H S g_ Wirchnae
CHffic o/ Frod uclivity [3n2] antails ||=
" melact indiv dual pac kages Iertal nstall izas 1,261
|@lllde 1 1€ :1| |Ij|'h:-EEEE Netas A Dack B Mext
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Package Group
Selection

Sulec) the packayge [application)
yroups Lhal you want o install. To
sizloct o packaye yroup, click on
the chezck box beside it

Once a package qraup has heen
selermed, click an Details 1o view
wehich packages will be installed
by delault ane o achl or remove
vplional packayes roem thal
yroup.

To selectindividual packages,
check the Select Individual
Packages hAnx atthe batiam atihe
SCIEER.

|ﬁ Hich- Help |Dﬂ:'h‘.:'.:' P,

.
Coallre e 2

Package Group
Selection

Suledl the package lapplicalion)
yroups Lal vow wanl o imstall. To
select a packaye yroup, click on
the check box beside it

Once a package qraup has heen
selectad, click on Delails 10 view
vihich packages will be installed
by defaull aned o achd or remove
wplbonal packayes from thal
yroup.

To selectindividual packages,
check the Select ndividual
Packages hox arthe battam otthe
SCIEER.

|ﬁ Hih- Help |DE:'H‘-!'.I:' i
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Mackage Group Selectlon

Severs |
C server Coanfiguration Tools [or4]
Q 1his qraup contans al of Had Hal's ©ustom server
= carflguratian Toels.
[ Web Server L=k
ﬁ\ Ihrse tnals allos yaw ta nun a8l senesr an e system.
[~ Mall Server 17
sfn, Theme mackies allirae yooe o conligoee an RS or Poedlin
I mal seneer
L windows Flle Server [wz]
=4 This veckaye youp al o you o shane likes babazen Linus B
(:ﬁ', ) WS Winchms, gy e
L DN5 Hamee Server [wz]
i Th 5 sackage graup al s vau 1o a DS nake sapver
PEIW D0 ar Liee sysbem .
C FIF Senver [v1]
@_:] These wals alow vau ta i an FTF senar on tha swsiem,
[T SO Mabibase Server [3] =l
[ =rl=ek imdie sl packages Boa! irstall sz 1,000
4 Haut |$ b |
Mackage Group Se ectlon
a
Development
[ oescloprment Tools [orda]
ﬁ Ihese toals incluce core cevelopment taos such as
aumamate, gog, par, mahar, ard debuggers.
[ Kvernol Develspmen| |w4)
@ Install thrme packagss ta recompile the ke
[T X Soltware Develop ment LK
|"_ Theme s kasve aillvvae yene 1oy sl apoli atiome. hae (he %
e W e Sy st
L GHOME Software Developraent [or4a]
LI FrS P e pakaves in unler ke develop ETE= el
O E araphic al apnlicalioms
L KDE Software Development [or2 o]
B K7 Insell these packages i develop CT and KDC graphlcal ¢
-"-.-J'L'-" epplicalons.
System
[~ Adrmini=tretsn Toosls [Lika KN
This gracn s a3 oollesbar o qeaphieal semmn stamon mols -
E"_\'. Forthe roardtam  rack ar $or ryanoc ne irer s courie oo el

[ =rleek e Al packages Homa! install sieee 1,000

@ Ak |-i 53
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Package Group
Selection

Select he package Gapplicaion)
yrowps Lhal you veanl Lo inslall, Ta
selerr 2 package graup, click an
the chieck hox heside it

Cnew a packaye group has been
s lecled, dick on Details lo view
which packages will he insialled
hry detawlt and to 2dd or re rove
aptienal packages from that
yroup.

l'o seleer individual packages,
check the Select Individual
Packages box atthe bettorn af the
sern,

|ﬁHHD I-_-:ll|1| ||_=|ﬂdn=|':n horas

orling =&

About to Install

Cautieon: Once you click MexE,
the inslallalion program will begin
wiifimg 112 operating system to fhe
hare] ddives(s). This process cannotl
be undone. IFyou have decided
sl I conlinue wilh his

imstallat on, this is the last point at
which you can salely abor Lhe
imsiallat on procass.

l'a abort this installatien, re mowve
all instal laivn modia, amd press
WoUT Computer's Eeset button or
rese | wsing Comtrol Al Delete,

Fﬂliceu&:

||_"| [=lease hames
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System
[ Administration Taols [mr11]
o e gezson i o el e al geaptecal acmmires e ey
g fur the syuier, soch s far manaying v accoonis arsd
conlivanng wys bem e,
M Syslem Tools 19513]
. Thiz yron iz e colection ol verimes ol s bor Ve spalam,
I-r?'gil siUzh as 1ae Zlizr ko C:Irr-'.‘(ﬂ"ls T SKMEG shares and s
T3 P TO neraok raric.
L] Prindng Suppoert Bri0]  Damals
r_}h Instal thesz 0a s to 2nable the svstem o pintor actas a
L W SE AL
L] Mirilmal
A Amnee T g grnup to et tha minma) possible st of
Oy packages. Usedud fae crevtng seall ecterfresall wess, —
o 4
. for ewant ke
[ Eweryihing [
o This groun incdlues all te pockages weailubia, Mot hal
& ez e s wndiadly e pae vaces thar jos ) Ui wnes in et

Frval skl simes 1 A1CE
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"] arertingwdual packages
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&0 e Inseal

Tk fesn a begin irsmallaran
of Hrd Har Linis.

A cam ot low af the
Asta/latkan can pe tolnd Ik ha f
rronirsTalLlng fle aber
rebaalieg your sys .
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anlrs Help

Installing Packages

e hanues garlhesred all the
infermition nevded o install Rad
Het Limux am the sysicm. | may
take a while winstall everdhing,
depending sn haw rrarmg
packiage s need o he inslalled .

Department of Computer Science and Engineering

rsalirg Packages

Fareage: Jlbc-copymor-2.3.2-10.9

Bl L . S

SLAmA N Srvmok alaanes and Ineale dam toe il

Frsbage Preqrcy: [

TR Mo ees |

REFTIEY | ."d‘.kﬂl,t:-l 5i.:e| Tunel
lulel u e RO T]
Coriplele i} M 00700
Rerigining ] 1M 1.00.00

&= Hed Hat Bluecurve -><:i:

Looking fora n ey 1 U2 000 S
desimap praduct sty sol mon, without

All 1h creerwehelining oo ey ‘ !
Wi b s i Al R Aok here_ E’J

{ e ren e P 50T e e e L ek s e

|@H che Felp | | ]HJ.{I.\:.L- Foidere,

nlrs Felp

Installing Packages

Wies harves garlhesres] all the
infermation nevded o install Red
Heit Limux amthe system. | may
take a while w install everdhing,
depending on haw rrarmg
packsyes need o he inslalled.

|J,.u Bk | R

r=ulirg Packages

Faigage: Q31146
Sl LU, 50 REy s
cuEmE A Tea shamd lbes sy bar thie O GLA Fas e

Factae Prograss: [N
Tatal Pregwess:  [I—

LEFTNEY | F‘:H.lw_r.e:l SL:el Tunel

1alel b1k 1429 W] LR R ]

Coriphaie 422 53 .03 36

REriaining 124 200 1.07.1¢
| Thank You!

—
I.J;) sz ot veould e Dotk Rhis final sorean e
v Thane Yain al the demlopers, deshgrens,
‘ aned eragirwe s 1 Bhe coirenaniby that made
1his mlessd possibia, We caldn'Land
swarilednn o i AR e

|'ﬁH e b | | ) e Rt
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Crine Hep rstall ng Packages
. Fackage db4-devald.ol4-20
Installing Packages Sizer 7,752 KEpms

Summarg: Devel apmert files far the Sekelay 138 vemsian 4 Farang.

‘We have gathered all the
inforreation neaded o install Red | po g Progrese [ —
Hau Linux an the system. Imay T Fegess: TR

Litks an wehnile o inslial | overything,

depending an haw many Slalun | Fak u_.t'-.l HI-‘I:'I I||'u~|
nackages need i he installed. -
Tl S1E k-l | 0173
Complered 506 243 M o115
Hemiairng M LB M [IELEE

2 All-ln-One Office Suite +3

Alare poun Bleas vl e yoned

“"1‘
%}?& CzerMice org 1 saresdihwest, wiond

e Bl ury Processar and presenmatior safare
o P, mz e It possik e

Eizomiiai fo g e Ten Ao aens

|ﬁHldr- Ealp ||_jﬂdn:|':n h.lm:l:| | @ Rack A |
orline Hep rstall ng Packages
Fackage kcegamas-3.14
Installing Packages Slzer 21443 nBytes

Summarg: K asktnng B o onmant - Gamas
‘We have gathered all the
infommation neaded te install Hed [ ackaye Pogress

A I,

Lihz an wehnilez o insbal | everything,

depending an how marny Slalun | Fak l|_.l:".| HI-‘I:'I I||'u~|
nackages need ta he insfalled. -
Tulul 51E 1229 W 0165
Compleed S L6ET W 01524
Hemairing M 1ET W 14143

i Warld-Class Web and E-mail +3

kirrllle
Kieh lincvrear rrland D ereder

‘Faith the Mozilla we s brooser and Ximian Dwohution. connect
arad conmnroridle goes Wi cseer kL ellorlsls

HErTBET PIIT BL, S SN LR TS e T e W

|ti Hide Ealp

|Ljﬂdp==nh.kw= @ Bacw :;-' e |
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vl el Sk MAsk e Srewlan

Eoot Diskette Creation 5]

o b i boctine o lomese oo o Dol e Han Hal L
t systen b a fanmy dsbamre. & boor coskeme Al mas pau
blank diskee imo vour loppy fal paur swsbamn i the sverl vour b sader cunliguralio
drive, and click MexE bo oo s work ng, F v choese oot inorstal a bast nader, anf
‘waur thine-namy' Bool Icace ! €023 rol SLEaT LI,

Tw creale a hool disksle, inserla

5 hiqhly Famom merced Yol SIFaTe & Aot diskere,

i rEs, L wnlde ke T orears 3 ol diskena

A LU T T T T TR I 1 ] [P T

|EH-:P_' Fp | \IWJL‘-'LL' Foudir, | 4 gl | [ T
onlrs Help _ Grapkiral inbedaca (0 CanflgueEen
F—  Ip oz noasss, e v cdea beodwers cen ke agbomiativelly vz, I
G raphical Interface the drtectee setk ags aee ree coreet Far the Basdwa e, seleet the
. | nighl =ellimgs,
{X) Configuration I o |E
[ mvima [

Alihcgh (hes insballalion
proy ram prabos wedebermine
thi be st wideo card foryour

Wl DA SR BE
UWIDNA GRCDCE 2 peneic

systam, you cam chasse (I3  1DIAGEMare 2 GTS Genenc)
analherviles canl iMneeded, | MDA GeMoe 2 WX igenerc)

|[ ] wIDiAGEMoce 256 iaenenc)
Once you have sclected your || UWIDIA Gerawe 3 peneic
wideg card, choose the amaunt || VI DS Cara

il witlenn RAM present an your
tarrl.

MDA GRMDCE 4 MM 1generc)

| Wl DA SR oe DO geradc
fyoudecide that thevalues ||| WIDIAGeMace T g nedc

il have seleced are incarreet, ||| SWIDIA Qdadie < (Jenerc)
use the Restore ariginal (541 WV D& Daadre T3 iganerch
values bution o reurn e the | [ MWIDIA Rhea 123 (genedc)

sugge sted probed scrngs. VI DIA Riva THT Jgarens)

Wau can alsa choose o Skip X ' HVIDIA Rva TRTE t0eredo) L=
Cnnﬂuu rJuD” i|' wou 'Hl?ul'bl Whleo cam RAk 4 W0 2 | Eesioe o3 93 values
rather contigure X ater the

mstall atime oer 1101 31 all

Z mkip ® conligak an

|gH-¢P.'H’.'F| [T [Ty |<-l Buck | e poasl :|
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arline =elp Mo Somlquaion
= nomeral o, he manier com s aolem dalby detes e, 17 b
Monitor CDﬂﬁgU ration hetecbedd mallnge are mul vomacl oo Ui o oo, sehbecl iz dight
S ME.

H |-- we
The installation program will L aredec Maikor

iy aalbernipl Io e becd yawr Unprubed Ml

mon kor ko determine your I+ Laprane
rmachine’s hesldisplay sellings. L&Dl
It the monitor canmot be | A
desle cled, choose he manilor e
that bast matches the madel Lo
allached o this compulsr rom [‘ ——
the monimars listed. :l’ SranieLiy
I &zar
You may alsa e mer the T AoTion SYSTEMS, 196,

Fprizontal and verical I
synchronization ranges for your |

i I+ &dara
meriter, These values can be o,
tound in the dacurmentation tar G L
your displiy, Bu careful when ||| » 20
entering these values: iFyaun || I+ Hus Campntar systems

enter walues thiat Mall vutside the || 0 cTx

capahilities of vour squipmen, b Cangl towh |;

FEM RN el Uamage 1o v
display. Onky erter numbersin
thise felds il the valoes in your |[¢]  Zetical Syae

Hoerantal e (479 453 | kHr

Yy |Hr Heston angiral values

|"EII e Lz n ||_‘||:I.£Ease bES A Qack |E'i' Manr

orline =&l custamiza Graphica CanfiguEran

Customize Graphics
Configuration

Choose the comect colar depth
ad resalution for your X
configuration.

Colar Depth is e number of
Wislimel calers that can b
represernted by & pliece of
Franrcdw are ar s elware,

Screen Reselutlan is the the ) )
nurehar af dets (pixels) onthe Lo Deplh Soreen Moo
e screcn. L Catar S il * T

% ou may alsa be able 10
chanse whether you want i
baot your system inbe a
graphical o rext enviranment
once Hed Hat Linus is installed.
Linless yau have special P € hous = | ayin vps
nmeeds, bootng inta a graphical o & Grashkeal [ Texr

srmuire nrnsl Dsarmilar ioos

|-‘E| Ice L=

PI [i=lzase koES = fack |:E}- - .3;;[ _:
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Congraruatans

Langram abans, the installation 1s comp ete,

Remxa ary (9572l latlan med a jd skames o COHRCKS] used
churirg Lher inslallalinn.

[ o creabac & boot disketta dunrg ths installanen as vawr
armary means of bostng Nad | lar Linu, Inset It before
resualirny yuur reody irslallzg sysem.

o irfnmmannn on Fraks (updates ard hug frees), wse
bt v, edbat.camyeratE,

T inlurmielivn on eolamzlic updal=s iraugh Mec Blel
Helwink, vinil
Frtpe i redlrak.c oy

ror Irfomradon o6 usirg ard cobflgur ng the syseEm, st
L o: Mo, meclbalo cimgcho = ¢
e S, s baalon comg appe el

T reglster the oracuct far suopa, wisit
Fero:oanws, sedbat.camy appssactivares

i b Rl b eebend (b syl

|§-§ = el | |Di.- el R N o

Linux Bash Commands:

Basic Commands:

Before we start, here are some ground rules. Anything that is red means to type it, if you see brackets
<option> it means you will have to make a decision (an option). Don't type the brackets < > for the option!
Look for italic words for they will give a clue of what commands I'm talking about.

Login

The first time you login to Linux you will have to login as root

login:root

Then it will ask you for a password, and again to verify. Now you are in the root account.

What's the root account? Root is where the user has full access to everything on the system. Normally, the

root account is only used when performing system administration tasks which includes shutting down.

d="4.2">
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Exiting, restart, and shutdown

How to shut down
the Linux OS? Type the command

#shutdown -h now

If you which to restart the Linux OS then type
#reboot

If you want to get out of the root account then type

#exit

TASKS

Hardware Troubleshooting:

Basic troubleshooting:

Sometimes things do not work exactly as planned at this point. Sometimes the system will not power on at
all. Sometimes it will power on, but you get no video. Sometimes you will get beep codes. Sometimes you
hear the fans, but the rest of the PC just sits there and does nothing. If things didn't go according to plan,
troubleshoot the system. Walk mentally through the boot process and check all hardware as it goes. Think
like the computer thinks, if you know what I mean. Here is a list of some of the more common problems.

1. The power does not even turn on. This sometimes happens on ATX machines and it usually tracks
down to the fact that the power switch is not properly connected to the motherboard or it is not
connected at all. Find the power switch lead and make sure it is connected to the motherboard, as
described in Step 11. It’s a possibility that simply reversing the lead will do the trick. If this is the
not the case, then make sure the motherboard is not grounded somehow. Make sure that the board is
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not touching the case (this is what the spacers are for). Make sure that none of the screws that hold
the board in place is touching anything metal or any of the electrical pathways on the motherboard.
If you have any doubt on this, you can remove each screw one at a time and place a washer on them.
You do not need to remove the motherboard to do this.

2. The PC boots, but it is giving beep codes. This is actually better than having to track everything
down on your own, because at least the PC is giving you a hint as to what is wrong. You can also use
the PC Mechanic Beep Codes E-book available on the PC Mechanic CD to track it down for other
BIOS versions. Often, these beep codes will not tell you exactly what the problem is, but will point
you at the trouble device. This information will then get you pointed in the correct direction.

3. The fans come on, but you get no video or beeps. Sometimes, this is because some key component
may not be plugged in well or may not be operational. Check the memory modules and the processor
to be sure they are firmly installed. You might want to make sure the processor is actually working.
One way that I have used to see if a processor is working is to remove or unplug the CPU fan and
place your fingers on the CPU to see if it heats up real fast. If it does, its OK and don’t let it run this
way for long. If it remains at room temperature for awhile, then there is no juice going through the
processor and it may need replacing. The keyboard doesn’t seem to work. This one doesn’t happen
too often, but if it does, your two trouble sources will be the keyboard itself or the keyboard
controller on the motherboard. Hope it isn’t the second one.

Software Troubleshooting:

BIOS SETUP & DISK FORMATTING
BIOS SETUP

What Is BIOS?

BIOS is an acronym for Basic Input Qutput System.

Why BIOS?

To run any system, there must be default settings so that the system can load those settings when it is started

or restarted. For a computer system the basic I/O settings and boot process details are necessary to start a
system.
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All these default, predefined settings will be loaded in the BIOS and whenever we start the system, these
settings will be loaded.

How to view BIOS?

Whenever we start the system, we can enter into the BIOS Setup Utility by pressing Del Key. Sometimes an
F1 or F8 key has to be instead of DEL key, depending on the type of BIOS.

When we enter in to this utility we get these following menus/services, depending upon our mother board.

In main Menu, we can view the details such as BIOS Version, Processor Type, and Speed, RAM Size and
the system bus speed and memory speed.

We can change the settings like language system time and date. We can even change the hyper threading
facility if the processor supports this technology.

We must be very careful when we change these settings otherwise it may cause our system to malfunction.

Here, we can change the settings of PCI devices, Floppy Drives configuration and chipset, USB peripheral
devices and even monitoring the Hardware.

Security

We can set the supervisor password, to restrict unauthorized users to enter the BIOS setup utility.
User password can also be set to restrict the unauthorized persons to boot or use the system.
What is a Password?

How to type a Password?

We can even set the Chassis Intrusion to protect the system devices from removing the components of the
system.

Power
The power settings protect the system from power failures by configuring the ACPL.

For example, after power failure we can stay off the system or Power on the system or else we can even
make the system to restore its previous state by selecting the appropriate options.

Boot

Silent boot : If this option is enabled it displays only the OEM logo and in the background POST(Power on
Self Test) completes. If this is disabled, instead of LOGO, we can view POST messages
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Rapid BIOS Boot: By enabling this option it will decrease the time needed to boot the by skipping some
unnecessary tests.

Here, we can also set the boot sequence from the available devices by selecting Boot Device Priority.
We can even view the Hard Drives and any removable devices and attached to the system.
Exit

By selecting the appropriate options we can exit from the BIOS setup like exiting the setup by saving or
discarding the changes or even by loading optimal or default values.

Internet and World Wide Web

TASKI1

Orientation and Connectivity Boot Camp:

To configure TCP/IP settings
1. Open #Network Connections.
2. Click the connection you want to configure, and then, under Network Tasks, click Change settings
of this connection.
3. Do one of the following:

AURORAS'S TECHNOLOGICAL AND RESEARCH INSTITUTE

41




ITWS Lab Department of Computer Science and Engineering

o If the connection is a local area connection, on the General tab, under This connection uses
the following items, click Internet Protocol (TCP/IP), and then click Properties.

o If this is a dial-up, VPN, or incoming connection, click the Networking tab. In This
connection uses the following items, click Internet Protocol (TCP/IP), and then click
Properties.

4. Do one of the following:

o If you want IP settings to be assigned automatically, click Obtain an IP address
automatically, and then click OK.

o If you want to specify an IP address or a DNS server address, do the following:

= Click Use the following IP address, and in IP address, type the IP address.
= Click Use the following DNS server addresses, and in Preferred DNS server and
Alternate DNS server, type the addresses of the primary and secondary DNS
servers.
5. To configure DNS, WINS, and IP Settings, click Advanced.

£Notes

e To open Network Connections, click Start, point to Settings, click Control Panel, and then double-
click Network Connections.
¢ You should use automated IP settings (DHCP) whenever possible, for the following reasons:
o DHCP is enabled by default.
o If your location changes, you do not have to modify your IP settings.
o Automated IP settings are used for all connections, and they eliminate the need to configure
settings such as DNS, WINS, and so on.

To make a local area connection
e If you have a network adapter installed, and have set up a home or small office network, you are
connected to a local area network (LAN). You are also connected to a LAN if your Windows XP
Professional computer is part of a corporate network. When you start your computer, your network
adapter is detected and the local area connection automatically starts. Unlike other types of
connections, the local area connection is created automatically, and you do not have to click the local
area connection in order to start it.

To make an Internet connection

Open ENetwork Connections.

Under Network Tasks, click Create a new connection, and then click Next.

Click Connect to the Internet, and then click Next.

Choose one of the following:

o If you already have an account with an Internet service provider (ISP), click Set up my

connection manually and then click Next.
If you have a CD from an ISP, click Use the CD I got from an ISP and then click Next.
If you do not have an Internet account, click Choose from a list of Internet service
providers (ISPs) and then click Next.

5. From your choice above, click one of the following:

el NS
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#Set up my connection manually

O

If you are connecting to your ISP using a standard 28.8 Kbps, 56 Kbps, or ISDN modem,
click Connect using a dial-up modem, click Next, and follow the instructions in the wizard.
If your DSL or cable modem ISP connection requires a user name and password, click
Connect using a broadband connection that requires a user name and password, click
Next, and then follow the instructions in the wizard.

If your DSL or cable modem ISP connection is always on and does not require you to type a
user name and password, click Connect using a broadband connection that is always on,
click Next, and then click Finish.

#Use the CD I got from an ISP

O

Click Next, and then click Finish. Insert the CD provided by your ISP and follow the
instructions.

#Choose from a list of Internet service providers (ISPs)

To create an Internet account using MSN Explorer, click Get online with MSN, and then
click Finish. Follow the instructions in MSN Explorer.

To choose an ISP, click Select from a list of ISPs, click Finish, and then double-click Refer
me to more Internet service providers. Follow the instructions in the wizard.

TASK2

Web Browsers and Surfing the Web:

*The internet is a network of computer networks worldwide
*The web is a tool used to retrieve information published on the internet
*To navigate the web we use a browser L.E. Internet Explorer, Mozilla Fire Fox ...etc

Internet Addresses

*Each computer on the internet has its own address
*E-mail addresses discussed in e-mail classes
*Each document, essay, image, etc. On the WWW has its own address
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*To find a web document, follow a link or key in a web address (URL)*Highlighted words or text in a
WWW document
*Moves you to a place within same document, or to a web page elsewhere

*An electronic document stored on a web server

*Uses HTML (Hypertext Markup Language)

*May include text, sound, animation, images

*Usually has links to other Web pages or different parts of the same Web site
*Example: http://www.yahoo.comCustomizing the Web Browser

*[LLAN Proxy Settings
*Bookmarks

*Search Toolbars
*Pop-up blockers
*Managing Plug-ins

Proxy Server

*A server that sits between a client application, such as a Web browser, and a real server.

o[t intercepts all requests to the real server to see if it can fulfill the requests itself. If not, it forwards the
request to the real server.

Specifying Proxy Settings in Internet Explorer

*Goto Tools->Internet Options in main menu

*Click on the Connections tab

*Click on Lan Settings button

*Specify the proxy server address and port in the Proxy server section

*If you want to specify different proxies for different servers or you do not want to use proxy servers for
some addresses, click on Advanced

—You can provide different proxy address and ports for different servers

—You can enter addresses for which you do not want to use proxy serversNavigating the Web Using
Internet Explorer

*Moving within a page;

— Page up/down keys

— Up/down arrow keys

— Scroll bar on the right side

—Clicking on hypertext links (may be text, images, URL)
—Using the navigation, location or menu tool

Internet Explorer Toolbar Buttons
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Adding a Favorite

*To add a page to your list of favorite pages

—Go to the page that you want to add to your Favorites list.

—On the Favorites menu, click Add to Favorites.

—Type a new name for the page if you want to.

*To open one of your favorite pages, on the Favorites menu, click the page you want to open.
*As your list of favorite pages grows, you can organize them by moving them into subfolders

Tasks

*Configure Your Browser to access the Internet
*Customize the browser

—Security Settings

—Privacy Settings

—Pop-up Blocking

—Search Toolbar

*Manage Bookmarks

TASK3

Search Engines and Netiquette:

Search Engines

*Software that lets a user specify search terms. The search engine then finds sites that contain those terms.
*Over time a search engine builds a database of searchable terms that can be matched to web sites.
*Examples:

—www.google.com

—www.altavista.com

—www.AskJeeves.com

Query

*Terms entered into a form of a search engine’s web page.

*Not necessarily phrased as a question since words such as “what”, “a”, “is” etc. would be ignored.
*Enter specific keywords.

*Make sure your spelling is correct.

Methods of searching

*Use more than one word.

*Use quotes

*Use boolean queries

*Use + sign or - sign
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eUse * (wild card)
Boolean Query
AND, OR, NOT
*A AND B
—results in sites containing both A and B
*'AORB
—results in sites containing A or B, or both A and B
*A AND NOT B
—results in sites containing A and excludes sites containing both A and B.
Stemming
Some search engines will return results that include variations on the endings of words.
scomputer
ecomputers
ecomputed
Using boolean queries
eshelf AND ice
—results in URLs of pages containing the word “shelf” and the word “ice” (in any order).
eshelf OR ice
—Results in URLs of pages containing the words “shelf” and “ice”, or just the word ‘““shelf” or just the word
“ice”.
ecomputers NOT notebook
—Results in URLs of pages containing the word “computers” but not containing the word “notebook”.
Metasearch Engines
*Performs a search by using more than one search engine to do the search.
—www.metasearch.com
—www.metacrawler.com
—www.dogpile.com
—www.infind.com
White Pages

*Used for finding individuals
—www.bigfoot.com
—www.fourl1l.com
—www.whowhere.com

Types of Links

*Text Hyperlink

eImage Hyperlink

*Mailto Hyperlink — launches a mailer

eIntra-document Link (Internal link) - links to another location within the same page.

To open a web page in a new browser window.
*Right-mouse click on the link of interest and then select “Open in new window”.
*Click on the original browser window on the task bar below in order to continue viewing the original web

page while that page loads.
*This speeds up your search since you can view one page while another is loading. Tasks
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*Write search engines to find the following

—To find pages related to Computer Science or Computer Programming
—Who invented Laser

—To find information about AND & OR gates

—To find information about apple(the fruit, NOT Apple computers)
—To search for word School of IT in jntu.ac.in

Netiquette

"Netiquette" is network etiquette, the do's and don'ts of online communication. Netiquette covers both
common courtesy online and the informal "rules of the road" of cyberspace.

What is Netiquette?

Simply stated, it's network etiquette --
that is, the etiquette of cyberspace.

“Etiquette” means “the forms required by good breeding or
prescribed by authority to be required in social or official life.”

In other words, Netiquette is a set of rules for

behaving properly online.The golden rule: Do unto others as you'd have others do unto you. Imagine how
you'd feel if you were in the other person's shoes. Stand up for yourself, but try not to hurt people's
feelings.Electronic communication lacks the facial expression, gestures and tone of voice to convey your
meaning. It’s easy to misinterpret meaning of words. Would you say it to the person's face?If the answer is
no, rewrite and reread. Repeat the process till you feel sure that you'd feel as comfortable saying these words
to the live person as you do sending them through cyberspace. Remember, when you communicate through
cyberspace your words are written. Chances are they're stored somewhere. They can come back and haunt
you. You don't have to be engaged in criminal activity to want to be careful. Any message you send could
be saved or forwarded by its recipient. You have no control over where it goes.

Standards of behavior may be different in some areas of cyberspace, but they are not lower than in real life.
Be ethical.

If you encounter an ethical dilemma in cyberspace, consult the code you follow in real life.

If you use shareware, pay for it.

Paying for shareware encourages more people to write shareware. The few dollars probably won't mean
much to you, but they benefit all of cyberspace in the long run.

Breaking the law is bad Netiquette.

If you're tempted to do something that's illegal, chances are it's also bad Netiquette. Netiquette varies from
domain to domain. What's perfectly acceptable in one area may be dreadfully rude in another. Netiquette is
different in different places, so it's important to know where you are. Lurk before you leap

When you enter a domain of cyberspace that's new to you, take a look around. Spend a while listening to the
chat or reading the archives. Get a sense of how the people who are already there act. Then go ahead and
participate. Bandwidth is the information-carrying capacity of the wires and channels that connect everyone
in cyberspace. It also refers to the storage capacity of a host system. If you accidentally post the same note
to the same newsgroup five times, you are wasting both time (of the people who check each copy) and
bandwidth (by sending repetitive information over the wires and requiring it to be stored somewhere). You
are not the center of cyberspace. Don’t expect instant responses to all your questions, and don't assume that
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all readers will agree with -- or care about -- your passionate arguments.Ensure your message is worth the
time it takes to open it. Before you copy people on your messages, ask yourself whether
they really need to know. If the answer is no, don't waste their time. If the answer is maybe, think twice
before you hit the send key. Take advantage of your anonymity. You won't be judged by color, weight, age
or dress sense. You will, however, be judged by the quality of your writing. So spelling and grammar do
count.

Know what you're talking about and make sense. Pay attention to the content of your writing. Ensure your
notes are clear and logical.

Be pleasant and polite. Avoid offensive language, and don't be confrontational for the sake of confrontation.
If you must swear, think up creative alternatives

The strength of cyberspace is in its numbers. The Internet itself was founded and grew because academics
wanted to share information. Don't be afraid to share what you know.

If you ask a question and anticipate a lot of answers, it’s customary to request replies by email instead of to
the group. Share the results of your questions with others, so everyone benefits from the experts who took
the time to write to you.

If you’re an expert, or you've researched a topic that you think would be of interest to others, write it up and
post it. Sharing your knowledge is fun. And it makes the world a better place

opinion without holding back any emotion.

Netiquette does not forbid flaming. Flaming is a long-standing network tradition (and Netiquette never
messes with tradition).

Netiquette does forbid the perpetuation of flame wars that can dominate the tone and destroy the
camaraderie of a discussion group.

While flame wars can initially be amusing, they’re an unfair monopolization of bandwidth. Some people in
cyberspace have more power than others. There are wizards in MUDs (multi-user dungeons), experts in
every office, and system administrators in every system.

TASK 4

Cyber hygiene:

Types of Internet Threats

*Viruses

*Network Worms

*Trojans

*Spyware / Adware

*Other Malware

*Other Threats

Viruses

*Main purpose is to spread and infect files

*Attach to a file and replicate when file is executed
*More than 100 000 known viruses exists in the world todayeSeveral hundred new viruses are discovered
every month

Network Worms
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Self-replicating Viruses that reside in the active memory of a computer.*Worms Send themselves out to the
Internet from infected systems. *Either include tiny e-mail server or search for unprotected shared network
drives to unload.

Trojan Programs

*Programs that installs themselves stealthly via Internet & provide access for malicious usesThreats enabled
by (/through) Trojans

—DDos attacks

—Data stealing

—Distributed spam eMails

*Do not replicate

Spyware / Adware

*Cookies — Track you online

*Browser Hijackers — Changes default home page

*Tracking Cookies — Gathers info of web usage

*Trickles — Reinstalls spyware when deleted

*Keyloggers — Records anything you type!

*Data-Mining

eList goes on...

Other Threats

*Phishing

—Confidential information stealing by fraud emails & web sites (author falsified)
—Several millions of Phishing messages have been sent world wide

—Fastest growing threat today

*SPIM

—Instant Messaging SPAM

—Estimated: 4 billion SPIM's during 2004

Diagnosing Infections

*Slow computer, system reboots

*Mouse moves by itself

*Browser goes to unexpected web sites

*Slow internet access

*Endless popup ads

*New desktop toolbars

Diagnosing Infections

*Disabled antivirus scanner or firewall

*Check startup program group regularly for software you didn’t install

*Check Add/Remove programs for software you didn’t install (make a list of installed items on a new
machine and check the list regularly)

Diagnosing Infections

*Check running services monthly

*Check running processes in Task Manager

*Monitor open ports

*Monitor outgoing and incoming connections

Updating

*Few pieces of software are perfect. Many have security flaws that can allow an intruder to take over your
system.

*When the flaws are discovered, the vendor generally fixes them and places patches on their Web sites.
—https://www.Microsoft.com/Security  (Windows, Internet Explorer, Outlook, etc.)
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—http://www/redhat.com/solutions/security/  (Red Hat Linux)
—http://securityresponse.symantec.com/  (Norton Anti-Virus)

*Some vendors provide a tools for Automatic Updates
Anti-Virus Software

*Examples

—Norton Anti-Virus

—Mc Afee Anti-Virus

—AVG Anti-Virus

AntiSpyware Tools

*Only Software tools exist at the moment

*Programs are trying to detect distinctive signs that spyware places on system
*Popular software

—Lavasoft: Ad-Aware SE

—Spybot: Search & Destroy

Firewalls

*Monitor network traffic and Block access by configured rules
*Software Vs. Hardware

Stateful inspection

—Examine the headers & content of each passing network packet

Productive Tools

MS Publisher

MS Publisher:
Microsoft Publisher helps us to create, customize, and publish materials such as newsletters, brochures,

flyers, catalogs, and Web sites. In this module, we will learn create and publish web pages using MS
Publisher.

Inserting and Editing Text Objects

Many of the concepts and techniques that you know from working with a word processor will carry over to
Publisher. One important thing to remember is that all text needs to be in a text box.

e (Creating a Text Box
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Adding Text
Selecting Text

Editing Text
Changing Type Specifications
Cutting, Copying, and Pasting Text

£ Creating a Text Box
A text box is an area that contains text only and can be moved to any part of the publication. Type within a

text box can fill only the area of the text box, not the entire publication. Before typing text, a text box must
be created.

1. From the Objects toolbar, select the Text Box

If the Objects toolbar is not visible, from the View menu, select Toolbars » Objects
2. Move the tool across the screen

The cursor looks like a cross.
3. Place the cursor where the text box should begin

4. To create the text box, click and drag

5. Release the mouse button
A text box with a cursor appears.

> 4 qding Text

Typing large volumes of text in Publisher is not advised. But using Publisher to type headlines, titles,
captions, headers and footers (type which is usually set off with a different style or placement) is easy.

Adding Text: Typing
If you need to type or edit a large amount of text, you may want to use Word.

1. Create a text box

2. Type the text
To see the text better, zoom in by pressing [F9]. To zoom out, press [F9] again.

Adding Text: Paste Special

Text files from Publisher-compatible word processing programs such as Microsoft Word can be placed into
a Publisher document. Text with little or no formatting generally works best. After placing the text into
Publisher you can edit, format and manipulate it using the same methods as you would for text typed
directly into Publisher.
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Pasting text into Publisher that has been copied from another file can be done using the Paste Special
feature. There are various ways that your text can be pasted. Your options when using Paste Special are as
follows:

Option Description

Microsoft Office Word Inserts the copied text from Word and gives you the ability to edit it from
Document Object Publisher using Word.

Unformatted Text Inserts the copied text, removing any existing formatting.

New Table Inserts the copied text as a new Publisher table.

New Text Box Inserts the copied text as a new Publisher text box.

Picture Inserts the copied text as a new Publisher picture frame. You can select
vh\/llg(teeta?i?er you want to use a Windows Metafile or an Enhanced Windows

This text can not be edited.

Inserts the copied text, preserving existing formatting.
Formatted Text

HTML Inserts the copied text as HTML.

When you paste text, Publisher will create the text boxes necessary to accommodate it or will allow you to
create the text boxes. These two options are described here:

Option  Description

Autoflow allows you to place text and have Publisher create the text boxes as needed.
Autoflow  Text will flow automatically into each text box on the page and onto subsequent pages
(added if necessary).

Manual text flow requires you to create the text boxes and add the pages necessary to
accommodate the text you are placing. If you choose to use the manual text flow
option, be sure to have the Connecting Frames toolbar displayed.

To add text using Paste Special:

Manual
Flow

1. Select the text to be copied
2. Copy the selected text
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3. In Publisher, from the Edit menu, select Paste Special...
The Paste Special dialog box appears.

Paszte Special ﬂ m I
Source:  P:hprodhLeaders\ WELC BinderCHS doc | ] I
A Cancel |

{* Paste Microzoft Word Docurnent Object
MHew Table

™ Paste Link Picture M Display s loon
Ficture [Enhanced Metafile)
HTHRL

Result

Inzerts the contents of the clipboard into your

document as a new bext frame.

4. In the As scroll box, select an option
For text that you will want to edit or format, select New Text Frame.

5. Click OK
The text is now pasted.

Adding Text: Inserting a Text File

—

Create a text box
2. From the Insert menu, select Text File...
The Insert Text dialog box appears.

3. Locate and select the desired file

4. Click OK
If the text file is larger than the text box, a confirmation dialog box appears asking you to choose
between auto or manual flow.

Q- Selecting Text

You will select text when you want to change its type specifications, cut or copy it, or delete it. Use the

Select Objects tool by to select text for editing.
If you have problems selecting the first character at the edge of a text block, start with the last
character and drag to the first character.

Q‘ Editing Text

If you make a mistake while typing, you can always go back and fix it. Editing text in Publisher is much like
editing text in a word processor. You have the following options when editing text:
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To insert text, simply type and text will appear at the insertion point
To delete the selected text, press [Delete]

To delete text to the right of the insertion point, press the [Delete] key

To replace the selected text, begin typing.
The selected text will be replaced by the new text that you type.

To change type style, select the appropriate options from the Formatting toolbar.
For more information, see Changing Type Specifications.

To move or duplicate the text, from the Edit menu, select Cut, Copy, or Paste.
For more information, see Cutting, Copying, and Pasting Text.

Create, use, or change a template in Publisher

If you run a typical business, you probably create certain publications — such as newsletters, flyers,
postcards, and gift certificates — over and over again. While each new version is unique, some elements
remain consistent, like your company name and address.

In a monthly newsletter, for example, much of the layout stays the same, but the content of the newsletter
changes for each version.

Woodgrove Bank Monthly

Learn about templates

You can make a template from any publication by saving that publication as a Publisher template file. Any
template that you save to the default template location becomes available in the New Publication task pane.

When you start a new publication by selecting a template, a copy of the template file opens so that the
original template isn't altered by mistake. If you want to make changes to the template itself, you can open a
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copy of the template file, make the changes that you want, and then save it again as a template. You can also
create categories for your templates in order to organize them in the New Publication task pane.

You can save time by designing a master publication that reflects your company brand and identity and then
saving it as a template. Then, each time you want to create a new version, you can use the template and add
only the information that is unique to that version. Using a template for a publication that you regularly
produce not only saves time but also ensures quality and consistency.

There are many ways to create a publication in Publisher. Publisher offers many designs that are like
templates, but with dynamic features that make it easy to change the design, layout, colors, and other
elements. You can:

i Use a Publisher Master Design Set to promote a consistent company identity.
i Use one of the publication wizards to create exactly the type of publication you want, such as a
calendar, newsletter, or postcard.

You can even design a publication by using a design set or publication wizard and then save it as a template.

This article is about how to save a publication as a template and work with template files (.pub) that are
located on your computer.

For more information about how to design a publication to save as a template, read about creating branded
templates for your business from scratch in Publisher.

For information about downloading a template from the Microsoft Office Online Web site, click
Downloading Office Online templates in the See Also section of this article.

Save a publication as a template

You can make a template from any publication by saving that publication as a Publisher template file. You
can also download a template from Microsoft Office Online, make any changes that you want, and save the
file as a template that you can use again.

1. Create or open the publication that you want to use as a template.
2. On the File menu, click Save As.
3. In the Save as type box, click Publisher Template.

The destination folder changes to the default template location (C:\Documents and Settings\user
name\Application Data\Microsoft\Templates, if you haven't changed the location in Microsoft Word).
You need to save your template in this folder if you want it to appear on the right side of the New
Publication task pane.

>

In the File name box, type a name for the template.
S. Click Save.

Use a template to create a publication

This procedure works only if you already created a publication template in Publisher (by choosing
Publisher Template in the Save as type list when you saved the publication) and saved it to the default
template location.
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Note If you save a publication template to a location other than the default template location, it is not
available in the New Publication task pane, and you cannot use it as a template.

1. On the File menu, click New.

2. In the New Publication task pane, under New from a design, click Templates, and then click the
template that you want to use.

3. Add the content that you want, and make any changes that you want in the new version of your
publication.

4. When you want to save this version of the publication, click Save As on the File menu.

5. Save the publication as a regular Publisher file in any location that you want.

Change a template

This procedure works only if you already created a publication template in Publisher and saved it to the
default template location.

Note If you save a publication template to a location other than the default template location, it is not
available in the New Publication task pane, and you cannot use it as a template.

On the File menu, click New.

In the New Publication task pane, under New from a design, click Templates.
In the Preview Gallery, click the template that you want to change.

Make the changes that you want.

On the File menu, click Save.

In the Save as type box, click Publisher Template.

Click the name of the template that you changed.

Click Save.

When you are asked if you want to replace the existing file, click Yes.

XTI E WD =

Organize your templates by using categories

By default, templates that you save to the default templates folder appear in the My Templates category
under Templates in the New Publication task pane.

Mew Publication v

T W T Momalmua Tids

Mew from a design . -

» Publications For Prink
Web Sites and E-mail
Design Sets

Blank, Publications
Templates

FyYyYTYrw

Expense Report Mewsletter

You can organize your templates into additional categories under Templates by adding a value to the
Category property for the template file.

AURORAS'S TECHNOLOGICAL AND RESEARCH INSTITUTE




ITWS Lab Department of Computer Science and Engineering

1. On the File menu, click New.
2. In the New Publication task pane, under New from a design, click Templates, and then click the
template that you want to categorize.

On the File menu, click Properties, and then click the Summary tab.

In the Category box, type the name of the category that you want to create.

Click OK.

On the File menu, click Save.

In the Save as type box, click Publisher Template.

Click the name of the template that you categorized.

When you are asked if you want to replace the existing file, click Yes.

LT AW

Mew Publication v

Fa——

New from a design

» Publications For Prink
Web Sites and E-mail
Design Sets
Elank Publications
Templates
My Templates
Mewsletters

L N A

Mewsletter

Layouts

Layout guides allow you to create a grid of horizontal and/or vertical lines automatically instead of
manually. This can be helpful when creating business cards or note cards.From the Arrange menu, select
Layout Guides...The Layout Guides dialog box appears.
T - ||

Margin Guides | Grid Guides | Baseline Guides I

rZolumn Guides ———————] [ Preview

Columns: [z i’
Spacing: Igz"—ﬂ
rRow Guides ——————
Rows: |2—ﬂ
Spacing: IDz"—i’

I add center guide between
colurmns and rows

(=] 4 I Cancel Help
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1. Select the Grid Guides tab
2. Under the Column Guides section, in the Columns text box, use the nudge buttons to add/delete
columns in the grid

3. Under the Row Guides section, in the Rows text box, use the nudge buttons to add/delete rows in the
grid

4. To display a line between column and row borders, select Add center guide between columns and
rows

5. When done, click OK
The grid is created.

Inserting and Removing Pages

Once you have begun working on a publication, you may decide that the number of pages originally
assigned to the document is either not enough or too many. You can adjust the number of pages, however,
by inserting or removing pages.

e Inserting Pages
e Removing Pages

£ Inserting Pages

Your page insertion options depend on whether you are viewing your publication in Two-Page Spread view
or as individual pages.

Inserting Pages: Individual Pages

1. Place the insertion point in the page before or after where the additional pages will be inserted
2. From the Insert menu, select Page...
The Insert Page dialog box appears.

Inzert Page m |
Mumber of new pages: I

) Before current page

& after current page

Options
% Insert blank pages
) Create one text box on each page

™ Duplicate all objects on page: I
oK I Cancel |
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3. In the Number of new pages text box, type the number of pages to be inserted

4. To insert the pages before the currently displayed page, select Before current page
To insert the pages after the currently displayed page, select After current page

5. Click OK
The pages are inserted.

Inserting Pages: Two-Page Spread

When working with the Two-Page Spread view, you can insert new pages to the left or right of the two-page
spread or between the two pages.

1. Place the insertion point in the page before or after where the additional pages will be inserted
2. From the Insert menu, select Page...

The Insert Page dialog box appears.

Inzert Page m |
Murmber of new pages: |2

" Before left page
%) after right page

" Between pages

Options
% Insert blank pages

£ Create one text box on each page

) puplicate all objects on page: I

Ok I Cancel |

3. In the Number of new pages text box, type the number of pages to be inserted
4. To insert the pages before the left page, select Before left page

To insert the pages after the right page, select After right page
To insert the pages between the left and right pages, select Between pages

5. Click OK
The pages are inserted.

ﬁ’_!h Removing Pages

Your page removal options depend on whether you are viewing your publication in Two-Page Spread view
or as individual pages.

Removing Pages: Individual Pages

1. Place the insertion point in the page to be removed
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2. From the Edit menu, select Delete Page...

The page is removed.

Removing Pages: Two-Page Spread

1.

Place the insertion point in the page(s) to be removed
From the Edit menu, select Delete Page...
The Delete Page dialog box appears.

Delete Page m |

Delete

{¥ Both pages
{7 Left page only
= Right page only

| a4 I Cancel

To delete both displayed pages, select Both pages
To delete only one of the displayed pages, select Left page only or Right page only
The page(s) are removed.

Create a hyperlink

In Microsoft Office Publisher 2003, you can create hyperlinks to files, Web pages, e-mail addresses, and
other pages in a Web publication by using the Insert Hyperlink button on the Standard toolbar.

You can also create a hyperlink to a specific location on a Web page (sometimes called inserting a
bookmark) by using HTML code fragments. To learn more about this procedure, see the topics listed in the
See Also section, which is visible when you are connected to the Internet.

To follow a hyperlink after you insert it, hold down CTRL while you click the linked text or picture.

+ Create a hyperlink to a file

s

5.

Select either text or a picture.

On the Standard toolbar, click Insert Hyperlink .
Under Link to, click Existing File or Web Page.
Do one of the following:
To select a file from your My Documents folder, click Current Folder.
To select a file that you were recently working in, click Recent Files.
Browse to and select the file or page that you want.

+ Create a hyperlink to a Web page

1.

In your Web browser, browse to the Web page that you want to link to.
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Select the URL of the Web page, and then press CTRL+C to copy it.
In Publisher, select either text or a picture.

On the Standard toolbar, click Insert Hyperlink .
Under Link to, click Existing File or Web Page.
Click in the Address box, and then press CTRL+V to paste the URL.

Sk v

Note If you recently visited the Web page that you want to link to, you can start with step 3. In the Insert
Hyperlink dialog box, click Browsed Pages. In the list of Web pages, click the URL that you want.

+ Create a hyperlink to an e-mail address

Select either text or a picture.

1

2. On the Standard toolbar, click Insert Hyperlink .

3. Under LinKk to, click E-mail Address.

4 Either type the e-mail address that you want in the E-mail address box, or select an e-mail address
from the Recently used e-mail addresses box.

5. In the Subject box, type the subject of the e-mail message.

Note Some Web browsers and e-mail programs might not recognize the subject line.
+ Create a hyperlink to another page in your document

Select either text or a picture.

1
2 On the Standard toolbar, click Insert Hyperlink .
3. Under Link to, click Place in This Document.

4 Select the page that you want.

w Create a hyperlink to a new file

Select either text or a picture.

On the Standard toolbar, click Insert Hyperlink .
Under Link to, click Create New Document.
Type the name of the new file, including the three-letter extension (such as .pub, .doc, or .xls).
Do one of the following:
. If you know the full path of the location where you want to create the new file, you can
include the full path with the name.
. If you don't know the full path, click Change, and then browse to the location that you want,
select it, and then click OK.
6. Click either Edit the new document later or Edit the new document now.

MBS

Publish a Publisher Web site

After you have created a Web publication in Publisher, your next step is to publish it. You can publish a
Web site to a Web server (Web server: A computer that hosts Web pages and responds to requests from
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browsers. Also known as an HTTP server, a Web server stores files whose URLSs begin with http://.), a
network server, a File Transfer Protocol (FTP) (FTP: A communication protocol that makes it possible for a
user to transfer files between remote locations on a network. This protocol also allows users to use FTP
commands, such as listing files and folders, to work with files on a remote location.) server, or to a folder on
your own computer.

~ Publish a Web site to a location on the Internet or on a network

To publish your Web site on the World Wide Web (WWW) (World Wide Web (WWW): The multimedia
branch of the Internet that presents not only text, but also graphics, sound, and video. On the Web, users can
easily jump from item to item, page to page, or site to site by using hyperlinks.), you need to subscribe to a
Web hosting service. A Web hosting service provides Internet access and storage space on Web servers.
Before you can publish your Web site, you should ask your Internet Service Provider (ISP: A business that
provides access to the Internet for such things as electronic mail, chat rooms, or use of the World Wide
Web. Some ISPs are multinational, offering access in many locations, while others are limited to a specific
region.) or system administrator for the Uniform Resource Locator (URL) (Uniform Resource Locator
(URL): An address that specifies a protocol (such as HTTP or FTP) and a location of an object, document,
World Wide Web page, or other destination on the Internet or an intranet, for example:
http://www.microsoft.com/.) of the Web site where you can save files.

1. On the File menu, click Publish to the Web.
2. In the File name box in the Publish to the Web dialog box, type the URL of the Web or network
server where you want to save your Web site, and then click Save.

3. If prompted, type your user name and password, and then click OK.
The directory associated with your URL will appear in the Publish to the Web dialog box.
4, Double-click the folder where you want to save your Web site.
5. In the File name box, select index as the default name for your home page, and then click Save.
6. When prompted, click OK.

+ Publish a Web site using FTP

Before following this procedure, contact your Internet Service Provider or system administrator to get the
information you need to publish to an FTP (FTP: A communication protocol that makes it possible for a
user to transfer files between remote locations on a network. This protocol also allows users to use FTP
commands, such as listing files and folders, to work with files on a remote location.) site. You also have to
create an FTP site in FTP Locations.

b How?

On the File menu, click Publish to the Web.

In the Save in box, click FTP Locations.

Double-click Add/Modify FTP Locations.

Enter the information you received from your Internet Service Provider, and then click OK.
Click Cancel.

Nk LD =

On the File menu, click Publish to the Web.

. In the Save in box, click FTP Locations.

3. In the list of FTP sites, double-click the site you want, and then double-click the folder where you
want to publish your Web site.

N =
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4. Click Save.

+ Publish a Web site to a folder on your computer

1. On the File menu, click Publish to the Web.
2. In the Save in list, in the Publish to the Web dialog box, click the drive or folder where you want to
publish your Web site.
3. Do one of the following:
. In the folder list, double-click the folder where you want to publish your Web site.

. Click Create New Folder to create a new folder, and then type a name for the new folder
in the Name box.

4. In the File name box, type a file name for your Home page.
5. Click Save.

Note If your Internet Service Provider (ISP) requires you to use a specific program to upload your Web
site, or if you are publishing your Web site to a corporate intranet, you may need to save a version of your
Web site in a specific HTML (HTML: The standard markup language used for documents on the World
Wide Web. HTML uses tags to indicate how Web browsers should display page elements such as text and
graphics and how to respond to user actions.) file format and follow a different procedure to publish your
Web site. Ask your ISP or your system administrator for information about how to save and publish your
Web site.

Create a website for your college. The website should have the following pages

Homepage which describes the college website

About Us page which tells about the college vision, when it was established...etc
Departments page which describes the departments in the college

Separate pages for at least two departments of your college

Contact page which contains address and contact information about the college

Al

Guidelines for the website are given below:

NOTE: Resources like and images and documents are available in Website Content Folder

Homepage
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A Home - Microsoft Internet Explorer

Department of Computer Sci

ence and Engineering
X

T

File Edit WView Favorites Tools Help
<) O-MHNR 2| P search v Favorites 48| (- & (] - [ B EHEe
Address @C:\Documems and Settings\dnm'My Documentsindex.htm V| Go GODg]K-

E N

Organiz

Replace this image with
your college logo or

logo.jpg

YOUR COLLEGE NAME HERE

Home

HOME

About Us

Give an overview of your college website.
Departments

Computer Science Dept

Electronics and
Communications Dept.

building.jpg

Replace this image with
your college picture or

—
Contact Us
Describe the above picture
or graphic
Home AboutUs D s Computer Science D Electronice and Communications
Department  Contact Us
@ Done 4 My Computer

G & 0 EXsE 3 PublicProxy 5... 1 example.pub ... [ & My Documents

43 Home - Micros...
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2} About Us - Microsoft Internet Explorer
&

Department of Computer Science and Engineering

x|

File Edit WView Favorites Tools Help

Qua- O -RE G

Fsearch FrrFavarites @ | (3- 4 - DB H @

Address @ Ct\Documents and Settings\dnmMy Documentslndex_files\Page344.htm "| Go GOUSIg = |C‘ Y @ T &

-
Your business tag line here. l =
Organization
YOUR COLLEGE NAME HERE
I —
Home
ABOUT US
About Us Tell the visitors about your college like when it was established,
— its vision. location, facilities available .__etc
Departments
Computer Science Dept
Electronics and
Communications Dept.
S— Caption describing picture
or graphic.
Contact Us
Home AboutUs D s Computer Science D Electronics and Communications
Department  Contact Us
hd

g My Computer

Beubh.. | [Hexam.. | @ myo.. 3 abou... | i Publi... Book... &)@ 32T 10:21aM
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3 Departments - Microsoft Internet Explorer )(|
i

File Edit WView Favorites Tools Help
Qeack - D - [® B 0| Poearch FrFavorites 8 (- & W - LDE B

Address @ Ct\Documents and Settings\dnm'My Documentslndex_files\Page421.htm "| Go G0ng = |C‘ - B @ ¥ o

Your business tag line here. l
Organization

YOUR COLLEGE NAME HERE

Home Hyperlink these table entries
DEPARTMENTS to the corresponding

AboutUs department pages
— Tell the visitors about the departments in your college.

Departments List the departments in a tabular format like the fallowing
p— Serial Department Name Intaki

Computer Science Dept Numiber
= 1 Computer Science

Elgr%‘r[molmwccsa?ig?}s Dept. 2 Electronics and Commups 60

Contact Us

Home AboutUs Dep s Computer Science I Electronics and Communications

Department  Contact Us

g My Computer

Beubh.. | [Hexam.. | @ myo.. oepa... | DPubli.. [ [¥Book.. &)@ 3T 10:21aM
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omputer Science Department - Microsoft Internet Explorer

File Edit WView Favorites Tools Help

Qeack - O - XN A o | P search 57 Favorites 49 - LT | Fe¥] @

Address @ Ct\Documents and Settings\dnmMy Documentsindex_files\CS.htm "| Go G0ng = |C‘ - @& @ T &

Your business tag line here.

YOUR COLLEGE NAME HERE

Organization

Home Tell the wisitors about the Computer Science Department like faculty, number of computers,
intake __etc
About Us Provide the courses offered by Computer Science department and provide link to the course

syllabus (BTechCSE. doc in Syllabus folder).

Departments

Computer Science Dept

Electronics and
Communications Dept.

—
ContactUs
Home About Us Departments Computer Science Department Electronics and Communications
Department  Contact Us
a Done g My Computer
—

23 Publi... %] exam... MyD... ¥ 00 10:21AM
bl & My e 3
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lectronics and Communications Department - Microsoft Internet Explorer | |

File Edit WView Favorites Tools Help

Qeack - O - XN A o | P search 57 Favorites 49 - LT | Fe¥] @

Address @ Ct\Documents and Settings\dnmMy DocumentsYndex_files\Electronics.htm "| Go G0ng = |C‘ - @& @ T &

Your business tag line here.

YOUR COLLEGE NAME HERE

Organization

Tell the visitors about the Electronics and Communications Department like faculty
Home intake _etc

Provide the courses offered by Electronics and Communications department and provide link
About Us to the course syllabus (BTechECE doc in Syllabus folder)

Departments

Computer Science Dept

Electronics and
Communications Dept.

—
Contact Us
Home AboutUs D s Computer Science D Electronics and Communications
Department Contact Us
@ Done g My Computer
e

2 Publi... B exam... & MyD... 3 Elect... O publi...
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Contact Us - Microsoft Internet Explorer

File Edit View Favorites Tools Help l'f
Qeack - D - [® B 0| Poearch FrFavorites 8 (- & W - LDE B

Address @ Ct\Documents and Settings\dnm'My Documentslndex_files\Page382.htm "| Go G0ng = |C‘ - B @ ¥ o

-
Your business tag line here. =
Organization
YOUR COLLEGE NAME HERE
I —
Home
CONTACT US
About Us
Tell the visitors how to reach your college campus. Give the
Departments address. phone and fax numbers and the email address of the
contact person
Computer Science Dept  Change the graphic with image showing directions to your
campus or routemap.gif in Website Content
Electronics and
Communications Dept.
—
h
Contact Us To contact us:
College Name B
College Name Address
‘our Address Line 2
‘Your Address Line 3
‘Your Address Line 4
b
@ Done g My Computer

o publi... Book.. & ;@ 327 10:22aM
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MICROSOFT Excel

TASK1

Microsoft Excel is a spreadsheet program. It features an intuitive interface, calculation and graphing tools. These
tools could be used for business financial analysis and other administrative tasks. These features have made Excel
one of the most popular microcomputer applications to date. In this module you will master Microsoft Excel.

Merge cells

When you merge two or more adjacent cells, the cells become one merged cell, and the contents of
the upper-left cell are displayed in the center of the merged cell, as shown in the following example.

lorem ipsum

Text spread and centered over multiple cells

Important Only the data in the upper-left cell of a range (range: Two or more cells on a sheet. The

cells in a range can be adjacent or nonadjacent.) of selected cells will remain in the merged cell. Data

in other cells of the selected range will be deleted.

1. If the data that you want to display in the merged cell is not in the upper-left cell, do the
following:

1. Select the data that you want to display in the merged cell, and then click Copy on the
Standard toolbar.
2. Select the upper-left cell of the range of adjacent cells that you want to merge, and then click

Paste on the Standard toolbar.
2. Select the cells that you want to merge.

Note The cells that you select must be adjacent.

3. On the Formatting toolbar (toolbar: A bar with buttons and options that you can use to carry out
commands. To display a toolbar, point to Toolbars on the View menu. If you don't see the button

you want, click the arrows at the right end of the toolbar.), click Merge and Center.

The cells will be merged in a row or column, and the cell contents will be centered in the merged
cell.

Note If the Merge and Center button is unavailable, the selected cell may be in editing mode. To
cancel editing mode, press ENTER.

1. To change the text alignment in the merged cell, select the cell, and then click Align Left or
Align Right on the Formatting toolbar.

Enabling Border options

Using predefined border styles, you can quickly add a border around cells or ranges (range: Two or
more cells on a sheet. The cells in a range can be adjacent or nonadjacent.) of cells.
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1. To apply a new or different border style, click the arrow next to Borders on the Formatting toolbar,
and then choose a border style from the palette.

Tip To apply a custom border style or a diagonal border, click Cells on the Format menu. On the
Border tab, click the line style and color that you want, and then click one or more buttons to

indicate the border placement. Two diagonal border buttons are available under Border.
2. To remove cell borders, click the arrow next to Borders on the Formatting toolbar, and then
click No Border on the palette.

AutoFill Data
Automatically repeat items already entered in the column

If the first few characters that you type in a cell match an existing entry in that column, Microsoft
Excel automatically enters the remaining characters for you. Excel automatically completes only those
entries that contain text or a combination of text and numbers. Entries that contain only numbers,
dates, or times are not completed.

Do one of the following:
1. To accept the proposed entry, press ENTER.

2. The completed entry exactly matches the pattern of uppercase and lowercase letters of the
existing entry.

3. To replace the automatically entered characters, continue typing.

4. To delete the automatically entered characters, press BACKSPACE.
Use the fill handle to fill data
You can use the Series command (point to Fill on the Edit menu, and then click Series) to fill data
into worksheet cells. You can also have Excel automatically continue a series of humbers, number and
text combinations, dates, or time periods, based on a pattern that you establish. However, to quickly
fill in several types of data series, you can select cells and drag the fill handle (fill handle: The small
black square in the lower-right corner of the selection. When you point to the fill handle, the pointer

changes to a black cross.) —i.
The fill handle is displayed by default, but you can hide it.

1. On the Tools menu, click Options.
2. On the Edit tab, do one of the following:

e To hide the fill handle, clear the Allow cell drag and drop check box.

e To display the fill handle, select the Allow cell drag and drop check box.
To avoid replacing existing data when you drag the fill handle, make sure that the Alert before
overwriting cells check box is selected. If you don't want to get a message about overwriting
nonblank cells, you can clear this check box.

Fill data into adjacent cells
1. Select the cells that contain the data that you want to fill into adjacent cells.
2. Drag the fill handle (fill handle: The small black square in the lower-right corner of the selection.

When you point to the fill handle, the pointer changes to a black cross.) —Lacross the cells that
you want to fill.

3. You can use the Auto Fill Options button , which appears after you drag the fill handle, to
choose how to fill the selection. For example, you can choose Fill Formatting Only or Fill
Without Formatting.
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Fill formulas into adjacent cells
1. Select the cell that contains the formula that you want to fill into adjacent cells.
2. Drag the fill handle (fill handle: The small black square in the lower-right corner of the selection.

When you point to the fill handle, the pointer changes to a black cross.) —Lacross the cells that
you want to fill.

3. You can use the Auto Fill Options button , which appears after you drag the fill handle, to
choose how to fill the selection. For example, you can choose Fill Formatting Only or Fill
Without Formatting.

Fill in a series of numbers, dates, or other built-in series items
Using the fill handle (fill handle: The small black square in the lower-right corner of the selection.
When you point to the fill handle, the pointer changes to a black cross.), you can quickly fill cells in a
range with a series of numbers or dates or with a built-in series for days, weekdays, months, or years.
1. Select the first cell in the range that you want to fill.
2. Type the starting value for the series.
3. Type a value in the next cell to establish a pattern.
For example, if you want the series 1, 2, 3, 4, 5..., type 1 and 2 in the first two cells. If you want
the series 2, 4, 6, 8..., type 2 and 4. If you want the series 2, 2, 2, 2..., you can leave the second
cell blank.
+ More examples of series that you can fill

When you fill a series, the selections are extended as shown in the following table. Items separated
by commas are in placed in individual adjacent cells.

Initial selection Extended series
1,2,3 4,5,6,...

4. Select the cell or cells that contain the starting values.
5. Drag the fill handle —Lacross the range that you want to fill.

To fill in increasing order, drag down or to the right. To fill in decreasing order, drag up or to the
left.

Fill data by using a custom fill series

To make entering a particular sequence of data (such as a list of names or sales regions) easier, you
can create a custom fill series. A custom fill series can be based on a list of existing items on a
worksheet, or you can type the list from scratch.

Use a custom fill series based on an existing list of items

1. On the worksheet, select the list of items that you want to use in the fill series.

2. On the Tools menu, click Options, and then click the Custom Lists tab.

3. Verify that the list of items that you selected is displayed in the Import list from cells box, and
then click Import.
The items in the list that you selected are added to the Custom lists box.

4. On the worksheet, click a cell, and then type the item in the custom fill series that you want to use
to start the list.

5. Drag the fill handle (fill handle: The small black square in the lower-right corner of the selection.

When you point to the fill handle, the pointer changes to a black cross.) I:I-across the cells that
you want to fill.

Use a custom fill series based on a new list of items

1. On the Tools menu, click Options, and then click the Custom Lists tab.

2. In the Custom lists box, click New list, and then type the entries in the List entries box,
beginning with the first entry.
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Press ENTER after each entry.

3. When the list is complete, click Add.
4. On the worksheet, click a cell, and then type the item in the custom fill series that you want to use
to start the list.

5. Drag the fill handle I:I-across the cells that you want to fill.

Add, change, or remove conditional formats

1. Select the cells for which you want to add, change, or remove conditional formatting (conditional

format: A format, such as cell shading or font color, that Excel automatically applies to cells if a

specified condition is true.).

On the Format menu, click Conditional Formatting.

Do one of the following:

=~ Add a conditional format

1. Do one of the following:
To use values in the selected cells as the formatting criteria, click Cell Value Is, select the
comparison phrase, and then type a constant (constant: A value that is not calculated and,
therefore, does not change. For example, the number 210, and the text "Quarterly Earnings"
are constants. An expression, or a value resulting from an expression, is not a constant.) value
or a formula. If you enter a formula, start it with an equal sign (=).
To use a formula as the formatting criteria (to evaluate data or a condition other than the
values in selected cells), click Formula Is and then enter the formula that evaluates to a
logical value of TRUE or FALSE.

2. Click Format.

3. Select the formatting you want to apply when the cell value meets the condition or the formula
returns the value TRUE.

4. To add another condition, click Add, and then repeat steps 1 through 3.

wn

You can specify up to three conditions. If none of the specified conditions are true, the cells
keep their existing formats.

Note Using multiple conditions If more than one specified condition is true, Microsoft Excel
applies only the formats of the first true condition, even if more than one condition is true.
=+ Copy formats to other cells

1. Select the cells that have the conditional formats you want to copy.

2. On the Formatting toolbar (toolbar: A bar with buttons and options that you use to carry out
commands. To display a toolbar, click Customize on the Tools menu, and then click the

Toolbars tab.), click Format Painter , and then select the cells you want to format.

< Change or remove a conditional format

Do one or more of the following:

1. To change formats, click Format for the condition you want to change.

2. To reselect formats on the current tab of the Format Cells dialog box, click Clear and select
new formats.

3. To remove one or more conditions, click Delete, and then select the check box for the
conditions you want to delete.

~ Tip

To remove all conditional formats as well as all other cell formats for selected cells, point to Clear

on the Edit menu, and then click Formats.

Display numbers as dates or times

1. Select the cell or range (range: Two or more cells on a sheet. The cells in a range can be adjacent
or nonadjacent.) or cells that you want to format.
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2. On the Format menu, click Cells.
3. On the Number tab, in the Category list, click Date or Time.
4. 1In the Type list, click the format that you want to use.

Dates or times that you type into formatted cells will be displayed in the format that you selected.

+ Custom date and time codes
Days, months, and years If you use "m" immediately after the "h" or "hh" code or immediately
before the "ss" code, Microsoft Excel displays minutes instead of the month.

To display Use this code
Months as 1-12 m

Hours, minutes, and seconds
To display Use this code

Hours as 0-23 H

1.AM and PM If the format contains an AM or PM, the hour is based on the 12-hour clock, where
"AM" or "A" indicates times from midnight until noon and "PM" or "P" indicates times from noon
until midnight. Otherwise, the hour is based on the 24-hour clock. The "m" or "mm" code must
appear immediately after the "h" or "hh" code or immediately before the "ss" code; otherwise,
Microsoft Excel displays the month instead of minutes.

2.When you try to undo a date or time format by selecting General in the Category list, Excel
displays a number code. When you enter a date or time again, Excel displays the default date or
time format. To enter a specific date or time format, such as January 2005, you may want to
format it as text by selecting Text in the Category list.

Apply or remove cell shading:
You can add shading to cells by filling them with solid colors or specific patterns.

1. Select the cells or ranges (range: Two or more cells on a sheet. The cells in a range can be
adjacent or nonadjacent.) of cells that you want to apply shading to or remove shading from.
2. Do one of the following:

e To fill cells with a solid color, click the arrow next to Fill Color on the Formatting
toolbar (toolbar: A bar with buttons and options that you can use to carry out commands. To
display a toolbar, point to Toolbars on the View menu. If you don't see the button you want,
click the arrows at the right end of the toolbar.), and then click the color that you want on the
palette.

e To apply the most recently selected color, click Fill Color .

e To fill cells with a pattern, click Cells on the Format menu. On the Patterns tab, under Cell
shading, click the background color that you want to use for the pattern. Then click the arrow
next to the Pattern box, and click the pattern style and pattern color.

e To remove a fill color or fill pattern from selected cells or cell ranges, click the arrow next to Fill

Color , and then click No Fill.

To calculate the Sum
<~ Add numbers in a cell

You can add numbers as you type them into a cell. For example, type =5+10 in a cell to display the
result 15.
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~ Add all contiguous numbers in a row or column

You can use AutoSum to do this task.
1. Click a cell below the column of humbers or to the right of the row of numbers.

2. Click AutoSum on the Standard toolbar (toolbar: A bar with buttons and options that you use
to carry out commands. To display a toolbar, click Customize on the Tools menu, and then click
the Toolbars tab.), and then press ENTER.

TASK2

To Change the Text Orientation

For the optimal display of the data on your worksheet (worksheet: The primary document that you use
in Excel to store and work with data. Also called a spreadsheet. A worksheet consists of cells that are
organized into columns and rows; a worksheet is always stored in a workbook.), you may want to
reposition the text within a cell. You can change the alignment of the cell contents, use indentation for
better spacing, or display the data at a different angle by rotating it.

1. Select the cell or range (range: Two or more cells on a sheet. The cells in a range can be

adjacent or nonadjacent.) of cells that contains the data that you want to reposition.
2. On the Format menu, click Cells.
3. On the Alignment tab, do one of the following:
a. To change the horizontal alignment of the cell contents, click the alignment that you
want in the Horizontal box.

To calculate the average
The average is also called the mean.

+ Calculate the average of numbers in a contiguous row or column
1. Click a cell below or to the right of the numbers for which you want to find the average.

2. Click the arrow next to AutoSum on the Standard toolbar (toolbar: A bar with buttons and
options that you use to carry out commands. To display a toolbar, click Customize on the
Tools menu, and then click the Toolbars tab.), and then click Average, and then press
ENTER.
+ Calculate the average of numbers not in a contiguous row or column

Use the AVERAGE function to do this task.

Worksheet example
The example may be easier to understand if you copy it to a blank worksheet.

+ How?
1. Create a blank workbook or worksheet.
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2. Select the example in the Help topic. Do not select the row or column headers.

3.
4. Selecting an example from Help
5. Press CTRL+C.
6. In the worksheet, select cell A1, and press CTRL+V.
A 7. To switch
between viewing
Data the results and
10 viewing the
formulas that
7 return the
9 results, press
CTRL+" (grave
27 accent), or on
0 the Tools menu,
point to
4 Formula
UL Auditing, and
Formula Description (Result) then click
=AVERAGE(A2:A7) Averages all of numbers in list above (9.5) Formula
Auditing Mode.
=AVERAGE(A2:A4,A7) Averages the top three and the last number in
the list (7.5) Note The last
=AVERAGE(IF(A2:A7<>0, Averages the numbers in the list except those formula in the
A2:A7,"")) that contain zero, such as cell A6 (11.4) example must be
entered as an
array

formula (array formula: A formula that performs multiple calculations on one or more sets of values,
and then returns either a single result or multiple results. Array formulas are enclosed between braces
{ } and are entered by pressing CTRL+SHIFT+ENTER.). After copying the example to a blank
worksheet, select the cell A11. Press F2, and then press CTRL+SHIFT+ENTER. If the formula is not
entered as an array formula, the error #VALUE! is returned.

Function details

AVERAGE

+ Calculate a weighted average

Use the SUMPRODUCT and SUM functions to do this task.
Worksheet example

The example may be easier to understand if you copy it to a blank worksheet.

+ How?
1. Create a blank workbook or worksheet.
2. Select the example in the Help topic. Do not select the row or column headers.
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o

Selecting an example from Help

3. Press CTRL+C.

A B 4, In the
. . i worksheet,
Price per unit Number of units select cell A1,

20 500 and press
CTRL+V.
25 750 5. To
35 200 switch between
viewing the
Formula Description (Result) results and
=SUMPRODUCT(A2:A4,B2:B4)/SUM(B2:B4) Divides the total cost of all three ;’ém'&gsﬂt‘ﬁat
orders by the total number of units
ordered (24.66) return the

results, press

CTRL+" (grave
accent), or on the Tools menu, point to Formula Auditing, and then click Formula Auditing
Mode.

This example calculates the average price paid for a unit across three purchases, where each purchase
is for a different number of units at a different price per unit.

Function details

SUM

SUMPRODUCT

~ Calculate the average of numbers, ignoring zero (0) values
Use the AVERAGE and IF functions to do this task.
Worksheet example

The example may be easier to understand if you copy it to a blank worksheet.

~ How?
1. Create a blank workbook or worksheet.
2. Select the example in the Help topic. Do not select the row or column headers.

Selecting an example from Help
3. Press CTRL+C.
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A 4. In the
worksheet,

Data select cell A1,

10 and press
CTRL+V.

7 5. To

9 switch between
viewing the

27 results and

0 viewing the
formulas that

4 return the

L results, press

Formula Description (Result) CTRL+" (grave

=AVERAGE(IF(A2:A7<>0, Averages the numbers in the list except those accent), or on

A2:A7,") that contain zero, such as cell A6 (11.4) the Tools menu,
point to
Formula

Auditing, and then click Formula Auditing Mode.
Function details

AVERAGE
IF
Returns the average (arithmetic mean) of the arguments.

Syntax
AVERAGE(numberl,number2,...)
Numberl, number2, ... are 1 to 30 numeric arguments for which you want the average.
Remarks
1. Arguments can either be numbers or names, arrays, or references that contain numbers.
2. Logical values and text representations of numbers that you type directly into the list of
arguments are counted.
3. If an array or reference argument contains text, logical values, or empty cells, those values are
ignored; however, cells with the value zero are included.
4. Arguments that are error values or text that cannot be translated into numbers cause errors.
5. If you want to include logical values and text representations of numbers in a reference as part
of the calculation, use the AVERAGEA function.

To calculate the Standard Deviation

Syntax
STDEV(numberl,number2,...)
Numberl, number2, ... are 1 to 30 number arguments corresponding to a sample of a population.

You can also use a single array or a reference to an array instead of arguments separated by commas.

Example

Suppose 10 tools stamped from the same machine during a production run are collected as a random
sample and measured for breaking strength.

The example may be easier to understand if you copy it to a blank worksheet.

P How?
1. Create a blank workbook or worksheet.
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2. Select the example in the Help topic. Do not select the row or column headers.

Strength
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299

Formula Description (Result)
=STDEV(A2:A11) Standard deviation of breaking strength (27.46391572)

average value (the mean).

Syntax
STDEVA(valuel,value2,...)

Selecting an example
from Help

3. Press CTRL+C.
4. In the
worksheet, select cell
Al, and press CTRL+V.
5. To switch
between viewing the
results and viewing the
formulas that return the
results, press CTRL+"
(grave accent), or on the
Tools menu, point to
Formula Auditing, and
then click Formula
Auditing Mode.

Estimates standard
deviation based on a
sample. The standard
deviation is a measure of
how widely values are
dispersed from the

Valuel, value2, ... are 1 to 30 values corresponding to a sample of a population. You can also use a
single array or a reference to an array instead of arguments separated by commas.

Remarks

1. STDEVA assumes that its arguments are a sample of the population. If your data represents the
entire population, you must compute the standard deviation using STDEVPA.

2. The standard deviation is calculated using the "unbiased" or "n-1" method.

3. Arguments can be the following: numbers; names, arrays, or references that contain numbers;
text representations of numbers; or logical values, such as TRUE and FALSE, in a reference.

4. Arguments that contain TRUE evaluate as 1; arguments that contain text or FALSE evaluate as

0 (zero).

5. If an argument is an array or reference, only values in that array or reference are used. Empty

cells and text values in the array or reference are ignored.

6. Arguments that are error values or text that cannot be translated into humbers cause errors.
7. If you do not want to include logical values and text representations of humbers in a reference

as part of the calculation, use the STDEV function.
8. STDEVA uses the following formula:
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9. (n—1)

10. where x is the sample mean AVERAGE(valuel,value2,...) and n is the sample size.
Example

Suppose 10 tools stamped from the same machine during a production run are collected as a random
sample and measured for breaking strength.

The example may be easier to understand if you copy it to a blank worksheet.

P How?
1. Create a blank workbook or worksheet.
2. Select the example in the Help topic. Do not select the row or column headers.

Selecting an example from Help

Press CTRL+C.

In the worksheet, select cell A1, and press CTRL+V.

To switch between viewing the results and viewing the formulas that return the results, press
CTRL+" (grave accent), or on the Tools menu, point to Formula Auditing, and then click
Formula Auditing Mode.

u bW

To create a Chart

You can quickly create a chart in Microsoft Excel by using the Chart Wizard. In this wizard, you can
choose from a variety of chart types and specify various chart options. Although
worksheet (worksheet: The primary document that you use in Excel to store and work with data. Also
called a spreadsheet. A worksheet consists of cells that are organized into columns and rows; a
worksheet is always stored in a workbook.) data that you want to plot in a chart can be located in rows
or columns, some chart types require a specific arrangement of the data before you can create a chart.
For more information about chart types, see Available chart types.
1. On the worksheet, arrange the data that you want to plot in a chart.
~ How to arrange data for different chart types
o For a column, bar, line, area, surface or radar chart, you should arrange the data in
columns or rows.

e Data in columns:

e lorem e Ipsum
° 1 o 2
e 3 o 4

. Data in rows:

e |Lorem o 1 .

e Ipsum o 2 e 4
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o For a pie or doughnut chart with only one series of data, you should arrange the data in
one column or row only.

One column of data and one column of data labels:

e A e 1
e B o« 2
e (C e 3

e One row of data and one row of data labels:

e A [ B e C
e 1 o 2 e 3

o For a pie chart or doughnut chart that has more than one series of data, you can
arrange the data in more than one column or row.

More than one column of data:

e A e 1 °
e B e 3 °
e C e 5 .

¢ More than one row of data:
e A e B e C
e 1 e 2 e 3
o 4 e §5 e 6

o For an xy (scatter) or bubble chart, you can arrange the data in columns, so that x
values are listed in the first column and corresponding y values and/or bubble size
values are listed in adjacent columns.

Data in columns:

e X e Y e Bubble
° 1 o 2 e 3
e 4 e § e 6

o For a stock chart, you need to arrange data in the following order (in rows or columns):
high values, low values, and closing values. Use hames or dates as labels.

Data in columns:

e Date e High e Low e Close
e 1/1/2002 e 46.125 e 42 e 44,063
2. Select the cells that contain the data that you want to use for the chart.

3. Tip If the cells that you want to select for the chart are not in a continuous range, select the
first group of cells that contain the data that you want to include. Hold down CTRL, and then
select any additional cell groups that you want to include. The nonadjacent selections must
form a rectangle.
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Now

Tips

The nonadjacent ... aretrested &z a
selections ...

Korea 27 42

Click Chart Wizard on the Standard toolbar, or click Chart on the Insert menu.
Follow the instructions in the Chart Wizard.
For information about the Chart Wizard options, click Help [Zlin the title bar of the wizard.

To quickly create a basic chart that is displayed on a separate chart sheet (chart sheet: A sheet

in a workbook that contains only a chart. A chart sheet is beneficial when you want to view a chart or
a PivotChart report separately from worksheet data or a PivotTable report.), select the data that you
want to use for the chart, and then press ALT+F1 or F11.

chart

If you use a specific chart type frequently when you create a chart, you may want to set that
type as the default chart type.

+ Change the default chart type

1.

wnN

vk~

Notes
1.

2.

This is

Click anywhere in the chart area (chart area: The entire chart and all its elements.) to select
the chart.

On the Chart menu, click Chart Type.

On the Standard Types tab or Custom Types tab, in the Chart type list, click the chart type
that you want or accept the current selection, and then click Set As Default Chart.

Click Yes, and then click OK.

If the Add Custom Chart Type dialog box appears, type a nhame in the Name box and a
description in the Description box, and then click OK.

When you create a chart, the Chart toolbar is displayed and the Chart menu is added to the
menu bar. You can use the toolbar buttons and menu commands to modify the chart. For
example, use the toolbar to select specific items in the chart, change the chart type, make
formatting changes, show or hide the legend or data table, or switch between displaying the
data series by row and displaying it by column. The Chart menu allows you to make changes to
the source data, add data to the chart, specify numerous chart options, change the location of
the chart, and apply 3-D effects. The Chart menu does not, however, provide a command for
creating a chart.

The Chart toolbar can also be displayed (or hidden) at any time by pointing to Toolbars on the
View menu, and then clicking Chart. If you display the Chart toolbar before you create a
chart, you can use it to create a chart. Select the cells that contain the data that you want to
use in the chart, and then click Chart Type on the Chart toolbar. The chart will be displayed in
the selected chart type on the same worksheet.

also called a 3-D reference (3-D reference: A reference to a range that spans two or more

worksheets in a workbook.).

1.
2.
3.

Nouk

On the Insert menu, point to Name, and then click Define.

In the Names in workbook box, type the name.

If the Refers to box contains a reference, select the equal sign (=) and the reference and
press BACKSPACE.

In the Refers to box, type = (equal sign).

Click the tab for the first worksheet to be referenced.

Hold down SHIFT and click the tab for the last worksheet to be referenced.

Select the cell or range of cells to be referenced.
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A reference identifies a cell or a range of cells on a worksheet and tells Microsoft Excel where to look
for the values or data you want to use in a formula. With references, you can use data contained in
different parts of a worksheet in one formula or use the value from one cell in several formulas. You
can also refer to cells on other sheets in the same workbook, and to other workbooks. References to
cells in other workbooks are called links.

+ The Al reference style

By default, Excel uses the Al reference style, which refers to columns with letters (A through 1V, for a
total of 256 columns) and refers to rows with numbers (1 through 65536). These letters and numbers
are called row and column headings. To refer to a cell, enter the column letter followed by the row
number. For example, B2 refers to the cell at the intersection of column B and row 2.

To refer to Use
The cell in column A and row 10 A10

The range of cells in column A and rows 10 through 20 A10:A20
The range of cells in row 15 and columns B through E B15:E15
All cells in row 5 5:5

All cells in rows 5 through 10 5:10

All cells in column H H:H

All cells in columns H through J H:J]

The range of cells in columns A through E and rows 10 through 20 A10:E20

Reference to another worksheet In the following example, the AVERAGE worksheet function
calculates the average value for the range B1:B10 on the worksheet nhamed Marketing in the same
workbook.

Mame of the worksheet
|Heference to cell or range of cells on the shest
—AVERAGE(Marketing!B1:B 10)

Separ ates the sheet reference
from the cell reference

Link to another worksheet in the same workbook
Note that the name of the worksheet and an exclamation point (!) precede the range reference.

+ The difference between relative and absolute references

Relative references A relative cell reference in a formula, such as A1, is based on the relative
position of the cell that contains the formula and the cell the reference refers to. If the position of the
cell that contains the formula changes, the reference is changed. If you copy the formula across rows
or down columns, the reference automatically adjusts. By default, new formulas use relative
references. For example, if you copy a relative reference in cell B2 to cell B3, it automatically adjusts
from =A1 to =A2.

A | B |

I
k

Copied formula with relative reference
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Absolute references An absolute cell reference in a formula, such as $A$1, always refer to a cell in
a specific location. If the position of the cell that contains the formula changes, the absolute reference
remains the same. If you copy the formula across rows or down columns, the absolute reference does
not adjust. By default, new formulas use relative references, and you need to switch them to absolute
references. For example, if you copy a absolute reference in cell B2 to cell B3, it stays the same in
both cells =$A%$1.

A | B |

=FA%1
=}a%1

Copied formula with absolute reference

Mixed references A mixed reference has either an absolute column and relative row, or absolute
row and relative column. An absolute column reference takes the form $A1, $B1, and so on. An
absolute row reference takes the form A$1, B$1, and so on. If the position of the cell that contains the
formula changes, the relative reference is changed, and the absolute reference does not change. If you
copy the formula across rows or down columns, the relative reference automatically adjusts, and the
absolute reference does not adjust. For example, if you copy a mixed reference from cell A2 to B3, it
adjusts from =A$1 to =B$1.

Al B[ C |

=4%1

=E§1
Copied formula with mixed reference
« The 3-D reference style

If you want to analyze data in the same cell or range of cells on multiple worksheets within the
workbook, use a 3-D reference. A 3-D reference includes the cell or range reference, preceded by a
range of worksheet names. Excel uses any worksheets stored between the starting and ending names
of the reference. For example, =SUM(Sheet2:Sheet13!B5) adds all the values contained in cell B5 on
all the worksheets between and including Sheet 2 and Sheet 13.

You can use 3-D references to refer to cells on other sheets, to define names, and to create
formulas by using the following functions: SUM, AVERAGE, AVERAGEA, COUNT, COUNTA, MAX, MAXA,
MIN, MINA, PRODUCT, STDEV, STDEVA, STDEVP, STDEVPA, VAR, VARA, VARP, and VARPA.

3-D references cannot be used in array formulas (array formula: A formula that performs
multiple calculations on one or more sets of values, and then returns either a single result or multiple
results. Array formulas are enclosed between braces { } and are entered by pressing
CTRL+SHIFT+ENTER.).

3-D references cannot be used with the intersection operator (operator: A sign or symbol that
specifies the type of calculation to perform within an expression. There are mathematical,
comparison, logical, and reference operators.) (a single space) or in formulas that use implicit
intersection (implicit intersection: A reference to a range of cells, instead of a single cell, that is
calculated like a single cell. If cell C10 contains the formula =B5:B15*5, Excel multiplies the value in
cell B10 by 5 because cells B10 and C10 are in the same row.).

How 3-D references change when you move, copy, insert, or delete worksheets

The following examples explain what happens when you move, copy, insert, or delete worksheets that
are included in a 3-D reference. The examples use the formula =SUM(Sheet2:Sheet6!A2:A5) to add
cells A2 through A5 on worksheets 2 through 6.
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Insert or copy If you insert or copy sheets between Sheet2 and Sheet6 (the endpoints in this
example), Microsoft Excel includes all values in cells A2 through A5 from the added sheets in the
calculations.

Delete If you delete sheets between Sheet2 and Sheet6, Excel removes their values from the
calculation.
Move If you move sheets from between Sheet2 and Sheet6 to a location outside the referenced
sheet range, Excel removes their values from the calculation.
Move an endpoint If you move Sheet2 or Sheet6 to another location in the same workbook, Excel
adjusts the calculation to accommodate the new range of sheets between them.
Delete an endpoint If you delete Sheet2 or Sheet6, Excel adjusts the calculation to accommodate
the range of sheets between them.

Objective:

To learn about
a. How to use nested functions?
b. What are the logical operators and how can I use them for manipulating data?

by implementing a Capital gains and loss_worksheet.
Description:

This task requires you to implement and learn how to
1. To create Nested functions
2. To make use of logical operators

Task2 Assignment

Step By Step Guide:
To use Nested Functions

In certain cases, you may need to use a function as one of the arguments (argument: The values that
a function uses to perform operations or calculations. The type of argument a function uses is specific
to the function. Common arguments that are used within functions include numbers, text, cell
references, and names.) of another function. For example, the following formula uses a nested
AVERAGE function and compares the result with the value 50.

| Mested functions
—IF(AVERAGE(F2:F5)>50, SUM{GZ:G5),0]

Valid returns  When a nested function is used as an argument, it must return the same type of value
that the argument uses. For example, if the argument returns a TRUE or FALSE value, then the nested
function must return a TRUE or FALSE. If it doesn't, Microsoft Excel displays a #VALUE! error value.
Nesting level limits A formula can contain up to seven levels of nested functions. When Function B is
used as an argument in Function A, Function B is a second-level function. For instance, the AVERAGE
function and the SUM function are both second-level functions because they are arguments of the IF
function. A function nested within the AVERAGE function would be a third-level function, and so on

To use Nested Functions

You can use the AND, OR, NOT, and IF function to create conditional formulas. The IF function uses
the following arguments.
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v < %

=IF(logical_test,value_if_true,value_if_False)

Formula with the IF function
1 |ogical_test: the condition you want to check
2 value_if _true: the value to return if the condition is true

3 value_if false:

the value to
A return if the
Data condition is false
15
9
8
Sprockets A
Widgets Data
Formula = Descrintion (Result)
=AND(A2>A3, A2<A4) 9 Is 15 greater than 9 and less than 8? (FALSE)
=0R(A2>A3, A2<A4) 8 Is 15 greater than 9 or less than 8? (TRUE)
=NOT(A2+A3=24) Sprocket§s 15 plus 9 not equal to 24? (FALSE)
=NOT(A5="Sprockets") Widgets Is A5 not equal to "Sprockets"? (FALSE)
—OR(A5<>"Sprockets", A6 .Formula . Dfascription (Result)l
"Widgets") =IF(A2=1Wido&ts"?NFRUE) If the value in cell A2 equals 15, then return "O
OK") (OK)
=IF(A2<>15, "OK", "Not  If the value in cell A2 is not equal to 15, then rg
+ Create a conditional OK™) "OK". (Not OK)

formula that results in a
logical value (TRUE or
FALSE)

Use the AND, OR, and NOT functions, and operators (operator: A sign or symbol that specifies the type
of calculation to perform within an expression. There are mathematical, comparison, logical, and
reference operators.) to do this task, as presented in the following example worksheet.

The example may be easier to understand if you copy it to a blank worksheet.

P How?
1. Create a blank workbook or worksheet.
2. Select the example in the Help topic. Do not select the row or column headers.

Selecting an example from Help
3. Press CTRL+C.
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4, In the worksheet, select cell A1, and press CTRL+V.
5. To switch between viewing the results and viewing the formulas that return the results, press

CTRL+" (grave accent), or on the Tools menu, point to Formula Auditing, and then click Formula
Auditing Mode.

+ Create a conditional formula that results in another calculation, or values other than TRUE or FALSE
Use the IF, AND, and OR functions to do this task, as presented in the following example worksheet.
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TASK3

To calculate the NPV (Net Present Value)

Calculates the net present value of an investment by using a discount rate and a series of future
payments (negative values) and income (positive values).

Syntax
NPV(rate,valuel,value2, ...)

Rate

is the rate of discount over the length of one period.

Valuel, value2, ... are 1 to 29 arguments representing the payments and income.

1. Valuel, value2, ... must be equally spaced in time and occur at the end of each period.

2. NPV uses the order of valuel, value2, ... to interpret the order of cash flows. Be sure to enter
your payment and income values in the correct sequence.

3. Arguments that are numbers, empty cells, logical values, or text representations of numbers
are counted; arguments that are error values or text that cannot be translated into humbers
are ignored.

4. If an argument is an array or reference, only numbers in that array or reference are counted.
Empty cells, logical values, text, or error values in the array or reference are ignored.

Remarks

1. The NPV investment begins one period before the date of the valuel cash flow and ends with
the last cash flow in the list. The NPV calculation is based on future cash flows. If your first cash
flow occurs at the beginning of the first period, the first value must be added to the NPV result,
not included in the values arguments. For more information, see the examples below.

2. If nis the number of cash flows in the list of values, the formula for NPV is:

2. values;
NPV =} ————
{1+ rake)

4. NPV is similar to the PV function (present value). The primary difference between PV and NPV is
that PV allows cash flows to begin either at the end or at the beginning of the period. Unlike the
variable NPV cash flow values, PV cash flows must be constant throughout the investment. For
information about annuities and financial functions, see PV.

5. NPV is also related to the IRR function (internal rate of return). IRR is the rate for which NPV

equals zero: NPV(IRR(...), ...) = 0.

To make use of the Split panes

1.

2.

At the top of the vertical scroll bar or at the right end of the horizontal scroll bar, point to the
split box.

When the pointer changes to a split pointer, drag the split box down or to the left to the
position you want.
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TASK4
To create a new Worksheets

Add a single worksheet
1. Click Worksheet on the Insert menu.
Add multiple worksheets

Determine the number or worksheets you want to add.

1. Hold down SHIFT, and then select the same number of existing worksheet tabs that you want to
add in the open workbook.

2. Example: If you want to add three new worksheets, select three existing worksheet tabs.

3. Click Worksheet on the Insert menu.

Insert a new sheet that's based on a custom template
You must have already created a custom sheet template.
P How?

1. Decide which type of template you want:

Workbook template

Create a workbook that contains the sheets, default text (such as page headers and column and
row labels), formulas, macros (macro: An action or a set of actions you can use to automate tasks.
Macros are recorded in the Visual Basic for Applications programming language.), styles (style: A
combination of formatting characteristics, such as font, font size, and indentation, that you name
and store as a set. When you apply a style, all of the formatting instructions in that style are
applied at one time.), and other formatting you want in new workbooks based on the template.

Worksheet template

Create a workbook that contains one worksheet. On the worksheet, include the formatting,

styles (style: A combination of formatting characteristics, such as font, font size, and indentation,
that you name and store as a set. When you apply a style, all of the formatting instructions in that
style are applied at one time.), text, and other information you want to appear on all new sheets of
the same type.

2. To display a picture of the first page of a template in the Preview box of the Templates dialog
box (General Templates..., New Workbook task pane), click Properties on the File menu, click
the Summary tab, and then select the Save preview picture check box.

3. On the File menu, click Save As.

4. In the Save as type box, click Template.

5. In the Save in box, select the folder where you want to store the template.
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1. To create the default workbook template (default workbook template: The Book.xIt
template that you create to change the default format of new workbooks. Excel uses the
template to create a blank workbook when you start Excel or create a new workbook
without specifying a template.) or default worksheet template (default worksheet template:
The Sheet.xlIt template that you create to change the default format of new worksheets.
Excel uses the template to create a blank worksheet when you add a new worksheet to a
workbook.), select either the XLStart folder or the alternate startup folder (alternate startup
folder: A folder in addition to the XLStart folder that contains workbooks or other files that
you want to be opened automatically when you start Excel and templates that you want to
be available when you create new workbooks.). The XLStart folder is usually

C:\Program Files\Microsoft Office\Officel1\XLStart

2. To create a custom workbook or worksheet template, select the Templates folder, which is
usually

C:\Documents and Settings\user_name\Application Data\Microsoft\Templates

6. Enter the name of the template in the File name box. Do one of the following:
Workbook template
1. Type book to create the default workbook template.

2. To create a custom workbook template, type any valid file name.

Worksheet template
1. Type sheet to create a template for default worksheets.

2. To create a custom sheet template, type any valid file name.

7. Click Save, and then click Close on the File menu.
To insert a new worksheet

1. Right-click a sheet tab, and then click Insert.

2. Double-click the template for the type of sheet you want.
The name (or title) of a worksheet (worksheet: The primary document that you use in Excel to store
and work with data. Also called a spreadsheet. A worksheet consists of cells that are organized into
columns and rows; a worksheet is always stored in a workbook.) appears on its sheet tab on the
Sheet tab bar at the bottom of the screen. By default, the name is Sheetl, Sheet2, and so on, but
you can give your worksheet a more appropriate name.

1. To rename the active sheet, do one of the following:

o On the Format menu, point to Sheet and then click Rename.

o On the Sheet tab bar, right-click the tab you want to rename, and then click
Rename.

Sheet! ', Sheet2 | Chartl
Active sheet

2. Type the new name over the current name.

Tip You can include the name of the sheet when you print the worksheet. On the View menu, click
Header and Footer, and then, in the Page Setup dialog box on the Header/Footer tab, click
Custom Header or Custom Footer. In the Left section, Center section, or Right section box,

enter the sheet tab by clicking Tab in the row of buttons in the Header or Footer dialog box.

To create a hyperlink to a specific location in a workbook

To link to a location in the current workbook or another workbook, you can either define a
name (name: A word or string of characters that represents a cell, range of cells, formula, or constant
value. Use easy-to-understand names, such as Products, to refer to hard to understand ranges, such
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as Sales!C20:C30.) for the destination (destination: General term for the name of the element you go
to from a hyperlink.) cells or use a cell reference.

1. To use a name, name the destination cells in the destination workbook.

~ How?

1. Select the cell, range of cells, or honadjacent selections (nonadjacent selection: A selection of
two or more cells or ranges that don't touch each other. When plotting nonadjacent selections
in a chart, make sure that the combined selections form a rectangular shape.) that you want to
name.

2. Click the Name box at the left end of the formula bar (formula bar: A bar at the top of the
Excel window that you use to enter or edit values or formulas in cells or charts. Displays the
constant value or formula stored in the active cell.) %

- C5 - 3
1 Name box

3. Type the name for the cells.
4. Press ENTER.

Note You cannot name a cell while you are changing the contents of the cell.

2. In the source (source file: The file that contains information that was used to create a linked or
embedded object. When you update the information in the source file, you can also update the
linked object in the destination file.) workbook, right-click the text or graphic you want to represent
the hyperlink (hyperlink: Colored and underlined text or a graphic that you click to go to a file, a
location in a file, a Web page on the World Wide Web, or a Web page on an intranet. Hyperlinks
can also go to newsgroups and to Gopher, Telnet, and FTP sites.), and then click Hyperlink on the
shortcut menu.

3. Do one of the following:

1. To link to a location in your current workbook, click Place in this document under

Link to.
2. To link to a location in another workbook, click Existing file or Web page under Link
to.

4. 1If you chose Existing file or Web page, locate and select the workbook you want to link to, and
then click the Bookmark button.
5. Do one of the following:
1. In the list under Cell Reference, click the sheet you want to link to, and then type the
cell reference in the Type in the cell reference box. Click OK.
2. In the list under Defined Names, click the name that represents the cells you want to
link to. Click OK.
6. To assign a tip to be displayed when you rest the pointer on the hyperlink, click ScreenTip and
then type the text you want in the ScreenTip text box. Click OK.

To use HLookup and VLookup functions

We use HLookup and VLookup to find records in large worksheets, explained the basics of using the
HLOOKUP and VLOOKUP functions in Microsoft Excel to find records in a large worksheet. This column
explains several other ways to use those functions.

Use relative and absolute cell references to return multiple results

The instance of VLOOKUP that you created in the previous section contains a reference to Cell F3.
Excel calls that type of reference a relative reference, meaning that if you copy the formula down or
across a range of cells, Excel automatically increases the cell reference by 1 for each new instance of
the formula. If any of those instances of the formula reference empty cells, Excel displays the #N/A
error.
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In contrast, absolute cell references do not change when you copy them down or across a range of
cells, so using them can help you avoid #N/A errors. The following steps demonstrate how relative cell
references can cause #N/A errors, and how absolute references can fix them.

1. On the Page Views worksheet, copy and paste or type this formula into Cell D4:
=VLOOKUP(A4,Pages!A2:B39,2,false)

2. Click Cell D4, rest your mouse pointer on the lower-right corner of the cell until it changes to a
black plus sign (+), and then drag the mouse pointer down to Cell D41. The page names that
correspond to each ID appear in Column D.

At this point, #N/A appears in several cells. What happened? If you click cells in Column D, you see

that Excel also increased the cell references by one after the word Pages! in the formula. (In case you

haven't read the previous article, "Pages!A2:B39" is called the table array argument. For more
information about the argument, read the previous article.) In other words, the formula in Cell D4
references Cells A2 through B39 on the Pages worksheet, which is what you want. But look at the
formula associated with Cell D5: It references Cells A3 through B40. If you go back to the Pages
worksheet, you'll see that Cell B40 is empty. Excel returns the #N/A message because some instances
of the formula contain references to empty cells.

To work around the problem, use absolute cell references. Absolute references prevent Excel from
changing cell references in a formula when you copy that formula. Follow these steps:

1. In the Page Views worksheet, clear Cells D5 through D41.

2. In Cell D4 (or the formula bar, if that's easier), add dollar signs to the formula as shown:

=VLOOKUP(A4,Pages!$A$2:$B$39,2,FALSE)
The dollar signs make the cell references absolute.

3. Point to the lower-right corner of Cell D4 until your mouse pointer changes to a black plus sign,
and then drag the pointer down to Cell D41. As you copy the formula, the dollar signs prevent
Excel from changing any cell references in the table array argument. This time, the page names
that correspond to each ID appear in Column D with no errors.

The formula in Step 2 uses absolute columns and rows (the dollar signs are a dead giveaway). You can
use a mix of relative columns and absolute rows, or vice versa. For example:

1. If you need a relative column reference and an absolute row reference, use A$2.
2. If you need an absolute column reference and a relative row reference, use $A2.

You can mix absolute and relative references as needed. For example, you could use $A2:B$39, or any
other combination of characters. Just make sure that you place the dollar sign before the column or
row that you want to designate as an absolute reference. The function fails otherwise.

Finally, for more information about formula error messages, see Correct a #N/A error, Correct a #REF!
error, and Correct a #VALUE! error.

Use formula auditing to find empty cells and fix broken functions

Typically, a function doesn't work because it references at least one empty cell. You can use the
formula auditing tools in Excel to find the empty cell and fix the broken function. The formula auditing
tools use arrows and icons to point to the cells from which a function tries to take the data it needs.

Important To follow the steps in this section, you must first enable an error checking option. On the
Tools menu, click Options, click the Error Checking tab, and then select the Formulas referring to
empty cells check box.

To see the auditing tools in action:

1. On the Page Views worksheet, remove the dollar signs from the formula in cell D4.
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2. Clear cells D5 through D41, and then copy the changed formula down to Cell D41. Because all
instances of the formula except the first one contain an error, Excel displays a green triangle in the
upper-left corner of each cell:

F .
Cornics & Hurmaor |

Select Cell D5. The Trace Error icon appears.

3.
4. Click the arrow to the right of the icon, and then click Trace Empty Cell. The following arrow and
icon appear, indicating that the empty cell resides on another worksheet.
‘_1"Ec'|'n"l'rcs & Humar |
5. Double-click the black arrow that leads from the icon to the cell.
6. Double-click the entry in the Go to dialog box. Excel opens the Pages worksheet because that

worksheet contains the empty cell.

At this point, you need to notice something subtle: In the Pages worksheet, Excel highlights the cell
range A3 to B40, even though the data only resides in cells A2 to B39. The highlight is showing you
that the formula is searching the wrong range of cells. Hence, the error.

To see a more pronounced example of this behavior, go back to the Page Views worksheet, select Cell
D10, and repeat Steps 4 through 6. The highlight in the Pages worksheet extends even further down
to indicate the greater number of empty cells referenced by the instance of the formula in Cell D10.

3 |28000524 Maovies 2
35 |28001043 Maovies 3
36 28001271 Adts 1
37 |28000544 Arts 2
30 |28000456 Kids 1
39 |28001143 Kids 2
40
41 -
42 '
43

44
P—___

Use the Lookup Wizard to save time

If you don't have the time to write a function or if writing functions still frustrates you, you can use the
Lookup Wizard. The Lookup Wizard comes with Excel, so you don't need to download it (but Excel may
prompt you to install it the first time you try to use it). The wizard uses the INDEX and MATCH
functions (instead of VLOOKUP and HLOOKUP) to return records.

Unlike the lookup functions, the INDEX function requires you to specify row and column labels. The
INDEX function also returns values from unsorted lists.

The MATCH function determines the row that contains the desired value. You can use INDEX and
MATCH to enter more than one search term and return the value that corresponds to the intersection
of the two terms. For example, the following table contains shipping data for the first three months of
1994, 1995, and 1996.

Units Shipped

January February March
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1994 37 43 61
1995 40 60 52

1996 31 50 64

Using INDEX and MATCH, you can specify multiple search terms such as "1995" and "March." In that
case, the functions would return 52, the value at the intersection of those terms.

The steps in this section explain how to configure Excel to run the Lookup Wizard, and how to use the
wizard.

First, let's configure Excel.

1. On the Tools menu, click Add-Ins.
2. In the Add-Ins dialog box, click Lookup Wizard, and then click OK.

Now let's run the add-in. These steps explain how to duplicate the results you created earlier using the
VLOOKUP function. We'll use values from the Page Views and Pages worksheets, and return a result to
a blank cell on the Page Views worksheet.

1. Open the sample spreadsheet (LookupFunctions.xls) and select the Pages worksheet.
2. On the Tools menu, click Lookup. You should see the following text and cell range in the wizard.

Where iz the range to zearch, including the r
rovey and calumn labels’

| Pages!$A51:5B8539 -] |

If the text seems a bit cryptic, remember that you're defining the location and range of cells
through which the function searches. When you see those values, click Next.
3. Ensure that Page Name appears in the top drop-down box, and then pick a page ID number from
the bottom drop-down box and click Next.
4. Do one of the following:
1. If you want your worksheet to display only the result of your search, click Copy just the
formula to a single cell.
2. If you want the worksheet to display the search result and the parameters used in the
search, click Copy the formula and lookup parameters, and then click Next.
5. Do one of the following:
1. If you chose to display only the search result, enter a reference to a blank cell in the
box, and then click Finish.
2. If you chose to display the result and the lookup parameters, enter references to three
blank cells, and then click Finish.

The wizard performs the lookup and writes the result or results to the cell or cells you referenced in
Step 6.

A final reminder

As you use lookup functions, remember that you're pointing to a data string in one location, telling
Excel to find either a partial or absolute match for that data string in another location, and then telling
Excel to display a third value that lies either next to or near that second value.

HLookup

Searches for a value in the top row of a table or an array (array: Used to build single formulas that
produce multiple results or that operate on a group of arguments that are arranged in rows and
columns. An array range shares a common formula; an array constant is a group of constants used as
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an argument.) of values, and then returns a value in the same column from a row you specify in the
table or array. Use HLOOKUP when your comparison values are located in a row across the top of a
table of data, and you want to look down a specified humber of rows. Use VLOOKUP when your
comparison values are located in a column to the left of the data you want to find.

The H in HLOOKUP stands for "Horizontal."

Syntax

HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

Lookup_value is the value to be found in the first row of the table. Lookup_value can be a value, a
reference, or a text string.

Table_array is a table of information in which data is looked up. Use a reference to a range or a
range name.

1. The values in the first row of table_array can be text, numbers, or logical values.

2. If range_lookup is TRUE, the values in the first row of table_array must be placed in ascending
order: ...-2,-1,0, 1, 2,... , A-Z, FALSE, TRUE; otherwise, HLOOKUP may not give the correct
value. If range_lookup is FALSE, table_array does not need to be sorted.

3. Uppercase and lowercase text are equivalent.

4. You can put values in ascending order, left to right, by selecting the values and then clicking
Sort on the Data menu. Click Options, click Sort left to right, and then click OK. Under Sort
by, click the row in the list, and then click Ascending.

Row_index_num is the row number in table_array from which the matching value will be returned.
A row_index_num of 1 returns the first row value in table_array, a row_index_num of 2 returns the
second row value in table_array, and so on. If row_index_num is less than 1, HLOOKUP returns the
#VALUE! error value; if row_index_num is greater than the number of rows on table_array, HLOOKUP
returns the #REF! error value.

Range_lookup is a logical value that specifies whether you want HLOOKUP to find an exact match or
an approximate match. If TRUE or omitted, an approximate match is returned. In other words, if an
exact match is not found, the next largest value that is less than lookup_value is returned. If FALSE,
HLOOKUP will find an exact match. If one is not found, the error value #N/A is returned.

Remarks

1. If HLOOKUP can't find lookup_value, and range_lookup is TRUE, it uses the largest value that is
less than lookup_value.

2. If lookup_value is smaller than the smallest value in the first row of table_array, HLOOKUP
returns the #N/A error value.

3. If range_lookup is FALSE and lookup_value is text, you can use the wildcard characters,
question mark (?) and asterisk (*), in lookup_value. A question mark matches any single
character; an asterisk matches any sequence of characters. If you want to find an actual
question mark or asterisk, type a tilde (~) before the character.

VLOOKUP

Searches for a value in the first column of a table array and returns a value in the same row from
another column in the table array.

The V in VLOOKUP stands for vertical. Use VLOOKUP instead of HLOOKUP when your comparison
values are located in a column to the left of the data that you want to find.

Syntax
VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)
Lookup_value The value to search in the first column of the table array (array: Used to build single

formulas that produce multiple results or that operate on a group of arguments that are arranged in
rows and columns. An array range shares a common formula; an array constant is a group of
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constants used as an argument.). Lookup_value can be a value or a reference. If lookup_value is
smaller than the smallest value in the first column of table_array, VLOOKUP returns the #N/A error
value.

Table_array Two or more columns of data. Use a reference to a range or a range name. The values
in the first column of table_array are the values searched by lookup_value. These values can be text,
numbers, or logical values. Uppercase and lowercase text are equivalent.

Col_index_num The column number in table_array from which the matching value must be
returned. A col_index_num of 1 returns the value in the first column in table_array; a col_index_num
of 2 returns the value in the second column in table_array, and so on. If col_index_num is:

Less than 1, VLOOKUP returns the #VALUE! error value.

Greater than the number of columns in table_array, VLOOKUP returns the #REF! error value.
Range_lookup A logical value that specifies whether you want VLOOKUP to find an exact match or
an approximate match:

If TRUE or omitted, an exact or approximate match is returned. If an exact match is not found,

the next largest value that is less than lookup_value is returned.

The values in the first column of table_array must be placed in ascending sort order; otherwise,

VLOOKUP may not give the correct value. You can put the values in ascending order by choosing the

Sort command from the Data menu and selecting Ascending. For more information, see Default

sort orders.

If FALSE, VLOOKUP will only find an exact match. In this case, the values in the first column of
table_array do not need to be sorted. If there are two or more values in the first column of
table_array that match the lookup_value, the first value found is used. If an exact match is not
found, the error value #N/A is returned.

To make use of the COUNT Function

Counts the number of cells that contain numbers and counts numbers within the list of arguments. Use
COUNT to get the number of entries in a number field that is in a range or array of numbers.

Syntax

COUNT(valuel, value2,...)

Valuel, value2, ... are 1 to 30 arguments that can contain or refer to a variety of different types of
data, but only numbers are counted.
Remarks

e Arguments that are numbers, dates, or text representation of humbers are counted.

¢ Logical values and text representations of numbers that you type directly into the list of
arguments are counted.
Arguments that are error values or text that cannot be translated into numbers are ignored.
If an argument is an array or reference, only numbers in that array or reference are counted.
Empty cells, logical values, text, or error values in the array or reference are ignored.

e If you want to count logical values, text, or error values, use the COUNTA function.
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TASKS

To make use of the Group and Outline option

Create an Outline

[1]=]5] A E [ C
|| |RegionMonth  Sales

[[#] |4 |Fast  AprTotal n034
[*] |7 East  MarTotal 1075
[#] [10]west AprTotal 3543

- [1|west  Mar 2036

12| west  Mar ER| ]

1 3west  Mar 2,751
14|west | MarTotalig,a00
=]  [i5] All Sales 50,652

This outline lets you show and hide the detail rows for monthly sales.

1.

3.

If your summary rows are above the detail rows, or your summary columns are to the left of
the detail columns, change the direction setting.
How?

1. On the Data menu, point to Group and Outline, and then click Settings.

2. Clear the Summary rows below detail check box, the Summary columns to right
of detail check box, or both check boxes.

If you want to set outline styles (style: A combination of formatting characteristics, such as
font, font size, and indentation, that you name and store as a set. When you apply a style, all
of the formatting instructions in that style are applied at one time.) that will be applied
automatically when the outline is created, set the Automatic styles option.

How?

1. On the Data menu, point to Group and Outline, and then click Settings.

2. Select the Automatic styles check box.

Note If you don't want to apply automatic styles before you begin, you can apply them after
you create the outline.
Decide whether to outline the worksheet automatically or manually.

o You can outline any worksheet manually.

o You can outline worksheets automatically if they have summary formulas that reference
cells in the detail data (detail data: For automatic subtotals and worksheet outlines, the
subtotal rows or columns that are totaled by summary data. Detail data is typically
adjacent to and either above or to the left of the summary data.). All columns containing
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summary formulas must be either to the right or to the left of the detail data, or rows
containing summary formulas must be either below or above the detail data.
If you aren't sure whether your worksheet meets these requirements, try outlining
automatically, and if the results aren't as you expect, undo the operation and outline
manually instead.
4. Do one of the following:
Outline the data automatically
1. Select the range of cells you want to outline.
To outline the entire worksheet, click any cell on the worksheet.
1. On the Data menu, point to Group and Outline, and then click Auto Outline.
Outline the data manually
2. Select the rows or columns that contain detail data.
Detail rows or columns are usually adjacent to the row or column that contains the
summary formula or a heading. For example, if row 6 contains totals for rows 3 through
5, select rows 3 through 5. If row 8 contains a heading that describes rows 9 through
12, select rows 9 through 12.
3. On the Data menu, point to Group and Outline, and then click Group.
The outline symbols (outline symbols: Symbols that you use to change the view of an
outlined worksheet. You can show or hide detailed data by pressing the plus sign, minus
sign, and the numbers 1, 2, 3, or 4, indicating the outline level.) appear beside the
group on the screen.
4. Continue selecting and grouping detail rows or columns until you have created all of the
levels you want in the outline.
5. If you didn't select automatic styles, you can apply styles now.
How?
1. Select the cells that you want to apply outline styles to.
2. On the Data menu, point to Group and Outline, and then click Settings.
3. Select the Automatic styles check box.
4. Click Apply Styles.
Remove an Outline
No data is deleted when you remove an outline.
1. Click the worksheet.
2. On the Data menu, point to Group and Outline, and then click Clear Outline.
3. If rows or columns are still hidden, drag across the visible row or column headings on both
sides of the hidden rows and columns, point to Row or Column on the Format menu, and
then click Unhide.

To calculate subtotals and totals using grouping and outline

You can have Excel calculate subtotals or totals for portions of your worksheet data. For example, in a
worksheet with sales data for three different product categories, you can first sort the products by
category, and then select all the cells that contain data and open the Subtotal dialog box (Data
menu, Subtotals command).
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Subtotal

%]

At each change in:
Week w

Use function:
Surm L4

Add subtotal bo:

|:| Day A
|:| Weekday
W

Replace current subtotals
[] page break bebween groups
Summary below data

[R_emove all ] [ K ] [ Cancel ]

In the Subtotal dialog box, you can choose the column on which to base your subtotals (such as
every change of value in the Week column), the summary calculation that you want to perform, and
the column or columns with values to be summarized. For example (as shown in the previous picture),
you could calculate subtotals for the number of units sold in each category. After you define your
subtotals, they appear in your worksheet.

Ed Microsoft Office Excel 2003 - Sorting

E File Edit “ew Imserk Format  Tools [Data Window  Help

NEH RS RIFE 4GRS

: Arial ~ 10 v|B|I g|§§:§|$ 9
Al - &
]2[3 A | B | ¢ | D E |
1 | Week Day  Weekday Sales
[ [ - |2 [week 1 Man 158
3 [WWeekl 2 Tue 138
4 Weekl 3 Wed 182
_5 |Weeakl 4 Thu 240
B [vWeekl 5 Fri 158
7 [Wveekl B Sat 190
_8 |eekl 7 Sun 243
_ 9 |Weekl Total 1310
[ - |10 [Week2 8 Man 216
11 [WWeek2 9 Tue 161
12 [Weak2 10 Wed 144
13 [¥Week2 11 Thu 201
14 [Week? 12 Fri 136
15 |WWeek2 13 Sat 190
_16 |Mveekz 14 Sun 243
= 17 |[Week2 Total 1291
[ - |18 [Week3 158 Maon 105
18 [WWeek3 16 Tue 202
_20 [Week3 17 Wed 300
21 |WWeek3 18 Thu 5ta]

As the previous picture shows, when you add subtotals to a worksheet, Excel also defines groups
based on the rows used to calculate the subtotals. The groupings form an outline of your worksheet
based on the criteria that you used to create the subtotals. All the rows with furniture products are in
one group, rows with tools are in another, and so on. The outline section at the left of the worksheet
holds controls that you can use to hide or display groups of rows.
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Ed Microsoft Office Excel 2003 - Levels
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[ - | 18 |[Week3 15 Mon §  3.794.00
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- 20 [Week3 17 Wved §  3011.00

There are three types of controls in the outline section:

e Hide detail buttons When the rows in a group are visible, a hide detail button [=lappears next
to the group.

e Show detail buttons When you hide a group of rows, the button next to the group changes
to a show detail button [*/. Clicking a show detail button restores the rows in that group to the
worksheet.

e Level buttons Each of the numbered level buttons [112l3represents a level of organization in a
worksheet; clicking a level button hides all levels of detail below that of the button you clicked.

The following table identifies the three levels of organization in the previous graphic.

Level Description

1 The grand total

2 Subtotals for each group

3 Individual rows in the worksheet

In the worksheet shown in the previous picture, clicking the level 2 button would hide the rows with
data on the sales of individual products, but would leave the row with the grand total (level 1) and all
rows with the subtotals for each product (level 2) visible in the worksheet.

Ed Microsoft Office Excel 2003 - Levels

@ File Edit Miew Insert  Formak  Tools Data wWindow  Help

TAN=R" BENE= REN A A ==~ A R SeRAN-

: Arial - 10 T|BIE|EEEI$% s

A1 - 5
12]= A | B | ¢ | D B
1| Week Day  Weekday Sales

+ 9 |Weekl1 Total b 2274700

+ 17 |Week2 Total § 22B80.00

+| | 25 |Week3 Total b 22090.00

+| 33 |Weekd Total B 21.279.00

+ 37 |Weekd Total § 912900
- 38 |Grand Total $ Sroaennd

i)

For additional flexibility, you can add levels of detail to the outline that Excel creates, which enables
you to hide specific details from time to time. For instance, you might want to hide the sales of
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bamboo barrier, bamboo chimes, and bamboo stakes (which you know sell well) to see how the other
products sell in comparison with each other.

Create a new outline group within an existing group

1. Select the rows you want to group.

2. Point to Group and Outline on the Data menu, and then click Group.

Excel will create a new group on a new level (level 4), as shown in the following picture.

Remove a group

1. Select the rows in a group.

2. Point to Group and Outline on the Data menu, and then click Ungroup.
Tip If you want to remove all subtotals from a worksheet, click Subtotal on the Data menu, and then
click Remove All.
To make use of the Split panes

You can view two areas of a worksheet and lock rows or columns in one area by splitting or freezing
panes (pane: A portion of the document window bounded by and separated from other portions by
vertical or horizontal bars.). When you split panes, you'll be able to scroll in both areas of the
worksheet, while rows or columns in the non-scrolled area remain visible.

When you freeze panes, you select specific rows or columns that remain visible when scrolling in the
worksheet. For example, you would freeze panes to keep row and column labels visible as you scroll,
as shown in the following picture.

City Date Books Sold
Boise har a4
Denver Mar 3
Chicago Feb G0
Dallas Feh 72
Canta Fe [T, ETd 154

Lock rows and columns by splitting panes
1. To lock rows, select the row below where you want the split to appear.
To lock columns, select the column to the right of where you want the split to appear.
To lock both rows and columns, click the cell below and to the right of where you want the split
to appear.
2. On the Window menu, click Split.
3. To remove the split, click Remove Split on the Window menu.

B Tip
For a quick way to split panes, point to the split box at the top of the vertical scroll bar or at the right

end of the horizontal scroll bar.
——Split o

When the pointer changes to a split pointer ~or “, drag the split box down or to the left to the
position you want.
Lock rows and columns by freezing panes
1. To lock rows, select the row below where you want the split to appear.
To lock columns, select the column to the right of where you want the split to appear.
To lock both rows and columns, click the cell below and to the right of where you want the split
to appear.
2. On the Window menu, click Freeze Panes.
3. To unlock rows, click Unfreeze Panes on the Window menu.
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TASK6

Create a PivotTable report

1.

wnN

vk

Open the workbook where you want to create the PivotTable report.

o If you are basing the report on a Web query, parameter query, report template, Office
Data Connection file, or query file, retrieve the data into the workbook, and then click a
cell in the Microsoft Excel list containing the retrieved data.

If the retrieved data is from an OLAP database, or the Office Data Connection returns
the data as a blank PivotTable report, continue with step 6 below.

o If you are basing the report on an Excel list or database, click a cell in the list or
database.

On the Data menu, click PivotTable and PivotChart Report.

In step 1 of the PivotTable and PivotChart Wizard, follow the instructions, and click PivotTable
under What kind of report do you want to create?

Follow the instructions in step 2 of the wizard.

Follow the instructions in step 3 of the wizard, and then decide whether to lay out the report
onscreen or in the wizard.

Usually you can lay out the report onscreen, and this method is recommended. Use the wizard
to lay out the report only if you expect retrieval from a large external data source to be slow, or
you need to set page fields to retrieve data one page at a time. If you aren't sure, try laying
out the report onscreen. You can return to the wizard if necessary.
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6. Do one of the following:
Lay out the report onscreen

1. From the PivotTable Field List window, drag the fields with data that you want to display in

rows to the drop area labeled Drop Row Fields Here.

a. If you don't see the field list, click within the outlines of the PivotTable drop areas, and
make sure Show Field List is pressed in.

b. To see what levels of detail are available in fields that have levels, the click next to the
field.

Drag fields with data that you want to display across columns to the drop area labeled Drop
Column Fields Here.

3. Drag fields that contain the data that you want to summarize to the area labeled Drop Data
Items Here.

a. If you add more than one data field, arrange these fields in the order you want: Right-
click a data field, point to Order on the shortcut menu, and use the commands on the
Order menu to move the field.

Drag fields that you want to use as page fields to the area labeled Drop Page Fields Here.
To rearrange fields, drag them from one area to another. To remove a field, drag it out of the
PivotTable report.

a. To hide the drop area outlines, click a cell outside the PivotTable report.

Note If data is very slow to appear as you lay out the report, click Always Display Items on the
PivotTable toolbar to turn off initial data display. If retrieval is still very slow or error messages
appear, click PivotTable and PivotChart Report on the Data menu, and lay out the report in the
wizard.

Lay out the report in the wizard

If you've exited from the wizard, click PivotTable and PivotChart Report on the Data menu to
return to it.

1. In step 3 of the wizard, click Layout.

2. From the group of field buttons on the right, drag the fields that you want onto the ROW and

COLUMN areas in the diagram.
Drag the fields that contain the data that you want to summarize onto the DATA area.
Drag fields that you want to use as page fields onto the PAGE area.

a. If you want Excel to retrieve data one page at a time, so you can work with large
amounts of source data, double-click the page field, click Advanced, click Query
external data source as you select each page field item, and then click OK twice.
(This option is unavailable for some types of source data, including OLAP databases and
Office Data Connections.)

5. To rearrange fields, drag them from one area to another. Some fields can only be used in some
of the areas; if you drop a field in an area where it can't be used, the field won't appear in the
area.

a. To remove a field, drag it out of the diagram.

b. When you are satisfied with the layout, click OK, and then click Finish.
Ways to customize PivotTable reports
You can customize the appearance and content of a PivotTable report to get the presentation you
need. In a new report, first display the data you want to see, and then work on the appearance.
Adding and removing fields
When you click a PivotTable report, blue drop area guidelines appear along with the PivotTable
toolbar and the PivotTable Field List window, so that you can customize the report.
To add a field, you can drag it from the field list to the area of the report where you want it, or use the
Add To button and dropdown in the field list. To remove a field, drag it out of the report or drag it
back onto the field list. Fields that you remove remain available in the field list.
You can use fields with icons in the field list only as row (row field: A field that's assigned a row
orientation in a PivotTable report. Items associated with a row field are displayed as row labels.),
column (column field: A field that's assigned a column orientation in a PivotTable report. Items
associated with a column field are displayed as column labels.), or page fields (page field: A field that's

N

vk

nalh o
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assigned to a page orientation in a PivotTable or PivotChart report. You can either display a summary
of all items in a page field, or display one item at a time, which filters out the data for all other items.),
and fields with icons only as data fields (data field: A field from a source list, table, or database that
contains data that is summarized in a PivotTable report or PivotChart report. A data field usually
contains numeric data, such as statistics or sales amounts.). If your fields have these icons, each field
can be used in the report only once.

If your fields have icons, you can use any field in any area, and you can add a field to both to the data
area and to one of the row, column, or page areas, or display it more than once in the data area, as
long as you report doesn't have any calculated items (calculated item: An item within a PivotTable field
or PivotChart field that uses a formula you create. Calculated items can perform calculations by using
the contents of other items within the same field of the PivotTable report or PivotChart report.).
You can change the order in which fields appear by dragging them, or in the case of multiple data
fields, by using the Order commands on the PivotTable menu.
Changing the layout

a. Click a column field

b. Drag it to the row area

c. Sport becomes a row field like Region

When you move a field, it retains most settings you've made using the arrow in the field or the
Field Settings command, including page field (page field: A field that's assigned to a page orientation
in a PivotTable or PivotChart report. You can either display a summary of all items in a page field, or
display one item at a time, which filters out the data for all other items.) options and layout settings.
For example, if you set page field settings and move the field to the row area, then later move the
field back to the page area, the settings remain in effect.

Indented and nonindented formats

You can display a PivotTable report in an indented format similar to traditional banded or formatted
database reports, in which the summarized data from each data field (data field: A field from a source
list, table, or database that contains data that is summarized in a PivotTable report or PivotChart
report. A data field usually contains numeric data, such as statistics or sales amounts.) appears in a
single column. New reports are displayed in a nonindented or crosstabulated format, with data field
values in a grid. Switching to indented format may change the layout of the report, and it applies an
autoformat (autoformat: A built-in collection of cell formats such as font size, patterns, and alignment
that you can apply to a range of data. Excel determines the levels of summary and detail in the
selected range and applies the formats accordingly.) to the report.

Use Format Report on the PivotTable toolbar to select an indented or nonindented format. The
autoformats available for other worksheet areas are not available for PivotTable reports.

Indented formats Formats Report 1 through Report 10 are indented formats. Applying these
formats moves all column fields in the report to the row area. Data fields move to the right of row
fields (row field: A field that's assigned a row orientation in a PivotTable report. Items associated with
a row field are displayed as row labels.), and the field names change to omit the summary function
name. For example, Sum of Sales becomes Sales. After you apply a format, you can rearrange the
fields as in any PivotTable report.

Setting indented format manually If you don't want to apply an autoformat, you can move all
column fields to the row area, double-click each row field, click Layout, and then click Show items in
outline form. This setting is retained if you move the field to another area, but the field is displayed
in indented format only when it is in the row area.

Nonindented formats Formats PivotTable Classic and Table 1 through Table 10 are
nonindented, for use with PivotTable reports that have column fields (column field: A field that's
assigned a column orientation in a PivotTable report. Items associated with a column field are
displayed as column labels.). Table 1 through Table 10 move the leftmost row field to the column
area. Table 1 through Table 5 and Table 7 also add a blank line after each item in the outermost row
field.

Character, cell, and nhumber formats
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You can change cell formats in a PivotTable report, such as font, background color, and alignment, as
you do for other worksheet cells. You can set number formats for individual cells or for all cells of a
data field.

Most formatting is retained when you refresh (refresh: To update the contents of a PivotTable or
PivotChart report to reflect changes to the underlying source data. If the report is based on external
data, refreshing runs the underlying query to retrieve new or changed data.) a report or change its
layout, provided the Preserve formatting check box in the PivotTable Options dialog box is
selected. Cell border changes, however, aren't retained.

Changing what's displayed for errors and empty cells Instead of displaying error values, such
as #REF! or #N/A, and blanks for empty cells, you can specify different values for these cells in a
PivotTable report.

Using merged cells By default, the labels for items in outer row and column fields appear left
justified at the top of the item group. You can center the items horizontally and vertically by selecting
the Merge labels check box in the PivotTable Options dialog box.

Adding blank rows between item groups For outer row fields (row field: A field that's assigned a
row orientation in a PivotTable report. Items associated with a row field are displayed as row labels.),
you can add a blank line after each item or its total row.

Removing formats To remove all character and cell formats in a report, use the None format
available from the Format Report command.

Sorting

In a new report, the items (item: A subcategory of a field in PivotTable and PivotChart reports. For
instance, the field "Month" could have items such as "January," "February," and so on.) in each field
appear either in the order received from the source database, or in ascending order.

Refreshing (refresh: To update the contents of a PivotTable or PivotChart report to reflect changes to
the underlying source data. If the report is based on external data, refreshing runs the underlying
query to retrieve new or changed data.) a report places new items at the ends of the rows or columns.
Microsoft Excel uses the following ascending sort order: numbers, text, logical values, error values
such as #REF and #VALUE, and blank cells. When you sort in descending order, Excel sorts in the
reverse order except for blank cells, which are always sorted last. If you want a sorting sequence such
as Jan, Feb, Mar, and so forth, you can use a custom sort order, and you can also define your own
sorting sequence.

If your report has fields organized in levels, you can sort lower-level items together by hiding the
upper levels before you sort. For example, if you display both the Country and City levels, cities are
sorted separately under each country, but if you hide the Country level, you can sort cities from
different countries together.

You can manually reorder items by clicking and dragging the item labels.

Showing and hiding detail

Your options for varying the amount of detail displayed in a report depend on the type of source

data (source data: The list or table that's used to create a PivotTable or PivotChart report. Source data
can be taken from an Excel list or range, an external database or cube, or another PivotTable report.)
the report is based on.

For OLAP (OLAP: A database technology that has been optimized for querying and reporting, instead of
processing transactions. OLAP data is organized hierarchically and stored in cubes instead of tables.)

source data ( and icons in the field list), fields are organized in levels of detail, and you can
display and hide both individual items and entire levels. Summary values are usually calculated on the
OLAP server, so underlying detail records for data values usually aren't available for display. However,
your database may have other information available for items, called property fields (property fields:
independent attributes associated with items, or members, in an OLAP cube. For example, if city items
have size and population properties stored in the server cube, a PivotTable report can display the size
and population of each city.), that you can display or hide. For example, if your database has a City
field, you might be able to display population or climate figures for individual cities.
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For other types of source data ( icons in the field list), you can display and hide individual items
and also display underlying detail records for data values and items, if this option hasn't been disabled.
You can't directly select multiple items in a page field (page field: A field that's assigned to a page
orientation in a PivotTable or PivotChart report. You can either display a summary of all items in a
page field, or display one item at a time, which filters out the data for all other items.), but you can
move the field temporarily to the row or column area, hide some of the items, and move the field back
to the page area, so that the (All) item then displays a summary that omits the hidden items.

For both types of source data, you can automatically display the top or bottom items in a field — for
example, the top ten sales reps or the five least expensive products. If you set this type of display for
an OLAP field, your setting affects only the current level and lower levels in the dimension (dimension:
An OLAP structure that organizes data into levels, such as Country/Region/City for a Geography
dimension. In a PivotTable or PivotChart report, each dimension becomes a set of fields where you can
expand and collapse detail.), and remains in effect only if you don't hide the level you set it for.
Grouping items

You can use grouping to view less detailed summaries — for example, to view data by quarter instead
of week. You can group dates, times, or numbers, and selected items (item: A subcategory of a field in
PivotTable and PivotChart reports. For instance, the field "Month" could have items such as "January,"
"February," and so on.) in a report. Grouping works differently for different types of source

data (source data: The list or table that's used to create a PivotTable or PivotChart report. Source data
can be taken from an Excel list or range, an external database or cube, or another PivotTable report.).
For OLAP (OLAP: A database technology that has been optimized for querying and reporting, instead of
processing transactions. OLAP data is organized hierarchically and stored in cubes instead of tables.)
source data, when you select and group individual items, the rest of the items in the field appear in a
group named Other. The new group and the Other group become another level of detail that you can
show or hide, so that you can still display the individual items that you've grouped. To group items in a
page field, you can move the field temporarily to the row or column area, group the items, and then
move the field back to the page area. You can also select multiple page field items to display as a
combined summary.

For other types of source data (icons in the field list), when you select and group individual items, the
items are combined in a new item named Groupl (which you can rename). You can't display the
individual items unless you ungroup them. The rest of the items in the field are unchanged by adding
the group. While items in a field are grouped, you can't add calculated items (calculated item: An item
within a PivotTable field or PivotChart field that uses a formula you create. Calculated items can
perform calculations by using the contents of other items within the same field of the PivotTable report
or PivotChart report.) to the field. To group items in a page field, you can move the field temporarily to
the row or column area, group the items, and then move the field back to the page area.

Totals, calculations, and formulas

PivotTable and PivotChart reports (PivotChart report: A chart that provides interactive analysis of data,
like a PivotTable report. You can change views of data, see different levels of detail, or reorganize the
chart layout by dragging fields and by showing or hiding items in fields.) provide several types of
calculations. Data fields (data field: A field from a source list, table, or database that contains data
that is summarized in a PivotTable report or PivotChart report. A data field usually contains numeric
data, such as statistics or sales amounts.) use summary functions (summary function: A type of
calculation that combines source data in a PivotTable report or a consolidation table, or when you are
inserting automatic subtotals in a list or database. Examples of summary functions include Sum,
Count, and Average.) to combine values from the underlying source data (source data: The list or
table that's used to create a PivotTable or PivotChart report. Source data can be taken from an Excel
list or range, an external database or cube, or another PivotTable report.). You can also use custom
calculations (custom calculation: A method of summarizing values in the data area of a PivotTable
report by using the values in other cells in the data area. Use the Show data as list on the PivotTable
Field dialog for a data field to create custom calculations. ) to compare data values, or add your own
formulas that use elements of the report or other worksheet data.

+ Display subtotals for individual fields
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1. Double-click the field.

2. Do one of the following:
Subtotal an outer row or column field Click Automatic under Subtotals. To use a
different summary function (summary function: A type of calculation that combines source data

in a PivotTable report or a consolidation table, or when you are inserting automatic subtotals in
a list or database. Examples of summary functions include Sum, Count, and Average.) or
display more than one type of subtotal, click the summary function you want in the box to the
right of Custom (this option is unavailable for some types of source data (source data: The list
or table that's used to create a PivotTable or PivotChart report. Source data can be taken from
an Excel list or range, an external database or cube, or another PivotTable report.)).
Subtotal an inner row or column field Click Custom under Subtotals, if this option is
available, and then click a summary function in the box to the right.
Remove subtotals Click None under Subtotals.
Note If a field contains a calculated item (calculated item: An item within a PivotTable field or
PivotChart field that uses a formula you create. Calculated items can perform calculations by
using the contents of other items within the same field of the PivotTable report or PivotChart
report.), you can't change the subtotal summary function.
= Tip
For outer row fields (row field: A field that's assigned a row orientation in a PivotTable report.
Items associated with a row field are displayed as row labels.), you can display subtotals above
or below their items. Double-click the field, click Layout, click Show items in outline form,
and then select or clear the Display subtotals at top of group check box.

=+ Display grand totals for the entire report

1. Click the report.

2. On the PivotTable toolbar (toolbar: A bar with buttons and options that you use to carry out
commands. To display a toolbar, click Customize on the Tools menu, and then click the
Toolbars tab.), click PivotTable, and then click Table Options.

3. Do one of the following:

Display grand totals Select the Grand totals for columns check box, the Grand totals
for rows check box, or both.
Hide grand totals Clear either or both check boxes.
Note Grand totals for a field use the same summary function (summary function: A type of
calculation that combines source data in a PivotTable report or a consolidation table, or when
you are inserting automatic subtotals in a list or database. Examples of summary functions
include Sum, Count, and Average.) as the subtotals for the field.

=~ Calculate the totals with or without hidden items

1. Click the report.

2. On the PivotTable toolbar (toolbar: A bar with buttons and options that you use to carry out
commands. To display a toolbar, click Customize on the Tools menu, and then click the

Toolbars tab.), click Include Hidden Items in Totals

If this button is unavailable, your source data allows you to include or exclude hidden items in
page fields (page field: A field that's assigned to a page orientation in a PivotTable or
PivotChart report. You can either display a summary of all items in a page field, or display one
item at a time, which filters out the data for all other items.): click PivotTable, click Table
Options, and then select or clear the Subtotal hidden page items check box.

1. the data field (data field: A field from a source list, table, or database that contains data that is
summarized in a PivotTable report or PivotChart report. A data field usually contains numeric
data, such as statistics or sales amounts.) or a cell in the data area.

For a PivotChart report (PivotChart report: A chart that provides interactive analysis of data,
like a PivotTable report. You can change views of data, see different levels of detail, or
reorganize the chart layout by dragging fields and by showing or hiding items in fields.), work
in the associated PivotTable report (associated PivotTable report: The PivotTable report that
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supplies the source data to the PivotChart report. It is created automatically when you create a
new PivotChart report. When you change the layout of either report, the other also changes.).
On the PivotTable toolbar (toolbar: A bar with buttons and options that you use to carry out
commands. To display a toolbar, click Customize on the Tools menu, and then click the

Toolbars tab.), click Field Settings .

In the Summarize by box, click the summary function (summary function: A type of
calculation that combines source data in a PivotTable report or a consolidation table, or when
you are inserting automatic subtotals in a list or database. Examples of summary functions
include Sum, Count, and Average.) you want to use.

For some types of source data (source data: The list or table that's used to create a PivotTable
or PivotChart report. Source data can be taken from an Excel list or range, an external
database or cube, or another PivotTable report.), and for calculated fields (calculated field: A
field in a PivotTable report or PivotChart report that uses a formula you create. Calculated fields
can perform calculations by using the contents of other fields in the PivotTable report or
PivotChart report.) and fields with calculated items (calculated item: An item within a
PivotTable field or PivotChart field that uses a formula you create. Calculated items can perform
calculations by using the contents of other items within the same field of the PivotTable report
or PivotChart report.), you can't change the summary function.

If you want to use a custom calculation (custom calculation: A method of summarizing values in

the data area of a PivotTable report by using the values in other cells in the data area. Use the
Show data as list on the PivotTable Field dialog for a data field to create custom calculations.),
click Options, click the calculation you want in the Show data as list, and then select a Base
field and Base item, if these options are available for the calculation you chose, to provide the
data for the calculation. The base field should not be the same one you chose in step 1.

Note Setting Show data as to Normal turns off custom calculation.

If the report has multiple data fields, repeat these steps for each one that you want to change.
If your source data allows you to change the summary function, you can use more than one
summary method for the same field. Drag the field from the PivotTable Field List window to
the data area a second time, and then repeat the steps above for the second instance of the
field.

Note When you change the summary method in a PivotChart report or its associated PivotTable
report, some chart formatting may be lost.
Change the amount of detail displayed in a PivotTable report

1.

Determine what kind of source data (source data: The list or table that's used to create a
PivotTable or PivotChart report. Source data can be taken from an Excel list or range, an
external database or cube, or another PivotTable report.) your report has: click the report, if
the field list is not displayed click Show Field List on the PivotTable toolbar, and look at the
PivotTable Field List window.

For OLAP reports, display or hide different levels of detail for a field.

How?

1. Click the field.

2. To display or hide lower-level detail, click Show Detail or Hide Detail on the
PivotTable toolbar.

3. To hide upper levels of detail, right-click the field button (field button: Button that
identifies a field in a PivotTable or PivotChart report. You can drag the field buttons to
change the layout of the report, or click the arrows next to the buttons to change the
level of detail displayed in the report.) for the lowest level you want to hide, and then
click Hide levels on the shortcut menu.

The level you clicked and all higher levels in the dimension (dimension: An OLAP
structure that organizes data into levels, such as Country/Region/City for a Geography
dimension. In a PivotTable or PivotChart report, each dimension becomes a set of fields
where you can expand and collapse detail.) are removed from view, and the dropdown
arrow is also hidden.
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To redisplay hidden upper levels, right-click any field button in the dimension, and then
click Show levels on the shortcut menu.

For non-OLAP reports, do one or more of the following:
Display or hide detail data for an item
1. Click the item.

2. On the PivotTable toolbar, click Show Detail or Hide Detail
3. If prompted, click the field that has the detail data you want to see.
Display or hide detail for a data cell

1. Double-click a cell in the data area (data area: The part of a PivotTable report that
contains summary data. Values in each cell of the data area represent a summary of
data from the source records or rows.).
Microsoft Excel places the detail data summarized in the cell on a new worksheet.

2. To hide the detail data, delete the new worksheet.

2. For OLAP reports, display or hide property fields (property fields: independent attributes
associated with items, or members, in an OLAP cube. For example, if city items have size and
population properties stored in the server cube, a PivotTable report can display the size and
population of each city.), if available from your server cube.

How?
1. Click the field in the dimension for which you want to display property fields.
2. On the PivotTable toolbar, click PivotTable, and then click Property Fields.
3. In the Choose properties from level list, click each level for which you want to display
property fields, and then double-click the property fields you want to see.
4. In the Properties to display box, use the and buttons to arrange the

property fields in the order you want them to appear in the report.

5. Make sure the Show fields for this dimension in outline form check box is selected,
and then click OK.

6. If the levels for which you selected property fields aren't displayed in the report, click

the field and then click Show Detail on the PivotTable toolbar.
Group items in a PivotTable or PivotChart field
1. 1If the field is a page field (page field: A field that's assigned to a page orientation in a
PivotTable or PivotChart report. You can either display a summary of all items in a page field, or
display one item at a time, which filters out the data for all other items.), check the page field
settings, and then move it temporarily to the row or column area.
How?
For a PivotChart report, work in the associated PivotTable report (associated PivotTable report:
The PivotTable report that supplies the source data to the PivotChart report. It is created
automatically when you create a new PivotChart report. When you change the layout of either
report, the other also changes.).
1. Double-click the page field.
2. Click Advanced.
3. Make sure the Retrieve external data for all page field items option is either
selected or unavailable.
4. Click OK twice.
5. Drag the page field to the row or column area.
2. Do one of the following:

Group numeric items
1. Right-click the field with the numeric items, point to Group and Show Details on the
shortcut menu, and then click Group.
2. In the Starting at box, enter the first item to group.
3. In the Ending at box, enter the last item to group.
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4. In the By box, type the number of items that you want in each group.

Group dates or times

5. Right-click the field with the dates or times, point to Group and Show Details on the
shortcut menu, and then click Group.

6. Enter the first date or time to group in the Starting at box, and enter the last date or
time to group in the Ending at box.

7. In the By box, click one or more time periods for the groups.
To group items by weeks, click Days in the By box, make sure Days is the only time
period selected, and then click 7 in the Number of days box. You can then click
additional time periods to group by, such as Month, if you want.

Group selected items
8. Select the items to group, either by clicking and dragging, or by holding down CTRL or
SHIFT while you click.
For a PivotChart report, select the items in the associated PivotTable report (associated
PivotTable report: The PivotTable report that supplies the source data to the PivotChart
report. It is created automatically when you create a new PivotChart report. When you
change the layout of either report, the other also changes.).
9. Right-click the selected items, point to Group and Show Details on the shortcut menu,
and then click Group.
Note For fields organized in levels, you can only group items that all have the same next-level
item. For example, if the field has levels Country and City, you can't group cities from different
countries.

Ungroup items
o Right-click the group, point to Group and Show Details on the shortcut menu, and
then click Ungroup.
In a numeric or date/time field, right-click any group; Excel then ungroups all groups for
the field.
3. If the field was formerly a page field, drag it back to the page area.

Print a PivotTable report
1. If you have more than one PivotTable report on the worksheet, set a print area that includes
only the report you want to print.
How?
1. Click the report.
2. On the PivotTable toolbar, click PivotTable, point to Select, and then click Entire
Table.
3. On the File menu, point to Print Area, and then click Set Print Area.
2. On the File menu, click Page Setup, and adjust the page settings, sheet settings, margins,
and headers and footers.
3. If you want to repeat the row and column labels from the report on each page as print titles,
clear the Rows to repeat at top and Columns to repeat at left boxes, and then set
PivotTable print titles.

How?
1. On the PivotTable toolbar, click PivotTable, and then click Table Options.
2. Under Format options, select the Set print titles check box.
3. If your report has more than one row field and you also want to repeat outer row field

items on each page, select the Repeat item labels on each printed page check box.
4. If your report has more than one row field and you want automatic page breaks after each item
in one or more outer row fields, set these page breaks.
How?
1. Double-click the outer row field that has the items you want to print on separate pages.
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2. Click Layout.
3. Select the Insert page break after each item check box.
5. On the View menu, click Page Break Preview, and make any adjustments you want to the
page breaks.
You can insert new manual page breaks and move and delete automatic page breaks.
6. On the File menu, click Print Preview, and check your print layout. To make adjustments, you
can repeat any of the previous steps as needed.
7. When the preview looks correct, click Print

Custom calculations for PivotTable and PivotChart data fields
The following functions are available for custom calculations in data fields.
Function Result
Difference From Displays data as the difference from the value of the Base item in
the Base field.

% Of Displays data as a percentage of the value of the Base item in the
Base field.

% Difference Displays data as the percentage difference from the value of the

From Base item in the Base field.

Running Total in Displays the data for successive items in the Base field as a running
total.

% Of Row Displays the data in each row or category as a percentage of the total

for the row or category.
% Of Column Displays all the data in each column or series as a percentage of the
total for the column or series.

% Of Total Displays data as a percentage of the grand total of all the data or
data points in the report.
Index Calculates data as follows:

((value in cell) x (Grand Total of Grand Totals)) / ((Grand Row Total)
x (Grand Column Total))

Delete a PivotTable or PivotChart formula

For best results in a PivotChart report (PivotChart report: A chart that provides interactive analysis of
data, like a PivotTable report. You can change views of data, see different levels of detail, or
reorganize the chart layout by dragging fields and by showing or hiding items in fields.), work in the
associated PivotTable report (associated PivotTable report: The PivotTable report that supplies the
source data to the PivotChart report. It is created automatically when you create a new PivotChart
report. When you change the layout of either report, the other also changes.).

1. Determine whether the formula is in a calculated field (calculated field: A field in a PivotTable
report or PivotChart report that uses a formula you create. Calculated fields can perform
calculations by using the contents of other fields in the PivotTable report or PivotChart report.)
or a calculated item (calculated item: An item within a PivotTable field or PivotChart field that
uses a formula you create. Calculated items can perform calculations by using the contents of
other items within the same field of the PivotTable report or PivotChart report.).

Calculated fields appear in the PivotTable Field List window. Calculated items appear as
items (item: A subcategory of a field in PivotTable and PivotChart reports. For instance, the
field "Month" could have items such as "January," "February," and so on.) within other fields.

2. Do one of the following:

Delete a calculated field
1. Click the report.
2. On the PivotTable toolbar (toolbar: A bar with buttons and options that you use to
carry out commands. To display a toolbar, use the Customize dialog box (point to
Toolbars on the View menu and click Customize). To see more buttons, click Toolbar
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Options at the end of the toolbar.), click PivotTable or PivotChart, point to
Formulas, and then click Calculated Field.
3. In the Name box, click the field you want to delete.
4. Click Delete.

Delete a calculated item
5. Click the field with the item you want to delete.
6. On the PivotTable toolbar (toolbar: A bar with buttons and options that you use to
carry out commands. To display a toolbar, use the Customize dialog box (point to
Toolbars on the View menu and click Customize). To see more buttons, click Toolbar
Options at the end of the toolbar.), click PivotTable or PivotChart, point to
Formulas, and then click Calculated Item.
7. In the Name box, click the item you want to delete.
8. Click Delete.
Note When you delete a formula from a PivotChart report or its associated PivotTable report, some
chart formatting may be lost.
Tip
If you don't want to delete a formula permanently, you can hide the field or item. To hide a field, drag
it out of the report, or click the dropdown arrow in the Data field and then clear its check box; it
remains available in the field list. To hide an item, click the dropdown arrow in its field, and then clear
the check box for the item.
Making use of Field buttons
Hiding the field buttons (field button: Button that identifies a field in a PivotTable or PivotChart report.
You can drag the field buttons to change the layout of the report, or click the arrows next to the
buttons to change the level of detail displayed in the report.) also hides the page field drop area (drop
area: An area in a PivotTable or PivotChart report where you can drop fields from the Field List dialog
box to display the data in the field. The labels on each drop area indicate the types of fields you can
create in the report.), if your report doesn't have any page fields (page field: A field that's assigned to
a page orientation in a PivotTable or PivotChart report. You can either display a summary of all items
in a page field, or display one item at a time, which filters out the data for all other items.).

1. Click the PivotChart report.

2. On the PivotTable toolbar (toolbar: A bar with buttons and options that you use to carry out
commands. To display a toolbar, click Customize on the Tools menu, and then click the
Toolbars tab.), click PivotChart, and then select or clear the Hide PivotChart Field Buttons
command.

= Tip
If you hide field buttons but want to label elements of your chart that were previously identified by
field button names, you can add axis titles or text boxes to the chart.

To make data entry easier, or to limit entries to certain items that you define, you can create a drop-
down list that gets its choices from cells elsewhere on the worksheet.

1. Type the entries for the drop-down list in a single column or row. Do not include blank cells in
the list.
If you type the list on a different worksheet from the data entry cell, define a name (name: A
word or string of characters that represents a cell, range of cells, formula, or constant value.
Use easy-to-understand names, such as Products, to refer to hard to understand ranges, such
as Sales!C20:C30.) for the list.
¢ How?

1. Select the cell, range of cells, or nonadjacent selections (nonadjacent selection: A
selection of two or more cells or ranges that don't touch each other. When plotting
nonadjacent selections in a chart, make sure that the combined selections form a
rectangular shape.) that you want to name.
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2. Click the Name box at the left end of the formula bar (formula bar: A bar at the top of
the Excel window that you use to enter or edit values or formulas in cells or charts.
Displays the constant value or formula stored in the active cell.) I%
Locs - e
1 Name box
3. Type the name for the cells.
4. Press ENTER.
b How?
1. Open the workbook that contains the list of drop-down entries.
2. Open the workbook where you want to validate cells, point to Name on the Insert
menu, and then click Define.
3. In the Names in workbook box, type the name.
4. In the Refers to box, delete the contents, and keep the insertion pointer in the box.
5. On the Window menu, click the name of the workbook that contains the list of drop-
down entries, and then click the worksheet that contains the list.
6. Select the cells containing the list.
7. In the Define Name dialog box, click Add, and then click Close.
Select the cell where you want the drop-down list.
On the Data menu, click Validation, and then click the Settings tab.
In the Allow box, click List.
If the list is in the same worksheet, enter a reference to your list in the Source box.
If the list is elsewhere, enter the name you defined for your list in the Source box.
Make sure the reference or name is preceded with an equal sign (=).
Make sure the In-cell drop-down check box is selected.
Specify whether the cell can be left blank: Select or clear the Ignore blank check box.
To display optional input instructions when the cell is clicked, click the Input Message tab,
make sure the Show input message when cell is selected check box is selected, and then
fill in the title and text for the message.
9. Specify how you want Microsoft Excel to respond when invalid data is entered.
B How?
1. Click the Error Alert tab, and make sure the Show error alert after invalid data is
entered check box is selected.
2. Select one of the following options for the Style box:
To display an information message that does not prevent entry of invalid data, click
Information.
To display a warning message that does not prevent entry of invalid data, click
Warning.
To prevent entry of invalid data, click Stop.
3. Fill in the title and text for the message (up to 225 characters).
Note If you don't enter a title or text, the title defaults to " Microsoft Excel" and the
message to: "The value you entered is not valid. A user has restricted values that can be
entered into this cell."
Importing data
~ Importing data from databases and files
You can import data to Excel from most data sources by pointing to Import External Data on the
Data menu, clicking Import Data, and then choosing the data you want to import in the Select Data
Source dialog box.
The Data Connection Wizard, available when you click New Source in the Select Data Source dialog
box, makes it possible to import data from external data connections not available from the Select
Data Source dialog box. These sources may include OLE DB data sources (including OLAP cubes and
exchange servers) and any data sources a system administrator supplies. You cannot filter or join data
in the Data Connection Wizard.
The default connection method when you import data using the Data Connection Wizard is through
OLE DB providers. The resulting .odc (office data connection) files can be opened for viewing in

uhn
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Internet Explorer and edited in Excel, Notepad, and other Microsoft Office applications if the file
doesn't point to an OLAP data source.

The Data Connection Wizard also provides access to a data source called a data retrieval service. A
data retrieval service is a Web service installed on Windows SharePoint Services for connecting to and
retrieving data. To use a data retrieval service, a client application, such as Excel, sends a query
request over HTTP (HTTP: Internet protocol that delivers information on the World Wide Web. Makes it
possible for a user with a client program to enter a URL (or click a hyperlink) and retrieve text,
graphics, sound, and other digital information from a Web server.) to the data retrieval service on
Windows SharePoint Services. The data retrieval service sends that request to the data source, and
then passes the data that is returned to it back to the client application as XML. Importing data from a
data retrieval service in Excel automatically creates a databound XML list in your worksheet. After
adding a databound XML list to your worksheet, you can use the commands on the XML submenu of
the Data menu or the List tool bar to refresh data, edit the query, or set the properties of the XML
map associated with the XML list.

A default installation of Windows SharePoint Services provides a data retrieval service for connecting
to data in SharePoint lists. A SharePoint site administrator can install the Microsoft Office Web Parts
and Components to add additional data retrieval services for Microsoft SQL Server and Microsoft
Business Solutions. The installation program for Microsoft Office Web Parts and Components is
available on the Downloads on Microsoft Office Online.

~ Importing data with Microsoft Query

In most cases, you can import data by using the Import Data command as described in the section
above. Use Query or another program only if you need to perform specialized query tasks such as the
following:

e Filter rows or columns of data before they are brought into Excel.

e Create a parameter query (parameter query: A type of query that, when you run it, prompts for
values (criteria) to use to select the records for the result set so that the same query can be
used to retrieve different result sets.).

e Sort data before it is brought into Excel.

e Join multiple tables.

Microsoft Query provides a simple front end, easily accessible from within Excel, to perform these
specialized query tasks.

You can use Query to set up ODBC data sources to retrieve data. In Query, you can use the Query
Wizard to create a simple query (query: In Query or Access, a means of finding the records that
answer a particular question you ask about the data stored in a database.), or you can use advanced
criteria in Query to create a more complex query. You can access Query from Excel, or you can create
a query from within the PivotTable and PivotChart Wizard.

You can also use Dynamic Data Exchange (DDE) (Dynamic Data Exchange (DDE): An established
protocol for exchanging data between Microsoft Windows-based programs.) with Query. For more
information about DDE, see Query Help.

To import data using Query, you must first:

e Install Query Query, including the Query Wizard, is an optional feature for Excel. Under
most circumstances, you are prompted to install Query when you point to Import External
Data on the Data menu and click New Database Query.

e Install ODBC drivers An ODBC driver (Open Database Connectivity (ODBC) driver: A
program file used to connect to a particular database. Each database program, such as Access
or dBASE, or database management system, such as SQL Server, requires a different driver.) is
required to retrieve data in relational databases, text files, or Excel using Query. When you
install Query, you automatically install a set of ODBC drivers. If you use a driver other than one
installed with Query, you must install the driver separately.

o Install data source drivers A data source driver (data source driver: A program file used
to connect to a specific database. Each database program or management system requires a
different driver.) is required to retrieve OLAP source data. Query supports connecting to
databases that are created by using SQL Server OLAP Services; when you installed Query, you
automatically installed support for this type of OLAP database. To connect to other OLAP
databases, you must install a data source driver and client software.
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For more information, see Query Help.
+ Importing data from the Web
You can import data originating from a Web page by pointing to Import External Data on the Data
menu and clicking New Web Query. You must have access to the World Wide Web (World Wide Web
(WWW): The multimedia branch of the Internet that presents not only text, but also graphics, sound,
and video. On the Web, users can easily jump from item to item, page to page, or site to site by using
hyperlinks.) through your company's intranet or through a modem on your computer or network, or
you can make a query against local HTML or XML sources.
~ Importing data with Visual Basic for Applications (VBA)
You can use a Visual Basic for Applications (VBA: A macro-language version of Microsoft Visual Basic
that is used to program Windows applications and is included with several Microsoft applications.)
macro (macro: An action or a set of actions you can use to automate tasks. Macros are recorded in the
Visual Basic for Applications programming language.) to gain access to an external data source.
Depending on the data source, you will use either ActiveX Data Objects (ActiveX Data Objects (ADQO):
A data access interface that communicates with OLE DB-compliant data sources to connect to,
retrieve, manipulate, and update data.) or Data Access Objects (Data Access Objects (DAQ): A data
access interface that communicates with Microsoft Jet and ODBC-compliant data sources to connect to,
retrieve, manipulate, and update data and the database structure.) to retrieve data using VBA.
If you want to use a macro that you created in Excel version 5.0 or earlier, click Add-Ins on the Tools
menu, and then make sure the ODBC Add-In check box is selected.
For information about creating Visual Basic for Applications macros, see Visual Basic Help (Microsoft
V|suaI BaS|c HeID To qet help for Visual Basic in ExceI point to Macro on the Tools menu, and then

Note While you are recordlng a macro that includes a query, Excel can't run the query in the
background, even if you chose to run it that way. To change the recorded macro so that it runs in the
background, edit the macro in the Visual Basic Editor and change the refresh method for the
QueryTable object from "BackgroundQuery := False" to "BackgroundQuery := True".

Refreshing data and naming ranges

+ Refreshing data

Excel provides many options for refreshing imported data, including refreshing the data whenever you
open the workbook and automatically refreshing data at timed intervals. You can continue to work in
Excel while data is being refreshed, and you can also check the status of the refresh while it's being
refreshed.

If your external data source (data source: A stored set of "source" information used to connect to a
database. A data source can include the nhame and location of the database server, the name of the
database driver, and information that the database needs when you log on.) requires a

password (password: A word, phrase, or string of characters used to prevent unauthorized access to a
database. To gain access to the database, you must enter the password correctly.) to gain access to
the data, you can require that the password is entered each time the external data range (external
data range: A range of data that is brought into a worksheet but that originates outside of Excel, such
as in a database or text file. In Excel, you can format the data or use it in calculations as you would
any other data.) is refreshed.

When an external data range expands and additional records are returned, Excel can fill formulas in
adjacent columns or within the data range so that they remain next to the appropriate data.

You can also choose how to add new data to your worksheet.

<+ Naming external data ranges

Excel automatically names an external data range as follows:

e External data ranges from Office Data Connection (Office Data Connection (ODC) file: A file that
stores information about a connection to a data source (such as an OLE DB data source) and
the data associated with the connection.) (ODC) files are named with the .odc file extension.

e External data ranges from databases are named with the name of the query; by default
Query_from_source is the name of the data source you used to create the query.

e External data ranges from text files are named with the text file name.
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e External data ranges from Web queries (Web query: A query that retrieves data stored on your
intranet or&nbsp;the Internet.) are named with the name of the Web page from which the data
was retrieved.
If your worksheet has more than one external data range from the same source, the ranges are
numbered. For example, MyText, MyText_1, MyText_2, and so on.
You can also change the name of an external data range in the Data Range Properties dialog box
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TASKY7

To make use of the Filtering Concept

Filtering is a quick and easy way to find and work with a subset of data in a range. A filtered range
displays only the rows that meet the criteria (criteria: Conditions you specify to limit which records are
included in the result set of a query or filter.) you specify for a column. Microsoft Excel provides two
commands for filtering ranges: AutoFilter and Advanced Filter.

Unlike sorting, filtering does not rearrange a range. Filtering temporarily hides rows you do not want
displayed. When Excel filters rows, you can edit, format, chart, and print your range subset without
rearranging or moving it.

Use AutoFilter for simple criteria and to filter by selection

When you use the AutoFilter command, AutoFilter arrows E|appear to the right of the column labels
in the filtered range.
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1 Unfiltered range

2Filtered range

Microsoft Excel indicates the filtered items with blue.

You use custom AutoFilter to display rows that contain either one value or another. You can also use
custom AutoFilter to display rows that meet more than one condition for a column; for example, you
might display rows that contain values within a specific range (such as a value of Davolio).

+Top of Page
Use Advanced Filter for more complex criteria

The Advanced Filter command on the Data menu lets you use complex criteria (criteria: Conditions
you specify to limit which records are included in the result set of a query. For example, the following
criterion selects records for which the value for the Order Amount field is greater than 30,000: Order
Amount &gt; 30000.) to filter a range, but it works differently from the AutoFilter command in
several important ways.
e It displays the Advanced Filter dialog box instead of the Custom AutoFilter dialog box.
¢ You do not type the complex criteria in the Advanced Filter dialog box as you do in the
Custom AutoFilter dialog box. Rather, you type the complex criteria in a criteria range on the
worksheet and above the range you want to filter. Excel uses the separate criteria range in the
Advanced Filter dialog box as the source for the complex criteria.
e Although you can filter a range in place, like the AutoFilter command, the Advanced Filter
command does not display drop-down lists for the columns.
Filter for unique records
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e Select the column or click a cell in the range or list you want to filter.
e On the Data menu, point to Filter, and then click Advanced Filter.
e Do one of the following.
o To filter the range or list in place, similar to using AutoFilter, click Filter the list, in-
place.
o To copy the results of the filter to another location, click Copy to another location.
Then, in the Copy To box, enter a cell reference.

To select a cell, click Collapse Dialog to temporarily hide the dialog box. Select the

cell on the worksheet, and then press Expand Dialog .
e Select the Unique records only check box.
Note Once you filter for unique values, you can copy them to another worksheet and then archive or
delete the original worksheet.
Filters for different type of data cells
~ Filter for the smallest or largest number
1. Click the arrow [=lin the column that contains the numbers, and click (Top 10...).
2. In the box on the left, click Top, or Bottom.
3. In the box in the middle, enter a number.
4. 1In the box on the right, click Items.
=~ Filter a range for rows that contain specific text
1. Click the arrow [=lin the column that contains the numbers, and click (Custom).
2. In the box on the left, click equals, or does not equal, contains, or does not
contain.
3. In the box on the right, enter the text you want.
4. If you need to find text values that share some characters but not others, use a wildcard
character.
+ How?
The following wildcard characters can be used as comparison criteria (criteria:
Conditions you specify to limit which records are included in the result set of a query or
filter.) for filters, and when searching and replacing content.

Use To find

Any single character

? (question mark) For example, sm?th finds "smith" and
"smyth"
Any number of characters

* (asterisk) For example, *east finds "Northeast" and
"Southeast"

~ (tilde) followed by ?, *, A question mark, asterisk, or tilde

or ~ For example, fy91~? finds "fy91?"

1. To add another criteria, click And or Or, and repeat the previous step.
= Filter for blank or nonblank cells
Click the arrow [=lin the column that contains the numbers, then click (Blanks) or
(NonBlanks).
Note The Blanks and NonBlanks options are available only if the column you want to filter
contains a blank cell.
+ Filter for numbers greater than or less than another number
1. Click the arrow [®lin the column that contains the numbers, and click (Custom).
2. In the box on the left, click is greater than, is less than, is greater than or equal
to, or is less than or equal to.
3. In the box on the right, enter a number.
4. To add another criteria, click And or Or, and repeat the previous step.
= Filter for a number equal to or not equal to another number
1. Click the arrow [=lin the column that contains the numbers, and click (Custom).
2. In the box on the left, click equals, or does not equal.

AURORAS'S TECHNOLOGICAL AND RESEARCH INSTITUTE

11




ITWS Lab Department of Computer Science and Engineering
3. In the box on the right, enter a number.
4. To add another criteria, click And or Or, and repeat the previous step.
= Filter for the beginning or end of a text string
1. Click the arrow [=lin the column that contains the numbers, and click (Custom).
2. In the box on the left, click begins with, or does not begin with, or ends with, or
does not end with.
3. In the box on the right, enter the text you want.
4. If you need to find text values that share some characters but not others, use a wildcard
character.
~ How?
The following wildcard characters can be used as comparison criteria (criteria:
Conditions you specify to limit which records are included in the result set of a query or
filter.) for filters, and when searching and replacing content.

Use To find

Any single character

? (question mark) For example, sm?th finds "smith" and
"smyth"
Any number of characters

* (asterisk) For example, *east finds "Northeast" and
"Southeast"

~ (tilde) followed by ?, *, A question mark, asterisk, or tilde

or ~ For example, fy91~7? finds "fy91?"

1. To add another criteria, click And or Or, and repeat the previous step.
= Filter for the top or bottom numbers by percent
1. Click the arrow [®lin the column that contains the numbers, and click (Top 10...).
2. In the box on the left, click Top or Bottom.
3. In the box in the middle, enter a number.
4. In the box on the right, click Percent.
Notes
e When you apply a filter to a column, the only filters available for other columns are the values
visible in the currently filtered range.
¢ Only the first 1000 unique entries in a list appear when you click the arrow [=].

To Protect Workbook

To allow only authorized users to view or modify your data, you can help secure your entire workbook
file with a password (password: A way to restrict access to a workbook, worksheet, or part of a
worksheet. Excel passwords can be up to 255 letters, numbers, spaces, and symbols. You must type
uppercase and lowercase letters correctly when you set and enter passwords.).

1. On the File menu, click Save As.

2. On the Tools menu, click General Options.

3. Do either or both of the following:

o If you want users to enter a password (password: A way to restrict access to a
workbook, worksheet, or part of a worksheet. Excel passwords can be up to 255 letters,
numbers, spaces, and symbols. You must type uppercase and lowercase letters correctly
when you set and enter passwords.) before they can view the workbook, type a
password in the Password to open box, and then click OK.

o If you want users to enter a password before they can save changes to the workbook,
type a password in the Password to modify box.

Note Unlike passwords you specify in the Password to open box, passwords you specify in
the Password to modify box are not encrypted. These passwords are only meant to give
specific users permission to modify workbook data. For optimal password security, it's best to
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assign both passwords. An encrypted password to access the workbook, and one to provide
specific users with permission to modify its content.

Important Use strong passwords that combine uppercase and lowercase letters, numbers,
and symbols. Weak passwords don't mix these elements. Strong password: Yédh!et5. Weak
password: House27. Use a strong password that you can remember so that you don't have to
write it down.

4. If you want to use a different encryption type, click Advanced, click the type you want in the
Choose an encryption type list, and then click OK.

5. If needed, specify the number of characters you want in the Choose a key length box.

Note Document property encryption is enabled by default for most encryption types and

providers. It prevents unauthorized users from viewing summary and custom file properties

(such as the author or any custom file information) in the Properties dialog box. When users

right-click the password-protected file, and then click Properties, information won't be

available on the Summary tab and Custom tab. Authorized users, however, can open the file
and view all file properties (File menu, Properties command). To disable document property
encryption, clear the Encrypt document properties check box.

Click OK.

When prompted, retype your passwords to confirm them.

Click Save.

. If prompted, click Yes to replace the existing workbook.

Note You can also secure a workbook with a password on the Security tab of the Options dialog box

(Tools menu, Options command).

©®NO

Workbook elements

+ Protect workbook elements
1. On the Tools menu, point to Protection, and then click Protect Workbook.
2. Do one or more of the following:

o To protect the structure of a workbook so that worksheets in the workbook can't be
moved, deleted, hidden, unhidden, or renamed, and new worksheets can't be inserted,
select the Structure check box.

o To protect windows so that they are the same size and position each time the workbook
is opened, select the Windows check box.

o To prevent others from removing workbook protection, type a password, click OK, and
then retype the password to confirm it.

+ Protect elements in a shared workbook
1. 1If the workbook is already shared (shared workbook: A workbook set up to allow multiple users
on a network to view and make changes at the same time. Each user who saves the workbook
sees the changes made by other users.), and you want to assign a password to protect the
sharing, unshare the workbook.
+ How?

1. Have all other users save and close the shared workbook. If other users are editing,
they will lose any unsaved work.

2. Unsharing the workbook deletes the change history (change history: In a shared
workbook, information that is maintained about changes made in past editing sessions.
The information includes the name of the person who made each change, when the
change was made, and what data was changed.). If you want to keep a copy of this
information, print out the History worksheet (History worksheet: A separate worksheet
that lists changes being tracked in a shared workbook, including the name of the person
who made the change, when and where it was made, what data was deleted or
replaced, and how conflicts were resolved.) or copy it to another workbook.

~ How?
1. On the Tools menu, point to Track Changes, and then click Highlight
Changes.

2. In the When box, click All.
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Clear the Who and Where check boxes.

Select the List changes on a new sheet check box, and then click OK.

Do one or more of the following:

= To print the History worksheet, click Print = .
= To copy the history to another workbook, select the cells you want to

nhw

copy, click Copy =2 . switch to another workbook, click where you want

the copy to go, and click Paste .
Note You may also want to save or print the current version of the workbook,
because this history might not apply to later versions. For example, cell locations,
including row numbers, in the copied history may no longer be current.
3. On the Tools menu, click Share Workbook, and then click the Editing tab.
4. Make sure that you are the only person listed in the Who has this workbook open
now box.
5. Clear the Allow changes by more than one user at the same time check box.
If this check box is not available, you must unprotect the workbook before clearing the
check box.
+ How?
1. Click OK, point to Protection on the Tools menu, and then click Unprotect
Shared Workbook.
2. Enter the password if prompted, and then click OK.
3. On the Tools menu, click Share Workbook, and then click the Editing tab.
6. When prompted about the effects on other users, click Yes.
2. Set other types of protection if you want: Give specific users access to ranges, protect
worksheets, protect workbook elements, and set passwords for viewing and editing.
3. On the Tools menu, point to Protection, and then click Protect Shared Workbook or
Protect and Share Workbook.
Select the Sharing with track changes check box.
If you want to require other users to supply a password to turn off the change history (change
history: In a shared workbook, information that is maintained about changes made in past
editing sessions. The information includes the name of the person who made each change,
when the change was made, and what data was changed.) or remove the workbook from
shared use, type the password in the Password box, and then retype the password when
prompted.
6. If prompted, save the workbook.

vk

To Protect Worksheets

To prevent anyone from accidentally or deliberately changing, moving, or deleting important data, you
can protect certain worksheet (worksheet: The primary document that you use in Excel to store and
work with data. Also called a spreadsheet. A worksheet consists of cells that are organized into
columns and rows; a worksheet is always stored in a workbook.) or workbook elements, with or
without a password (password: A way to restrict access to a workbook, worksheet, or part of a
worksheet. Excel passwords can be up to 255 letters, numbers, spaces, and symbols. You must type
uppercase and lowercase letters correctly when you set and enter passwords.).

Important Worksheet or workbook element protection should not be confused with file security. It is
not meant to make your workbook more secure, and cannot protect it from users who have malicious
intent.

Worksheet elements

~ Protect worksheet elements from all users
1. Switch to the worksheet you want to protect.
2. Unlock any cells you want users to be able to change: Select each cell or range, click Cells on
the Format menu, click the Protection tab, and then clear the Locked check box.
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3. Hide any formulas that you don't want to be visible: Select the cells with the formulas, click
Cells on the Format menu, click the Protection tab, and then select the Hidden check box.

4. Unlock any graphic objects you want users to be able to change.
~ How?

You don't need to unlock buttons or controls for users to be able to click and use them. You can
unlock embedded charts, text boxes, and other objects created with the drawing tools that you
want users to be able to modify. To see which elements on a worksheet are graphic objects,
click Go To on the Edit menu, click Special, and then click Objects.

1. Hold down CTRL and click each object that you want to unlock.

2. On the Format menu, click the command for the object you selected: AutoShape,

Object, Text Box, Picture, Control, or WordArt.

3. Click the Protection tab.

4. Clear the Locked check box, and if present, clear the Lock text check box.

5. On the Tools menu, point to Protection, and then click Protect Sheet.

6. Type a password for the sheet.

Note The password is optional; however, if you don't supply a password, any user will be able
to unprotect the sheet and change the protected elements. Make sure you choose a password
you can remember, because if you lose the password, you cannot gain access to the protected
elements on the worksheet.

7. In the Allow all users of this worksheet to list, select the elements that you want users to
be able to change.

8. Click OK. If prompted, retype the password.

=+ Give specific users access to protected ranges
In order to give specific users access to ranges, your computer must be running Windows 2000 or later
and it must be on a domain.

1. On the Tools menu, point to Protection, and then click Allow Users to Edit Ranges. (This
command is available only when the worksheet is not protected.)

2. Click New.

3. In the Title box, type a title for the range you're granting access to.

4. 1In the Refers to cells box, type an equal sign (=), and then type a reference or select the
range.

5. In the Range password box, type a password to access the range.

The password is optional; if you don't supply a password, any user will be able to edit the cells.

6. Click Permissions, and then click Add.

7. Locate and select the users to whom you want to grant access. If you want to select multiple
users, hold down CTRL while you click the names.

8. Click OK twice. If prompted, retype the password.

9. Repeat the previous steps for each range for which you're granting access.

10. To retain a separate record of the ranges and users, select the Paste permissions
information into a new workbook check box in the Allow Users to Edit Ranges dialog
box.

11. Protect the worksheet: Click Protect Sheet in the Allow Users to Edit Ranges dialog box.

12. In the Protect Sheet dialog box, make sure the Protect worksheet and contents of locked
cells check box is selected, type a password for the worksheet, click OK, and then retype the
password to confirm.

Note A sheet password is required to prevent other users from being able to edit your designated
ranges. Make sure you choose a password you can remember, because if you lose the password, you
cannot gain access to the protected elements on the worksheet.

To understand the use of Track changes and its applications

Month | Type E liotl:

m r?g:'fm? Changed call B2 from
¥ B 'dairy to 'meat

Microsoft Excel can maintain and display information about how a worksheet was changed.
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Change tracking logs details about workbook changes each time you save a workbook. You can use
this history to understand what changes were made, and to accept or reject revisions.

This capability is particularly useful when several users edit a workbook. It's also useful when you
submit a workbook to reviewers for comments, and then want to merge input into one copy, selecting
which changes and comments to keep.

<+ How change tracking works

When you view the change history (change history: In a shared workbook, information that is
maintained about changes made in past editing sessions. The information includes the name of the
person who made each change, when the change was made, and what data was changed.), either
directly on the worksheet or on a separate History worksheet (History worksheet: A separate
worksheet that lists changes being tracked in a shared workbook, including the name of the person
who made the change, when and where it was made, what data was deleted or replaced, and how
conflicts were resolved.), you see who made each change, what type of change was made, when it
was made, what cells were affected, and what data was added or deleted.

Change tracking is available only in shared workbooks (shared workbook: A workbook set up to allow
multiple users on a network to view and make changes at the same time. Each user who saves the
workbook sees the changes made by other users.). In fact, when you turn on change tracking, the
workbook automatically becomes a shared workbook, although you don't have to store the workbook
where others can access it.

Change tracking differs from undo and backup Unlike the Undo button, you can't use the
change history to back out changes. However, the history includes a record of any deleted data, so
that you can copy lost data from the History worksheet back to the original cells. Because change
tracking isn't designed to help you return to earlier versions of a workbook, you should continue to
back up workbooks that have change tracking in effect.

Some types of changes aren't tracked Changes you make to cell contents are tracked, but other
changes, including formatting changes, are not. Some Excel features are unavailable in shared
workbooks and therefore aren't tracked.

History is kept only for a set interval When you turn on change tracking, the history is kept for
30 days. This limit keeps workbook size manageable. You can increase or decrease the number of days
of history to keep. If you want to keep the history indefinitely, you can specify a large humber of days,
or you can make periodic copies of the history information.

How history gets deleted Excel determines what history is kept by counting back from the current
date. Each time you close the workbook, Excel erases any part of the change history that is older than
the number of days in effect the last time the workbook was saved.

For example, if you're keeping 30 days of change history, and you open a workbook for the first time
in two months, you'll be able to view the history from two months ago. However, when you close this
workbook, the history from 31 to 60 days ago is deleted.

If you turn off change tracking or stop sharing the workbook, all change history is permanently
deleted.

<+ How to use change tracking

Excel provides the following ways to access and use the stored change history (change history: In a
shared workbook, information that is maintained about changes made in past editing sessions. The
information includes the name of the person who made each change, when the change was made, and
what data was changed.).

e Highlight onscreen Excel can outline changed areas in a different color for each user and
display the basic details as a comment when you rest the pointer over each changed cell.
Onscreen highlighting is useful when a workbook has only a few changes, or you want to see at
a glance what's changed.

e History worksheet Excel can display a separate worksheet that provides full details in list
form, so that you can filter (filter: To display only the rows in a list that satisfy the conditions
you specify. You use the AutoFilter command to display rows that match one or more specific
values, calculated values, or conditions.) to find changes of interest and print the information.
This History worksheet (History worksheet: A separate worksheet that lists changes being
tracked in a shared workbook, including the name of the person who made the change, when
and where it was made, what data was deleted or replaced, and how conflicts were resolved.) is
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useful when a workbook has lots of changes, or you want to investigate what happened in a
series of changes.

Review changes Excel can step you through the changes in sequence using a dialog box
that lets you decide whether to accept or reject each change. This method is useful when you're
evaluating and working with comments from others.

To make use of Effective sorting

+ Sort

rows in ascending order (A to Z, or 0 to 9) or descending order (Z to A, or 9 to 0)

1.

2.
Note
+ Sort

Click a cell in the column you would like to sort by.

Click Sort Ascending |Z*or Sort Descending [4*],

In a PivotTable report, Microsoft Excel uses the selected field to sort.
rows by two or three criteria (columns)

For best results, the range you sort should have column labels, or headers.

1.
2.
3.

q
[T
=
—~+
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7.
+ Sort

=

2
3.
4.
5
6.

Click a cell in the range you want to sort.

On the Data menu, click Sort.

In the Sort by and Then by boxes, click the columns you want to sort, starting with the most
important.

Select any other sort options you want, and then click OK.

rows by four criteria (columns)

Click a cell in the range you want to sort.

On the Data menu, click Sort.

In the first Sort by box click the column of least importance.

Click OK.

On the Data menu, click Sort.

In the Sort by and Then by boxes, click the other three columns you want to sort, starting
with the most important.

Select any other sort options you want, and then click OK.

rows by months or weekdays

Select a cell or range you want to sort.

On the Data menu, click Sort.

In the Sort by box, click the column you want to sort.

Click Options.

Under First key sort order, click the custom sort order you want, and then click OK.
Select any other sort options you want, and then click OK.

=~ Use your own data as the sort order

s
1.

WoOoNOURWN

10.
11.

Note

In a range of cells, enter the values you want to sort by, in the order you want them, from top
to bottom. For example:
Data
High
Medium
Low
Select the range.
On the Tools menu, click Options, and then click the Custom Lists tab.
Click Import, and then click OK.
Select a cell in the range you want to sort.
On the Data menu, click Sort.
In the Sort by box, click the column you want to sort.
Click Options.
Under First key sort order, click the custom list you created. For example, click High,
Medium, Low.
Click OK.
Select any other sort options you want, and then click OK.
You can't use a custom sort order in a Then by box. The custom sort order applies only to the

column specified in the Sort by box. To sort multiple columns by using a custom sort order, sort by
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each column separately. For example, to sort by columns A and B, in that order, first sort by column B,
and then specify the custom sort order by using the Sort Options dialog box. Next, sort the range by
column A.

+ Sort columns instead of rows
Most of the time, you sort rows. This procedure sorts the order of columns.
Click a cell in the range you want to sort.
On the Data menu, click Sort.
Click Options.
Under Orientation, click Sort left to right, and then click OK.
. In the Sort by and Then by boxes, click the rows you want to sort.
Note When you sort rows that are part of a worksheet outline, Microsoft Excel sorts the highest-level
groups (level 1) so that the detail rows or columns stay together, even if the detail rows or columns
are hidden.
+ Sort one column without affecting the others
Warning Be careful using this feature. Sorting by one column may produce results you don't want,
such as moving cells in that column away from other cells in the same row.

1. Click the column headito select the column you want to sort.

21

2. Click Sort Ascending or Sort Descending .
The Sort Warning dialog box is displayed.

3. Select Continue with the current selection.

4. Click Sort.

If the results are not what you want, click Undo .
Notes
e To exclude the first row of data from the sort, because it is a column header, on the Data
menu, click Sort, and then under My data range has, click Header row.
e To do a case-sensitive sort, on the Data menu click Sort, click Options, and then select Case
sensitive.
To find the top or bottom values in a range, such as top 10 grades or bottom 5 sales amounts, use
AutoFilter.

uhwhe
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Microsoft PowerPoint

Task1

Task1: Building a Mutually Rewarding Partnership

Welcome to the first task in PowerPoint. Here you will learn how to create basic presentations. Presentation
is a powerful mechanism to create impressive first impressions, and PowerPoint facilitates you in achieving
this. Let us now lay the foundation which will help you present your business plan to the Venture Capitalist.
You need to build a mutually trusting relationship with the VC in order to clinch a deal. Let us now practice
creating such a presentation. Recreate the presentation shown in the task.

task, to learn about:

Formatting: Color, font type, font size, font style etc.
Header and Footer

Bullets and Numbering

Drawing Toolbar: Auto shapes, Textboxes, etc
Design Template

Introduction to custom animation.

A e

Task?2

Creativity Session

Having established a relationship with the venture capitalist now let your creativity flow to come up with
novel ideas that can convince him to fund your ideas. Brainstorming is a good way to do some out of the
box thinking. The presentation shown in the task gives you tips on how to conduct a creativity session to
generate ideas. Create a similar presentation so that you know how to do brainstorming.

task, to learn about:

Slide transition

Master slide view

Insert picture — clipart, image
Action button

Drawing tool bar — lines, arrows
Hyperlink

Custom animation

Hide slide

Wash out

WO R WD =
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Task3:

Marketing plan

The way you sell your product to the venture capitalist really decides whether your project will be funded or
not. Using the right strategies to market your product is crucial. Learn here how a typical marketing
presentation should look like and create a similar one yourself.

task, to learn about:

10. Slide Layout

11. fill color

12. Inserting object, picture (effects), graph, word art
13. comments

14. Security — password

Task4

Business Presentation

Having learnt how to create presentations, build relationships, think creatively and market your product, you
are now ready to prepare your presentation to the venture capitalist. Practice your business plan presentation
by creating a similar presentation as shown in the task given.

task, to learn about:

15. Tables and Borders

16. Rehearse timings

17. Recording Narrations

18. Audio and video files

19. Inserting files, merging files, creating custom shows
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